Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 06-23-2010, 12:48 PM   #1
Registered: Jun 2003
Location: Brasil
Distribution: Slackware 13.1_64 Gold Edition
Posts: 205

Rep: Reputation: 32
Question Alsa / kde4 sound system messing with me!

Hello slackers!

Slackware 13.1_64, everything works like a charm,


every time my slackware boots up,
the sound system changes from one device to another.

So if I boot now, sound address is hw:1.0.
then if I reboot, the sound address becomes hw:0.0

It's really annoying, because every time I have to re-run xmms and mplayer setup to get any sound!

Also, if any program is playing audio (like xmms), other programs cannot play audio at the same time.

ie: if I'm listening music with xmms then I try opening some video with mplayer or firefox/flash, I get no audio on this video....

What's the deal with kde phonon? I thought it was supposed to be the new global sound system for kde4, like arts was for kde3. If so, why I can't choose phonon as my sound backend on xmms or mplayer setup?

Old 06-23-2010, 01:51 PM   #2
Senior Member
Registered: May 2008
Posts: 3,742

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
It may be that your soundcard is swapping device numbers in alsa.
You could try putting something like
options snd slots=snd-hda-intel,snd-usb-audio
in /etc/modprobe.d/sound.conf

The above ensures that my intel onboard audio is always hw:0.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is kde4 messing with my audio? Forgetamus Linux - Newbie 1 05-16-2008 10:15 PM
alsa sound system question tramni1980 Slackware 25 10-04-2006 04:46 AM
ALSA messing up atheist Linux - Software 2 10-24-2004 12:32 AM
Can I load both oss (kernel sound drivers) and alsa in 2 sound cared system? cmisip Linux - General 0 04-12-2003 02:27 AM

All times are GMT -5. The time now is 09:18 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration