LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-04-2004, 12:11 PM   #1
cccc828
Member
 
Registered: Feb 2004
Location: Austria
Distribution: Slackware
Posts: 95

Rep: Reputation: 15
ALSA, KDE 3.2, Kernel 2.6 and a wierd problem


Hello Forum ;-)

First of all I want to state, that I use Slackware for about 4 weeks now and I am more than happy with it. It is exactly the way I always wanted SuSE to be (used SuSE for around 9 month) and how Linux should (IMHO) be. The installation was very smooth and easy and upgrading KDE and installing a custom kernel was challenging, but after it was done I was just happy, wiser and a bit proud of myself ;-)
Long story short: I installed, learned and am happy :-)

However, there is a small problem with my soundchip I am not able to solve on my own:
The soundchip and mainboard in question is a C-Media CMI9739 on a MSI-Neo2 i865G board. The soundchip works without problems on my SuSE 8.2, and it also works under Slackware. My problem is, that whenever I start X (and KDE) I need to remove all soundmodules [1], start alsaconf and only then I have sound.
When I first noticed that behavior, I thought it might be aRts's fault, but now I uninstalled it and still the same problem. When I boot up and my rc.local[2] is executed, the settings of the alsamixer are 'correct', but as soon as I start X (and KDE) the settings are 'wrong' and I need to remove all modules, start alsaconf and only then my sound will work correctly.

Just in case no one knows what I can do, is there a way to execute my remove script and alsaconf in the background after KDE has started ?

If I can provide any further debugging help please just ask and I will post it.

Thank you for you help,

Severin Kacianka


[1] This is my shellscript to remove the modules:
-----
#!/bin/sh
/sbin/rmmod snd_pcm_oss
/sbin/rmmod snd_mixer_oss
/sbin/rmmod snd_intel8x0
/sbin/rmmod snd_ac97_codec
/sbin/rmmod snd_pcm
/sbin/rmmod snd_timer
/sbin/rmmod snd_page_alloc
/sbin/rmmod snd_mpu401_uart
/sbin/rmmod snd_rawmidi
/sbin/rmmod snd_seq_device
/sbin/rmmod snd
/sbin/rmmod soundcore
-----
[2] This my rc.local (from *sigh* As I am not allowed to post URLs yet:
http:<slash><slash>linuxtipps<dot>sourceforge<dot>net/show.php/en/tutorial/2.htm):
----
#!/bin/sh
/sbin/modprobe soundcore
/sbin/modprobe snd
/sbin/modprobe snd_seq_device
/sbin/modprobe snd_rawmidi
/sbin/modprobe snd_mpu401_uart
/sbin/modprobe snd_page_alloc
/sbin/modprobe snd_timer
/sbin/modprobe snd_pcm
/sbin/modprobe snd_ac97_codec
/sbin/modprobe snd_intel8x0
/sbin/modprobe snd_mixer_oss
/sbin/modprobe snd_pcm_oss
amixer set Master 90% unmute
amixer set PCM 90% unmute
----
 
Old 03-04-2004, 01:52 PM   #2
dbauder
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware-Current
Posts: 12

Rep: Reputation: 0
If I understand your problem correctly, when you launch KDE your mixer settings are getting changed to where you have no sound....

I know that by default KDE wants to load specific mixer settings at start up. You shouldn't have to remove any of your sound kernel modules. If you just fire alsamixer and change it back to the way you like, then go into the KDE control panel under Sound --> Mixer, there is a button to save current mixer settings. There is also a check box to load mixer settings at start up. You can probably just uncheck that box and that way KDE won't try to mess with your settings when it starts up. I know had a similar problem on my sound card (Gametheater XP cs46xx) KDE messes up the left/right balance to where I only get sound out of the right channel. I reset my mixer to my "right" settings then clicked the "Save Mixer" button in the control panel in KDE.

Hopefully that makes some sense for you.
 
Old 03-05-2004, 08:21 AM   #3
cccc828
Member
 
Registered: Feb 2004
Location: Austria
Distribution: Slackware
Posts: 95

Original Poster
Rep: Reputation: 15
Thank you. I will try to tweak my setting further, but thanks to your tipp I was able to activate the sound for xmms, although the KDE sound does not work. That is not really a problem, as I am not too keen on KDE's Beep's and Tuut's ;-)

Severin Kacianka
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa problem in kernel 2.6 sirdreis Debian 2 08-17-2005 10:27 PM
Wierd KDE desktop Problem - SOLVED DyeKid Slackware 1 08-15-2005 03:18 PM
ALSA-Problem with kernel 2.6.11.12 zorolowski Slackware 4 07-08-2005 01:18 PM
alsa problem KDE-3.3.1 micder Slackware 2 10-29-2004 09:02 AM
Suse 9.0 kernel 2.6.5 alsa and kde Quinn Linux - Distributions 11 05-17-2004 12:40 AM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration