LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-19-2008, 12:47 AM   #1
rixtr66
Member
 
Registered: Aug 2008
Location: Portland,ME.
Distribution: Slackware
Posts: 102

Rep: Reputation: 15
alsa conf didnt work?


after getting slack installed,i had no sound so i did alsacof.
it identified my card and did some stuff,but i still have no sound
what am i doing wrong?i also enabled alsa in the sound settings.
the card is an intel 82801h hd audio controller.
am i missing a step?
Rick
 
Old 08-19-2008, 02:32 AM   #2
sleekslack
Member
 
Registered: Mar 2008
Location: Bangkok, Thailand
Distribution: Slackware64 13.37
Posts: 34

Rep: Reputation: 16
After "alsaconf" identified your card, did you run "alsamixer" yet ?
 
Old 08-19-2008, 03:23 AM   #3
rixtr66
Member
 
Registered: Aug 2008
Location: Portland,ME.
Distribution: Slackware
Posts: 102

Original Poster
Rep: Reputation: 15
yes after i ran alsaconf i ran alsamixer,and alsactl store.
still dont know why its not working?i have a bios bug error
in the lilo conf.would that affect it?
 
Old 08-19-2008, 06:08 AM   #4
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Post the output of (as root)
Code:
# lspci | grep -i audio
This will tell us the sound card you are using
and
Code:
# lsmod | grep -i snd
This will tell us the modules loaded for your sound card. From that you (or someone here) can figure out if you have the right module(s) loaded for your sound card.
 
Old 08-19-2008, 06:56 AM   #5
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 215

Rep: Reputation: 64
Did you add yourself to the audio group?
Code:
gpasswd -a <user-name> audio
Sound doesn't work for the root user.
Configure sound as root, test in your regular user account.
 
Old 08-19-2008, 02:40 PM   #6
rixtr66
Member
 
Registered: Aug 2008
Location: Portland,ME.
Distribution: Slackware
Posts: 102

Original Poster
Rep: Reputation: 15
here are the outputs you requested;
oot@slack-1:~# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
root@slack-1:~#
and the other;
root@slack-1:~# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
root@slack-1:~# lsmod | grep -i snd
snd_seq_dummy 6660 0
snd_seq_oss 32896 0
snd_seq_midi_event 10112 1 snd_seq_oss
snd_seq 50256 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 10380 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 40352 0
snd_mixer_oss 17920 1 snd_pcm_oss
snd_hda_intel 289052 6
snd_pcm 72068 4 snd_pcm_oss,snd_hda_intel
snd_timer 22532 4 snd_seq,snd_pcm
snd_page_alloc 11528 2 snd_hda_intel,snd_pcm
snd_hwdep 10756 1 snd_hda_intel
snd 47716 17 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwd ep
soundcore 9824 1 snd
root@slack-1:~#
i tried passwd -a user audio,it had no effect.
hope this helps!
Rick
 
Old 08-19-2008, 03:11 PM   #7
Cuetzpallin
Member
 
Registered: Feb 2008
Location: Monterrey, MX
Distribution: Slackware since 3.4 and love it!!!
Posts: 162

Rep: Reputation: 31
Quote:
Originally Posted by wadsworth View Post
Did you add yourself to the audio group?
Code:
gpasswd -a <user-name> audio
Sound doesn't work for the root user.
Configure sound as root, test in your regular user account.
Currently I have sound on my root account... Is it a grown configuration?
 
Old 08-19-2008, 03:33 PM   #8
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 215

Rep: Reputation: 64
OK, on my Slackware 12.1 box root is a member of the audio group.
So I think sound should work fine for the root user.
(I distinctly remember that this was not always the case,
I've set up boxes where root only belonged to one group by default
- not the case for Slackware 12.1)

The OP should look at the output of
Code:
groups
and make sure they're a member of "audio"
 
Old 08-19-2008, 04:51 PM   #9
rixtr66
Member
 
Registered: Aug 2008
Location: Portland,ME.
Distribution: Slackware
Posts: 102

Original Poster
Rep: Reputation: 15
ok i made myself a member of groups and audio shows up.
but still no sound,i tried inmy regular account and theres no sound there either.maybe its the kernel?
Rick
 
Old 08-19-2008, 05:21 PM   #10
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
You have two posts with odd symptoms could they be related?

Did you do a full install? If you did, you may wish to re-install the system, as something may have had a problem when installing. An easy way is to mount the install DVD navigate to /slackware and run the command, as root,
Code:
upgradepkg --reinstall --install-new */*.tgz
You also mentioned a bios error, could you have a hardware problem, what is the error

It may be something simple with the audio, for example my sound card doesn't work unless I un-mute a certain channel in alsamixer.

In the other post are you trying to install the packages as root?

samac
 
Old 08-19-2008, 06:17 PM   #11
rixtr66
Member
 
Registered: Aug 2008
Location: Portland,ME.
Distribution: Slackware
Posts: 102

Original Poster
Rep: Reputation: 15
i am trying to install pakages as root.heres the lilo error;
Configuration NOT ok. LILO said:
LILO version 22.8 (test mode), Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2006 John Coffman
Released 19-Feb-2007 and compiled at 02:39:03 on Apr 1 2008.
Warning: LINEAR is deprecated in favor of LBA32: LINEAR specifies 24-bit
disk addresses below the 1024 cylinder limit; LBA32 specifies 32-bit disk
addresses not subject to cylinder limits on systems with EDD-BIOS extensions;
use LINEAR only if you are aware of its limitations.
Reading boot sector from /dev/sda
Warning: device 0x0805 exceeds 1024 cylinder limit.
Use of the 'lba32' option may help on newer (EDD-BIOS) systems.
Warning: LINEAR may generate cylinder# above 1023 at boot-time.
Fatal: Sector address 118004324 too large for LINEAR (try LBA32 instead).
is this something that has to do with the kernel?
Rick
 
Old 08-20-2008, 03:51 AM   #12
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
Your lilo error is nothing to do with the bios or the kernel it is the step in between the bootloader. Add lba32 below the line boot = /dev/sda in your /etc/lilo.conf and then run lilo.

Your sound card is showing up with configuration problems on all distributions, most of the responses involve modifying /etc/modprobe.d/sound by adding lines such as
Quote:
options snd slots=snd-hda-intel
alias snd-card-0 snd-hda-intel
samac
 
Old 08-20-2008, 04:09 AM   #13
rixtr66
Member
 
Registered: Aug 2008
Location: Portland,ME.
Distribution: Slackware
Posts: 102

Original Poster
Rep: Reputation: 15
samac,thanks for the information ill put it to good use!!
Rick
 
Old 08-20-2008, 04:20 AM   #14
rixtr66
Member
 
Registered: Aug 2008
Location: Portland,ME.
Distribution: Slackware
Posts: 102

Original Poster
Rep: Reputation: 15
ok i did what was posted by samac,and i recieved this message;

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (No such device)
The sound server will continue, using the null output device.
is this fixable?
Rick
 
Old 08-20-2008, 04:39 AM   #15
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
After another quick google I came up with this link Module-hda-intel

samac
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
automount didnt work PinRojas Debian 7 07-05-2005 11:29 AM
installign KDE 3.4 didnt work out so well joker20 Slackware 5 04-28-2005 03:17 AM
new compiled kernel 2.6.6 didnt work karfei00 Linux - General 4 06-09-2004 12:50 AM
Two network card in the same ip range, why didnt it work? geraldomanaus Linux - Networking 1 03-17-2004 10:03 PM
Debian Woody SB 5.1 prob....tried what I saw didnt work scheidel21 Debian 7 12-09-2003 11:11 PM


All times are GMT -5. The time now is 12:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration