LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ALSA and Slack 14 (I did configurate ALSA): no REC IN. (http://www.linuxquestions.org/questions/slackware-14/alsa-and-slack-14-i-did-configurate-alsa-no-rec-in-4175444034/)

stf92 01-03-2013 04:52 PM

ALSA and Slack 14 (I did configurate ALSA): no REC IN.
 
Hi:
I'm running Slackware 14.0. In view of the discontinuation of alsaconf, I created /etc/modprobe.d/alsa.conf with these lines:
Code:

 
    alias snd-card-0 snd_hda_intel
    alias sound-slot-0 snd_hda_intel
    options snd_hda_intel model=auto

Then,
Code:

# alsactl init
Found hardware: "HDA-Intel", "Realtek ALC887-VD", "HDA: ....."
Hardware is iniatilized using a generic method.

This made me possible to have audio output at the computer rear panal line output jacks.


The problem: I issue these three commands:
Code:

$ /usr/bin/amixer -c 0 sset Line,0 100%,100% mute  capt
$ /usr/bin/amixer -c 0 sset PCM,0 100%,100% unmute  nocap
$ arecord -r 8 -D plughw:0,0

Then I inject signal from my home pre-amplifier into the line input jacks. The result is ascii char 0x7f filling the screen. That is, arecord does not see the input signal. To verify, I do
Code:

$ arecord -f CD -D plughw:0,0 > some_file.wav
and play it (I repeat, aplay works fine), and can see I recorded nothing. It is possible that the ALSA configuration did not go so well after all. Now, the amixer settings above have always worked under slackware 12.0. What can possibly be the difference with 14.0?

EDIT: I consulted Sound-HOWTO and Alsa-sound in /usr/doc/Linux-HOWTOs but they are quite obsolete (dated year 2000).

stf92 01-04-2013 05:23 AM

The real I'm having with the sound chip Realtek ALC887 is in reality the fact that my machine is pci express, I think. I installed, after compilation, a package from Realtek for his ALC887, but the attempt was not successful. For the moment is all I can say. The machine is brand new.

kkady32 01-04-2013 05:32 AM

Use alsamixer and see with F4 when you have Capture enabled


All times are GMT -5. The time now is 09:25 PM.