LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-13-2007, 01:19 PM   #1
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
All clocks correct, except KDE taskbar clock


My BIOS had/has the correct time before and after the new time change the other day.
My OS also shows the correct time on my login AND when I go into the date/time settings. System logs are all timestamped correctly too, and file-times etc.
The clock in my KDE taskbar is 3 hours fast., if I right click the taskbar clock, I get the date and time settings thing, which shows the correct time, even though the clock I just right clicked is wrong.

My time-zone is set correctly, and saves as LOCAL time upon shutdown.

Any clues anyone? I searched LQ and got results having nothing at all to do with KDE or clocks (Am I using the search thing right? I usually get weird results) and google wasn't much help either.
 
Old 03-13-2007, 04:08 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Must be something about the KDE setting. I'm not familiar with KDE, but it must be somewhere in the control panel.
 
Old 03-13-2007, 04:18 PM   #3
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Funny thing is, the control panel shows the correct time!
The correct time is everywhere except in the taskbar applet.
<-- baffled..
 
Old 03-13-2007, 04:26 PM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
That's very strange ... I really don't know.
 
Old 03-13-2007, 06:22 PM   #5
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
It sounds like the kde clock is set to display the wrong time zone. If you have a wheel mouse try hovering over the clock and scroll the wheel.
also you could try deleting the config ~/.kde/share/config/clock_panelapplet
 
Old 03-13-2007, 07:10 PM   #6
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Hey, thanks for those suggestions. Unfortunately scrolling the mouse wheel over the applet did nothing, but I did delete the file you specified, and since nothing changed yet, I'm assuming any change that may occur will do so after I kill KDE and restart, so I will update again after I do that shortly.
 
Old 03-13-2007, 07:27 PM   #7
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
try this command as root

netdate time-a.nist.gov

and see if that fixes your prob.
 
Old 03-13-2007, 07:39 PM   #8
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
OK, logging out and back in to restart KDE, I see that having deleted the .config file for the clock_applet only caused my appearance settings for the clock to revert to default, but didn't change the time.
I tried netdate, and I suspect the request went out but my firewall blocked the returning data, because it returned 'netdate failed.'. Does netdate need the NTP port open? If so, there's the problem, or part of it..
Thanks again. I will do a test with the time port allowed by the firewall and see what happens.
SV

Last edited by GrapefruiTgirl; 03-13-2007 at 08:15 PM.
 
Old 03-13-2007, 08:19 PM   #9
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
OK, netdate repeatedl;y returns the following:
Quote:
netdate: send: Operation not permitted
Connection with udp to time-a.nist.gov failed.
Even though I have allowed outgoing and incoming TIME and NTP protocol packets via the firewall.
Last thing to check as far as 'netdate' goes, would be that my inetd.conf is fully commented out, but.. Well, I can't see that preventing me from sending the request.
I'm connected through a Windows machine by LAN, maybe therein lies the issue..
 
Old 03-14-2007, 12:38 PM   #10
deltabrown
LQ Newbie
 
Registered: Mar 2007
Location: Seattle Area
Distribution: Slackware
Posts: 7

Rep: Reputation: 0
Are you running nptdate as root? Check the man page, but I think a '-g' option will allow a 'big' correction. ntpd can not be running at the same time.

I don't think the firewall is the issue as you should have an 'ESTABLISHED-RELATED' connection with the time server if you initiate the connection from inside the firewall (assuming common firewall rules apply).

I don't know if this will fix the KDE issue but should allow you to sync-up your clock. Also check into `hwclock --systohc` to also sync the BIOS real-time-clock (I do this as a cron job on all servers).

One last suggestion is to verify the proper time zone files... should be /etc/localtime and also an informational link named /etc/localtime-copied-from -> /usr/share/zoneinfo/...something...
`ls -al /etc/local*` should do the trick.
 
Old 03-14-2007, 06:03 PM   #11
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Great I love when another new person shows up with suggestions!
@ Deltabrown, Yes, I ran 'netdate' as root, and incidentally I did check the man page while I was experimenting with it, but don't recall anything about the -g option. Iwill however check again shortly. I still am leaning towards that this is a KDE issue, and may have to pursue that angle, since all the system clocks including the KDE control panel show the correct time. It is the oddest thing.
- I agree with you on the firewall, too. And btw, I am not running the ntpd at all.
I will look into syncing the HWclock to system time, never know, 'something's' going to work eventually :P
My localtime file is correct, but I didn't know about the symlink you indicated there, I will look into that vey shortly too (like after supper I'm hungry right now!!)
Thanks very much for the input; I'll post the results soon!
Sasha
 
Old 03-14-2007, 06:29 PM   #12
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
UPDATE: Netdate (at least my installed version) has no -g option, only -l for limit and -v for version.

I have synced the hwclock --systohc, that command worked fine, but no change.
And finally, yup my localtime file is correct, and the symlink exists and is correctly linked.
pooey!! lol, well thanks for the suggestions! I will continue to experiment meanwhile, and if/when I determine exactly how to fix it, I'll share. Jeepers, am I the only person with this issue?
Hehehe
SV
 
Old 03-15-2007, 02:10 AM   #13
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
I had the problem to, but netdate worked for me, try this one...

netdate time-b.nist.gov
 
Old 03-15-2007, 05:37 AM   #14
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 58
Try using a totally different server for netdate, like one of the pool server for netdate, eg
Code:
netdate ca.pool.ntp.org
That way you will see the problem with netdate is on your side or if the server is blocking unauthorised requests. It is also better practice to use pool servers.

I'm afraid I have no clue about your original problem. Does it show up under fluxbox and XFCE?
 
Old 03-15-2007, 08:51 AM   #15
krussell
Member
 
Registered: Jul 2003
Location: dhaka
Distribution: Slackware 11 (fixed), MEPIS
Posts: 241

Rep: Reputation: 30
Hello GrapefruiTgirl :-)
I faced the same problem, and you don't have to use any command line for this as i understand.
Just right click the clock, check what "timezone" it is showing.
May be the timezone has +6 (or something) so it is showing the wrong value (sorry using a windows pc). Keep the timezone in your locality, then go to control center and also check for the timezone and make sure it is same as the clock, now in administrator mode correct the time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 07:19 PM
Xfce4 Taskbar Clock? RemusX2 Linux - Software 1 02-25-2006 11:09 PM
KDE taskbar applet drag bars disappeared, can't use taskbar now jon_k Linux - Software 1 05-08-2005 04:24 AM
Can't seem to reset KDE taskbar clock m_lp_ql_m Linux - General 10 02-12-2005 08:01 AM
Stupid KDE Clock Won't Stay Correct Uncreative Slackware 10 05-03-2003 06:59 AM


All times are GMT -5. The time now is 10:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration