LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   alien's KDE 4.6RC1 always run /usr/bin/strigidaemon after login... (http://www.linuxquestions.org/questions/slackware-14/aliens-kde-4-6rc1-always-run-usr-bin-strigidaemon-after-login-852299/)

grissiom 12-25-2010 01:28 AM

alien's KDE 4.6RC1 always run /usr/bin/strigidaemon after login...
 
I've disabled the strigi search and "semantic search" in KDE settings but no help. strigidaemon starts every time after I logged in and makes the system slow.(since it scanning the disk, there will a lot of disk IO)

Is there a way to get rid of this?

repo 12-25-2010 02:53 AM

Did you disabled the deamon in the settings?
Code:

system settings => sevicemanager
You could remove
Strigi-daemon, strigi-applet, strigi-client, strigi-plugins and strigi-utils.

Kind regards

mlangdn 12-25-2010 09:22 AM

Using Alien's latest packages, I went ahead and enabled nepomuck, strigi, and whatever else. The fans have been on high since about 8hrs and 20min ago. The system is barely usable since I got up, but the more I use it, the better it runs. Just makes the fans go harder. If this thing can't finish its index soon, I'm gonna shut it all down again.

Anybody know how long this takes on a first run? A week - 10 days?

grissiom 12-25-2010 09:33 AM

Quote:

Originally Posted by repo (Post 4202617)
Did you disabled the deamon in the settings?
Code:

system settings => sevicemanager
You could remove
Strigi-daemon, strigi-applet, strigi-client, strigi-plugins and strigi-utils.

Kind regards

No, there is only "Nepomuk Search Module" I found might be relative. But disable it doesn't help at all... I disabled strigi in every corner I can find and set the scan module to none. But it doesn't help too...

It eat up 50% CPU and ~200M RAM in about 10min. I have to shut it down by hand... ;(

grissiom 12-25-2010 09:36 AM

Quote:

Originally Posted by mlangdn (Post 4202781)
Anybody know how long this takes on a first run? A week - 10 days?

It depends on the setting of scan directories.

mlangdn 12-25-2010 09:58 AM

Screw it - I just killed all the indexing stuff. Now KDE runs as Bob intended.

repo 12-25-2010 10:30 AM

Did you looked at
http://alien.slackbook.org/blog/starting-with-kde-4-6/

Kind regards

grissiom 12-25-2010 09:07 PM

Quote:

Originally Posted by repo (Post 4202819)

Sure, I have. I even have comments in that post ;)

But there is no hint about how to stop strigi start every time after I log in...

grissiom 12-25-2010 09:08 PM

Quote:

Originally Posted by mlangdn (Post 4202801)
Screw it - I just killed all the indexing stuff. Now KDE runs as Bob intended.

Yup, I want to screw it as well but I don't know how to...

mlangdn 12-25-2010 11:09 PM

You can disable nepomuk in System Settings under Desktop search. That usually does all I need. Under System Administaration > Startup and Shutdown, there is some more things in there if you don't need them.

grissiom 12-26-2010 12:18 AM

@mlangdn

Yes, I did that. But it doesn't help... Do I need to cleanup the .kde folder _again_ ?... ;(

mlangdn 12-26-2010 01:44 AM

If you start with a new .kde folder, everything will be enabled again. You will have to go back and disable it all over again. I really have no clue why you aren't getting relief from just disabling nepomuk. I would run:

Code:

# top
and see what the culprit is.

ponce 12-26-2010 05:41 AM

I tried to
Code:

mv /usr/bin/strigidaemon /usr/bin/strigidaemon.old
an things got quieter (before I got segfaults in the logs). :)

then I removepkg'd akonadi and kdepim stuff don't work anymore, but things got even quieter. :D

grissiom 12-27-2010 07:37 PM

Good idea ;) I wanted to
Code:

ln -s /usr/bin/true /usr/bin/strigidaemon
but remove akonadi and kdepim might be better ;P


All times are GMT -5. The time now is 09:42 AM.