LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Alien Bob's VLC slackbuild fails on current (http://www.linuxquestions.org/questions/slackware-14/alien-bobs-vlc-slackbuild-fails-on-current-781414/)

Daedra 01-11-2010 03:26 AM

Alien Bob's VLC slackbuild fails on current
 
1 Attachment(s)
The error has to do with Twolame failing to compile. Which is strange to me because it compiled fine by itself with the slackbuilds build.

The error log is attached. If anyone has any ideas please let me know

Thanks.

Alien Bob 01-11-2010 08:43 AM

Apparently the new gcc has unearthed a bug in the twolame code.
This patch makes the compilation succeed again:

Code:

--- twolame-0.3.12/libtwolame/psycho_2.c.orig  2008-01-09 12:06:21.000000000 +0100
+++ twolame-0.3.12/libtwolame/psycho_2.c        2010-01-11 15:15:28.000000000 +0100
@@ -121,7 +121,7 @@
        window = mem->window;
        ath = mem->ath;
        numlines = mem->numlines;
-      partition = mem->numlines;
+      partition = mem->partition;
        s = mem->s;
        tmn = mem->tmn;
        fthr = mem->fthr;

Save this to a file "twolame-0.3.12_mem.diff"; then this is the patch to vlc.SlackBuild that you can use:
Code:

--- vlc.SlackBuild.orig  2009/12/11 09:08:17  1.139
+++ vlc.SlackBuild  2010/01/11 14:40:16
@@ -1574,10 +1574,13 @@
 {
 echo -e "**\n**  twolame  ...\n**"
 cd $TMP/tmp-$PRGNAM/twolame-$TWOLAME
-# For gcc 4.3:
+# Fix a bug that gets uncovered by gcc 4.4:
+cat $SRCDIR/twolame-0.3.12_mem.diff | patch -p1 --verbose 2>&1 \
+  | tee $OUTPUT/patch-${PRGNAM}_twolame.log
+# For gcc 4.3 and onwards:
 if [ $(gcc -dumpversion | tr -d  '.' |cut -c 1-2) -ge 43 ]; then
  cat $SRCDIR/twolame-0.3.12_gcc43.diff | patch -p1 --verbose 2>&1 \
-    | tee $OUTPUT/patch-${PRGNAM}_twolame.log
+    | tee -a $OUTPUT/patch-${PRGNAM}_twolame.log
 fi
 CFLAGS="$SLKCFLAGS" \
 CXXFLAGS="$SLKCFLAGS" \

Eric

Daedra 01-11-2010 04:38 PM

Thanks Eric :)

BroX 10-25-2010 02:39 PM

Should maybe start a new thread since it doesn't seem to be related to twolame, but I get the following error building either vlc-1.1.3 as per original slackbuild, or the current 1.1.4.1, on two different pc's, one a 32-bit Slackware-current laptop and on 64-bit current desktop.

Since googling didn't yield any lead (except this thread) I figure it must be me?

Last bit from the install per vlc.SlackBuild:

Code:

make[2]: Entering directory `/tmp/build/tmp-vlc/vlc-1.1.4.1/doc'
make[3]: Entering directory `/tmp/build/tmp-vlc/vlc-1.1.4.1/doc'
make[3]: Nothing to be done for `install-exec-am'.
test -z "/usr/doc/vlc-1.1.4.1" || /bin/mkdir -p "/tmp/build/package-vlc/usr/doc/vlc-1.1.4.1"
 /bin/ginstall -c -m 644 bugreport-howto.txt fortunes.txt intf-vcd.txt '/tmp/build/package-vlc/usr/doc/vlc-1.1.4.1'
test -z "/usr/man/man1" || /bin/mkdir -p "/tmp/build/package-vlc/usr/man/man1"
 /bin/ginstall -c -m 644 vlc.1 vlc-wrapper.1 vlc-config.1 '/tmp/build/package-vlc/usr/man/man1'
make[3]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.1.4.1/doc'
make[2]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.1.4.1/doc'
Making install in test
make[2]: Entering directory `/tmp/build/tmp-vlc/vlc-1.1.4.1/test'
make[3]: Entering directory `/tmp/build/tmp-vlc/vlc-1.1.4.1/test'
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.1.4.1/test'
make[2]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.1.4.1/test'
make[2]: Entering directory `/tmp/build/tmp-vlc/vlc-1.1.4.1'
make[3]: Entering directory `/tmp/build/tmp-vlc/vlc-1.1.4.1'
test -z "/usr/bin" || /bin/mkdir -p "/tmp/build/package-vlc/usr/bin"
 /bin/ginstall -c cvlc rvlc svlc qvlc '/tmp/build/package-vlc/usr/bin'
make[3]: Nothing to be done for `install-data-am'.
make[3]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.1.4.1'
make[2]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.1.4.1'
make[1]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.1.4.1'
mv: cannot stat `/tmp/build/package-vlc/usr/share/doc/vlc/*': No such file or directory
tar: ltablex.sty: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors


Alien Bob 10-25-2010 03:14 PM

Yes. Do not abuse an old thread for a new question.

Eric


All times are GMT -5. The time now is 07:56 AM.