LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Alien Bob's VLC fails to compile on newest current (http://www.linuxquestions.org/questions/slackware-14/alien-bobs-vlc-fails-to-compile-on-newest-current-793562/)

Daedra 03-06-2010 01:50 AM

Alien Bob's VLC fails to compile on newest current
 
looks like its related to libpng?

SOURCE -D_REENTRANT -D_THREAD_SAFE -DHAVE_RELEASE -D__LIBVLC__ -D__PLUGIN__ -DMODULE_NAME=png -DMODULE_NAME_IS_png -DMODULE_STRING=\"png\" -O4 -ffast-math -funroll-loops -mtune=athlon64 -fomit-frame-pointer -O2 -fPIC -I/tmp/build/tmp-vlc/vlcdeps/usr/include -Wall -Wextra -Wsign-compare -Wundef -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wvolatile-register-var -Werror-implicit-function-declaration -MT libpng_plugin_la-png.lo -MD -MP -MF .deps/libpng_plugin_la-png.Tpo -c png.c -fPIC -DPIC -o .libs/libpng_plugin_la-png.o
png.c: In function 'DecodeBlock':
png.c:158: error: 'png_infopp_NULL' undeclared (first use in this function)
png.c:158: error: (Each undeclared identifier is reported only once
png.c:158: error: for each function it appears in.)
make[5]: *** [libpng_plugin_la-png.lo] Error 1
make[5]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.5/modules/codec'
make[4]: *** [install-recursive] Error 1
make[4]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.5/modules/codec'
make[3]: *** [install] Error 2
make[3]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.5/modules/codec'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.5/modules'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/tmp/build/tmp-vlc/vlc-1.0.5'
make: *** [install] Error 2
mv: cannot stat `/tmp/build/package-vlc/usr/share/doc/vlc/*': No such file or directory

Slackware package maker, version 3.14159.

Franklin 03-06-2010 05:26 AM

I had a similar problem with digiKam 1.1.0

Downgrading libpng solved my problem. The version I used was libpng-1.2.37 from the previous -current.
This is on 32 bit and I can't say what I might have broken by downgrading. Digikam is a dealbreaker for me though.

I have done no research on this so I can't say if there's a better fix.

Steve

titopoquito 03-06-2010 05:53 AM

I got interested because of digikam myself and searched for that. There is a patch for vlc at least upstream that might help (not tested by myself):
http://git.videolan.org/?p=vlc.git;a...3e8a5f1a6aaeef

Daedra 03-06-2010 04:23 PM

Quote:

Originally Posted by titopoquito (Post 3888113)
I got interested because of digikam myself and searched for that. There is a patch for vlc at least upstream that might help (not tested by myself):
http://git.videolan.org/?p=vlc.git;a...3e8a5f1a6aaeef

that got it. thanks


All times are GMT -5. The time now is 01:19 PM.