LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-27-2010, 09:29 AM   #1
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 410

Rep: Reputation: 45
alien's vlc, -current and SBo's libva


I want to let vlc take use of my Intel HD's H264 hardware decoder. I installed libva with the SlackBuild from SBo. But Alien said libva should match the version vlc built with. So I decided rebuild vlc with new libva.

So I changed the LIBVA to 0.31.1-1+sds4 and added --enable-i965-driver to libva's configure. Building was fine but when I opened a flash video(h264) it said that I don't have h264 plugin and refused to continue. After I changed the version number back, vlc can play h264 again.

As a compromise, I comment out make_libva in the building phase. All things went well then. It won't consume too much CPU even when play large h264

So what is wrong with new libva? I noticed vlc 1.1.4 was released, but I think Alien is more qualified to bump the version. So I didn't change that.
 
Old 10-27-2010, 01:38 PM   #2
dolphin77
Member
 
Registered: May 2009
Posts: 200

Rep: Reputation: 54
http://www.linuxquestions.org/questi...ml#post4140565
 
Old 10-28-2010, 08:50 AM   #3
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 410

Original Poster
Rep: Reputation: 45
Yes, my question raises from there. I just don't know why new libva would disable h264 plugin of vlc. BTW, build vlc with new libva will have
Code:
usr/lib64/vlc/plugins/demux/libh264_plugin.la
usr/lib64/vlc/plugins/demux/libh264_plugin.so
usr/lib64/vlc/plugins/packetizer/libpacketizer_h264_plugin.la
usr/lib64/vlc/plugins/packetizer/libpacketizer_h264_plugin.so
but vlc just refuse to play h264... ;(
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Alien Bob's VLC slackbuild fails on current Daedra Slackware 4 10-25-2010 03:14 PM
how to Install kde 4.5 from alien's zrdc28 Slackware 43 09-08-2010 10:26 PM
[SOLVED] Alien Bob's VLC fails to compile on newest current Daedra Slackware 3 03-06-2010 04:23 PM
[SOLVED] Alien's 64bit wine, and World of Warcraft cwwilson721 Slackware 7 10-14-2009 08:59 PM
VLC error: VLC could not open the file "/usr/share/vlc/skins2/text.bmp". brjoon1021 Ubuntu 1 01-14-2009 10:48 PM


All times are GMT -5. The time now is 07:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration