LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-05-2011, 06:03 PM   #1
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Rep: Reputation: Disabled
alfa awus036h slackware current dhcpcd wont connect


Hi im wondering where the problem might be

slackware-current kernel 2.6.35.10-smp

for instance if i just want to connect to wep ap

i done
Code:
iwconfig wlan0 essid name key s:key 
dhcpcd wlan0

it says waiting for carrier and it just time out, im wondering why
i read somwhere that its not working good with slackware 13.1 can you please clarify? and if theres something else to configure please
thanks
 
Old 02-05-2011, 07:16 PM   #2
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 498

Rep: Reputation: 136Reputation: 136
Well, first you need to make sure of the current module. what is you chipset? Provide lsmod, lspci, iwconfig output.
 
Old 02-05-2011, 07:50 PM   #3
rob0
LQ Newbie
 
Registered: Sep 2009
Location: Alabama, USA
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
BTW, WEP is not very useful. Is there a reason why you want to use WEP? It's flawed by design and cannot be secured. All it does is slow down an attacker and discourage passers-by from connecting. You should consider buying a better router if yours does not support WPA.
 
Old 02-05-2011, 07:55 PM   #4
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 498

Rep: Reputation: 136Reputation: 136
I concur. WEP can be hacked in seconds these days. WPA2-AES is what I use at home with a Netgear WNDR3700. This router I highly recommend.
 
Old 02-05-2011, 08:17 PM   #5
rob0
LQ Newbie
 
Registered: Sep 2009
Location: Alabama, USA
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
I confess, I use Slackware as my router. An Atheros ath5k NIC and hostapd(8) built from a newer version variant of http://slackbuilds.org/repository/13.1/network/hostapd/ .
 
Old 02-05-2011, 08:32 PM   #6
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 498

Rep: Reputation: 136Reputation: 136
Sweet. But do you have 2.4GHz and 5 GHz dual band with separate ssids, with extra guest ssid outside the firewall? PLUS, NAS capability and 4 port gigbit router?

Sorry, matters, I am drifting OT - been one of those days. Do post again and we will try to help.
 
Old 02-06-2011, 12:00 AM   #7
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
everything works, the signal was low, im now connected through it and it works perfectly. thanks

Last edited by matters; 02-06-2011 at 12:28 AM.
 
Old 02-23-2011, 10:29 PM   #8
porfirio1830
LQ Newbie
 
Registered: Sep 2010
Posts: 1

Rep: Reputation: 0
dhcpcd wlan0 timed out

I have the same problem, slackware 13.1 doesn't works with dhcpcd. I've searched
for weeks about some solution without results. I updated dhcpcd but it sends me the
same message. I installed wicd with the last two versions and they send the message
"bad password". I'm going to come back to my previous version of slackware. It's a
shame because I like the new one. I hope developers solve the bug soon.
 
Old 02-24-2011, 07:35 AM   #9
rob0
LQ Newbie
 
Registered: Sep 2009
Location: Alabama, USA
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
There is probably no bug, but if there is, it probably has nothing to do with dhcpcd. You have to be methodical and scientific if you hope to solve problems like this. Saying it doesn't work and calling it a "bug" accomplishes nothing. (Nothing positive, that is.)

First look at the device and its driver; read about possible issues at their linuxwireless.org pages. Check your iwconfig(8) output. Is it associated with the access point?

wicd is just a frontend. It's a nice one to have for wireless with WEP/WPA, but when there are problems, you still have to look behind it to see what's going on.
 
Old 02-25-2011, 06:13 AM   #10
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
To make to work to connect to others AP one must do

Code:
iwconfig wlan0 rate 1M auto
before connecting with wicd on access point of their choice, some time 5.5M works aswell with that you can use current kernel and can connect without getting disconnected . hopefully the patch will be provided any time soon, if you still dont like it just reverse to 2.6.29.6 kernel untill patch will be provided.

Last edited by matters; 03-13-2011 at 05:47 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALFA AWUS036H n compatability? t0rtr3ss Linux - Hardware 0 12-23-2010 04:26 AM
Alfa AWUS036h rtl8187 adapter not working on Slackware 13.1 arpanetguru Slackware 6 10-16-2010 03:14 PM
slackware 12.1 wpa_sipplicant wont connect. Zebis Linux - Wireless Networking 6 12-15-2008 06:24 PM
slackware 12.1 wpa_sipplicant wont connect. Zebis Linux - Wireless Networking 1 12-10-2008 01:58 PM
Neverwinter Nights wont work in im Slackware current b3rx Linux - Games 4 04-05-2006 01:11 PM


All times are GMT -5. The time now is 03:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration