LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-26-2006, 05:28 PM   #1
RedNovember
Member
 
Registered: Oct 2005
Distribution: Debian etch
Posts: 103

Rep: Reputation: 15
After swaret --upgrade -a, amaroK engines broken - Slack 10.2


I recently did a swaret --upgrade -a. Now when I start amaroK it gives me one error message per engine. I should note that Slackware tells me that the sound driver could not be initialized on startup, and KMix has a little X icon over it in the systray. There is no mixer to select.

Code:
amaroK could not initialize the helix-engine. Please check the paths in "amaroK Settings" -> "Engine"
Code:
KLibLoader could not load the plugin:
libamarok_gstengine_plugin
Error message:
libgstreamer-0.8.so.1: cannot open shared object file: No such file or directory
Code:
xine was unable to initialize any audio-drivers.
Code:
KLibLoader could not load the plugin:
libamarok_artsengine_plugin
Error message:
/opt/kde/lib/libamarokarts.so: undefined symbol: _ZTv0_n32_N4Arts16SynthModule_stub11autoSuspendEv
Terminal output in next post.

Help appreciated,
RedNovember
 
Old 02-26-2006, 05:29 PM   #2
RedNovember
Member
 
Registered: Oct 2005
Distribution: Debian etch
Posts: 103

Original Poster
Rep: Reputation: 15
From Terminal:
Code:
rednovember@slackware:~$ amarok
amaroK: [Loader] Starting amarokapp..
amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarok: BEGIN: App::App()
amarok:   BEGIN: void App::fixHyperThreading()
amarok:     Fix not enabled
amarok:   END__: void App::fixHyperThreading() - Took 0.0011s
amarok:   BEGIN: EngineBase* EngineController::loadEngine(const QString&)
amarok:     [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] != 'void-engine' and [X-KDE-amaroK-rank] > 0
amarok:     [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == 'void-engine' and [X-KDE-amaroK-rank] > 0
amarok:     [PluginManager] Trying to load: libamarok_void-engine_plugin
amarok:
amarok:     PluginManager Service Info:
amarok:     ---------------------------
amarok:     name                          : <no engine>
amarok:     library                       : libamarok_void-engine_plugin
amarok:     desktopEntryPath              : amarok_void-engine_plugin.desktop
amarok:     X-KDE-amaroK-plugintype       : engine
amarok:     X-KDE-amaroK-name             : void-engine
amarok:     X-KDE-amaroK-authors          : (Max Howell,Mark Kretschmann)
amarok:     X-KDE-amaroK-rank             : 1
amarok:     X-KDE-amaroK-version          : 1
amarok:     X-KDE-amaroK-framework-version: 15
amarok:
amarok:   END__: EngineBase* EngineController::loadEngine(const QString&) - Took 0.021s
amarok:   BEGIN: void PlaylistWindow::init()
amarok:     BEGIN: CollectionDB::CollectionDB(bool)
amarok:       [CollectionDB] Available db connections: 1
amarok:       [CollectionDB] Available db connections: 5
amarok:     END__: CollectionDB::CollectionDB(bool) - Took 0.012s
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout for PlaylistWindow/PlaylistWindow
amarok:     BEGIN: Creating browsers. Please report long start times!
amarok:       BEGIN: ContextBrowser
amarok:         [void ContextBrowser::setStyleSheet()]
amarok:         BEGIN: amaroK::Color::Color(const QColor&)
amarok:           [ContextBrowser] Initial Color Properties: s:107 v:178
amarok:           [ContextBrowser] Unapplied Contrast: 53
amarok:           [ContextBrowser] Final Colour Properties: s:30 v:231
amarok:         END__: amaroK::Color::Color(const QColor&) - Took 0.00082s
amarok:       END__: ContextBrowser - Took 0.086s
amarok:       BEGIN: CollectionBrowser
amarok:         [CollectionView::CollectionView(CollectionBrowser*)]
amarok:         [void CollectionView::renderView()]
amarok:       END__: CollectionBrowser - Took 0.062s
amarok:       BEGIN: PlaylistBrowser
amarok:       END__: PlaylistBrowser - Took 0.13s
amarok:       BEGIN: MediaBrowser
amarok:       END__: MediaBrowser - Took 0.039s
amarok:       BEGIN: FileBrowser
amarok:         [StatusBar] KDE::SqueezedTextLabel, mainTextLabel: 18: 0
amarok:         [StatusBar] QHBox, progressBox: 26: 0
amarok:         [StatusBar] QLabel, unnamed: 18: 0
amarok:         [StatusBar] QWidget, positionBox: 26: 0
amarok:         [StatusBar] QWidget, unnamed: 16: 0
amarok:       END__: FileBrowser - Took 0.087s
amarok:     END__: Creating browsers. Please report long start times! - Took 0.41s
amarok:   END__: void PlaylistWindow::init() - Took 0.5s
amarok:   BEGIN: UrlLoader
amarok:     BEGIN: UrlLoader::UrlLoader(const KURL::List&, QListViewItem*, bool)
amarok:       [KDE::ProgressBar::ProgressBar(QWidget*, QLabel*)]
amarok:       [StatusBar] Creating timer for: 1updateProgressAppearance()
amarok:     END__: UrlLoader::UrlLoader(const KURL::List&, QListViewItem*, bool) - Took 0.0095s
amarok:     BEGIN: void App::applySettings(bool)
amarok:       BEGIN: void App::applyColorScheme()
amarok:       END__: void App::applyColorScheme() - Took 0.00099s
amarok:       BEGIN: virtual void PlayerWidget::engineStateChanged(Engine::State, Engine::State)
amarok:       END__: virtual void PlayerWidget::engineStateChanged(Engine::State, Engine::State) - Took 0.0021s
amarok:       [void ContextBrowser::setStyleSheet()]
amarok:       BEGIN: amaroK::Color::Color(const QColor&)
amarok:         [ContextBrowser] Initial Color Properties: s:107 v:178
amarok:         [ContextBrowser] Unapplied Contrast: 53
amarok:         [ContextBrowser] Final Colour Properties: s:30 v:231
amarok:       END__: amaroK::Color::Color(const QColor&) - Took 0.00081s
amarok:       [Scrobbler] Handshake url: http://post.audioscrobbler.com/?hs=true&p=1.1&c=ark&v=0.1&u=RedNovember
amarok:       BEGIN: EngineBase* EngineController::loadEngine()
amarok:         BEGIN: EngineBase* EngineController::loadEngine(const QString&)
amarok:           [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] != 'helix-engine' and [X-KDE-amaroK-rank] > 0
amarok:           [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == 'helix-engine' and [X-KDE-amaroK-rank] > 0
amarok:           [PluginManager] Trying to load: libamarok_helixengine_plugin
amarok:
amarok:           PluginManager Service Info:
amarok:           ---------------------------
amarok:           name                          : Helix Engine
amarok:           library                       : libamarok_helixengine_plugin
amarok:           desktopEntryPath              : amarok_helixengine_plugin.desktop
amarok:           X-KDE-amaroK-plugintype       : engine
amarok:           X-KDE-amaroK-name             : helix-engine
amarok:           X-KDE-amaroK-authors          : (Paul Cifarelli)
amarok:           X-KDE-amaroK-rank             : 75
amarok:           X-KDE-amaroK-version          : 1
amarok:           X-KDE-amaroK-framework-version: 15
amarok:
amarok:           Initializing HelixEngine
amarok:           [ThreadWeaver] Job completed: UrlLoader. Jobs pending: 0
amarok:         END__: UrlLoader - Took 0.47s
amarok:         [StatusBar] Creating timer for: 1hideMainProgressBar()
amarok:         [virtual KDE::ProgressBar::~ProgressBar()]
amarok:         [StatusBar] 1updateProgressAppearance()
amarok:         [Scrobbler] Handshake result parsed: challenge=4C344444F7479224F5F65B78CD06302F, submitUrl=http://62.216.251.205:80/protocol_1.1
amarok:         [StatusBar] 1hideMainProgressBar()
amaroK: [Loader] amaroK is taking a long time to load! Perhaps something has gone wrong?
amarok:       END__: EngineBase* EngineController::loadEngine(const QString&) - Took 49s
amarok:     END__: EngineBase* EngineController::loadEngine() - Took 49s
amarok:   END__: void App::applySettings(bool) - Took 49s
amarok: END__: App::App() - Took 50s
rednovember@slackware:~$ QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
amarok: [virtual void BrowserBar::polish()]
amarok: [void App::slotConfigAmarok(const QCString&)]
QWidget::setMinimumSize: The smallest allowed size is (0,0)
amarok: [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-rank] > 0
amarok: Starting HelixConfigDialog
amarok: [helix-engine] NPLUGINS: 0
amarok: [void CollectionDB::createTables(DbConnection*)]
amarok: [CollectionDB] [ERROR!] [virtual QStringList SqliteConnection::query(const QString&)]  sqlite3_compile error:
amarok: [CollectionDB] [ERROR!] table amazon already exists
amarok: [CollectionDB] [ERROR!] on query: CREATE TABLE amazon ( asin VARCHAR(20), locale VARCHAR(2), filename VARCHAR(33), refetchdate INTEGER );
amarok: [void CollectionDB::dropTables(DbConnection*)]
amarok: BEGIN: virtual void CollectionDB::customEvent(QCustomEvent*)
amarok: END__: virtual void CollectionDB::customEvent(QCustomEvent*) - Took 0.00028s
amarok: [KDE::ProgressBar::ProgressBar(QWidget*, QLabel*)]
amarok: [StatusBar] 1updateProgressAppearance()
amarok: BEGIN: virtual void CollectionDB::customEvent(QCustomEvent*)
amarok:   [CollectionDB] Event from IncrementalCollectionReader received.
amarok:   BEGIN: void CollectionView::scanDone(bool)
amarok:     [void CollectionView::renderView()]
amarok:   END__: void CollectionView::scanDone(bool) - Took 0.03s
amarok: END__: virtual void CollectionDB::customEvent(QCustomEvent*) - Took 0.038s
amarok: [ThreadWeaver] Job completed: CollectionReader. Jobs pending: 0
amarok: [virtual KDE::ProgressBar::~ProgressBar()]
amarok: [StatusBar] 1hideMainProgressBar()
amarok: [helix-engine] SAVING in HelixConfigDialog
amarok: BEGIN: void App::applySettings(bool)
amarok:   BEGIN: void App::applyColorScheme()
amarok:   END__: void App::applyColorScheme() - Took 0.0014s
amarok:   [void ContextBrowser::setStyleSheet()]
amarok:   BEGIN: amaroK::Color::Color(const QColor&)
amarok:     [ContextBrowser] Initial Color Properties: s:107 v:178
amarok:     [ContextBrowser] Unapplied Contrast: 53
amarok:     [ContextBrowser] Final Colour Properties: s:30 v:231
amarok:   END__: amaroK::Color::Color(const QColor&) - Took 0.00067s
amarok:   BEGIN: EngineBase* EngineController::loadEngine()
amarok:     [static void PluginManager::unload(amaroK::Plugin*)]
amarok:     [PluginManager] Unloading library: libamarok_helixengine_plugin
amarok:     BEGIN: void EngineSubject::stateChangedNotify(Engine::State)
amarok:       BEGIN: virtual void ContextBrowser::engineStateChanged(Engine::State, Engine::State)
amarok:       END__: virtual void ContextBrowser::engineStateChanged(Engine::State, Engine::State) - Took 0.00047s
amarok:       BEGIN: virtual void PlayerWidget::engineStateChanged(Engine::State, Engine::State)
amarok:       END__: virtual void PlayerWidget::engineStateChanged(Engine::State, Engine::State) - Took 0.00043s
amarok:     END__: void EngineSubject::stateChangedNotify(Engine::State) - Took 0.0043s
amarok:     BEGIN: EngineBase* EngineController::loadEngine(const QString&)
amarok:       [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] != 'gst-engine' and [X-KDE-amaroK-rank] > 0
amarok:       [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == 'gst-engine' and [X-KDE-amaroK-rank] > 0
amarok:       [PluginManager] Trying to load: libamarok_gstengine_plugin
amarok:       [PluginManager] Trying to load: libamarok_xine-engine
amarok:
amarok:       PluginManager Service Info:
amarok:       ---------------------------
amarok:       name                          : xine Engine
amarok:       library                       : libamarok_xine-engine
amarok:       desktopEntryPath              : amarok_xine-engine.desktop
amarok:       X-KDE-amaroK-plugintype       : engine
amarok:       X-KDE-amaroK-name             : xine-engine
amarok:       X-KDE-amaroK-authors          : (Max Howell)
amarok:       X-KDE-amaroK-rank             : 255
amarok:       X-KDE-amaroK-version          : 1
amarok:       X-KDE-amaroK-framework-version: 15
amarok:
amarok:       BEGIN: virtual bool XineEngine::init()
amarok:         [xine-engine] 'Bringing joy to small mexican gerbils, a few weeks at a time.'
amarok:         [xine-engine] w00t/home/rednovember/.kde/share/apps/amarok/xine-config
ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3962:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM default
amarok:       END__: virtual bool XineEngine::init() - Took 13s
amarok:       [controller] [WARNING!] Could not init() an engine
amarok:       [PluginManager] Trying to load: libamarok_helixengine_plugin
amarok:
amarok:       PluginManager Service Info:
amarok:       ---------------------------
amarok:       name                          : Helix Engine
amarok:       library                       : libamarok_helixengine_plugin
amarok:       desktopEntryPath              : amarok_helixengine_plugin.desktop
amarok:       X-KDE-amaroK-plugintype       : engine
amarok:       X-KDE-amaroK-name             : helix-engine
amarok:       X-KDE-amaroK-authors          : (Paul Cifarelli)
amarok:       X-KDE-amaroK-rank             : 75
amarok:       X-KDE-amaroK-version          : 1
amarok:       X-KDE-amaroK-framework-version: 15
amarok:
amarok:       Initializing HelixEngine
amarok:     END__: EngineBase* EngineController::loadEngine(const QString&) - Took 31s
amarok:   END__: EngineBase* EngineController::loadEngine() - Took 31s
amarok: END__: void App::applySettings(bool) - Took 31s
amarok: [helix-engine] DELETING HelixConfigDialog
amarok: Starting HelixConfigDialog
amarok: [helix-engine] NPLUGINS: 0
amarok: [helix-engine] SAVING in HelixConfigDialog
amarok: BEGIN: void App::applySettings(bool)
amarok:   BEGIN: void App::applyColorScheme()
amarok:   END__: void App::applyColorScheme() - Took 0.0015s
amarok:   [void ContextBrowser::setStyleSheet()]
amarok:   BEGIN: amaroK::Color::Color(const QColor&)
amarok:     [ContextBrowser] Initial Color Properties: s:107 v:178
amarok:     [ContextBrowser] Unapplied Contrast: 53
amarok:     [ContextBrowser] Final Colour Properties: s:30 v:231
amarok:   END__: amaroK::Color::Color(const QColor&) - Took 0.00069s
amarok:   BEGIN: EngineBase* EngineController::loadEngine()
amarok:     [static void PluginManager::unload(amaroK::Plugin*)]
amarok:     [PluginManager] Unloading library: libamarok_helixengine_plugin
amarok:     BEGIN: void EngineSubject::stateChangedNotify(Engine::State)
amarok:       BEGIN: virtual void ContextBrowser::engineStateChanged(Engine::State, Engine::State)
amarok:       END__: virtual void ContextBrowser::engineStateChanged(Engine::State, Engine::State) - Took 0.00037s
amarok:       BEGIN: virtual void PlayerWidget::engineStateChanged(Engine::State, Engine::State)
amarok:       END__: virtual void PlayerWidget::engineStateChanged(Engine::State, Engine::State) - Took 0.00043s
amarok:     END__: void EngineSubject::stateChangedNotify(Engine::State) - Took 0.0037s
amarok:     BEGIN: EngineBase* EngineController::loadEngine(const QString&)
amarok:       [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] != 'arts-engine' and [X-KDE-amaroK-rank] > 0
amarok:       [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == 'arts-engine' and [X-KDE-amaroK-rank] > 0
amarok:       [PluginManager] Trying to load: libamarok_artsengine_plugin
amarok:       [void CollectionDB::createTables(DbConnection*)]
amarok:       [CollectionDB] [ERROR!] [virtual QStringList SqliteConnection::query(const QString&)]  sqlite3_compile error:
amarok:       [CollectionDB] [ERROR!] table amazon already exists
amarok:       [CollectionDB] [ERROR!] on query: CREATE TABLE amazon ( asin VARCHAR(20), locale VARCHAR(2), filename VARCHAR(33), refetchdate INTEGER );
amarok:       BEGIN: virtual void CollectionDB::customEvent(QCustomEvent*)
amarok:       END__: virtual void CollectionDB::customEvent(QCustomEvent*) - Took 7.6e-05s
amarok:       [KDE::ProgressBar::ProgressBar(QWidget*, QLabel*)]
amarok:       [StatusBar] 1updateProgressAppearance()
amarok:       [void CollectionDB::dropTables(DbConnection*)]
amarok:       BEGIN: virtual void CollectionDB::customEvent(QCustomEvent*)
amarok:         [CollectionDB] Event from IncrementalCollectionReader received.
amarok:         BEGIN: void CollectionView::scanDone(bool)
amarok:           [void CollectionView::renderView()]
amarok:         END__: void CollectionView::scanDone(bool) - Took 0.028s
amarok:       END__: virtual void CollectionDB::customEvent(QCustomEvent*) - Took 0.034s
amarok:       [ThreadWeaver] Job completed: CollectionReader. Jobs pending: 0
amarok:       [virtual KDE::ProgressBar::~ProgressBar()]
amarok:       [PluginManager] Trying to load: libamarok_xine-engine
amarok:
amarok:       PluginManager Service Info:
amarok:       ---------------------------
amarok:       name                          : xine Engine
amarok:       library                       : libamarok_xine-engine
amarok:       desktopEntryPath              : amarok_xine-engine.desktop
amarok:       X-KDE-amaroK-plugintype       : engine
amarok:       X-KDE-amaroK-name             : xine-engine
amarok:       X-KDE-amaroK-authors          : (Max Howell)
amarok:       X-KDE-amaroK-rank             : 255
amarok:       X-KDE-amaroK-version          : 1
amarok:       X-KDE-amaroK-framework-version: 15
amarok:
amarok:       BEGIN: virtual bool XineEngine::init()
amarok:         [xine-engine] 'Bringing joy to small mexican gerbils, a few weeks at a time.'
amarok:         [xine-engine] w00t/home/rednovember/.kde/share/apps/amarok/xine-config
amarok:         [StatusBar] 1hideMainProgressBar()
ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3962:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM default
amarok:       END__: virtual bool XineEngine::init() - Took 1.5s
amarok:       [controller] [WARNING!] Could not init() an engine
amarok:       [PluginManager] Trying to load: libamarok_gstengine_plugin
amarok:       [PluginManager] Trying to load: libamarok_helixengine_plugin
amarok:
amarok:       PluginManager Service Info:
amarok:       ---------------------------
amarok:       name                          : Helix Engine
amarok:       library                       : libamarok_helixengine_plugin
amarok:       desktopEntryPath              : amarok_helixengine_plugin.desktop
amarok:       X-KDE-amaroK-plugintype       : engine
amarok:       X-KDE-amaroK-name             : helix-engine
amarok:       X-KDE-amaroK-authors          : (Paul Cifarelli)
amarok:       X-KDE-amaroK-rank             : 75
amarok:       X-KDE-amaroK-version          : 1
amarok:       X-KDE-amaroK-framework-version: 15
amarok:
amarok:       Initializing HelixEngine
amarok:     END__: EngineBase* EngineController::loadEngine(const QString&) - Took 24s
amarok:   END__: EngineBase* EngineController::loadEngine() - Took 24s
amarok: END__: void App::applySettings(bool) - Took 24s
amarok: [helix-engine] DELETING HelixConfigDialog
amarok: Starting HelixConfigDialog
amarok: [helix-engine] NPLUGINS: 0
amarok: [helix-engine] SAVING in HelixConfigDialog
amarok: BEGIN: void App::applySettings(bool)
amarok:   BEGIN: void App::applyColorScheme()
amarok:   END__: void App::applyColorScheme() - Took 0.0014s
amarok:   [void ContextBrowser::setStyleSheet()]
amarok:   BEGIN: amaroK::Color::Color(const QColor&)
amarok:     [ContextBrowser] Initial Color Properties: s:107 v:178
amarok:     [ContextBrowser] Unapplied Contrast: 53
amarok:     [ContextBrowser] Final Colour Properties: s:30 v:231
amarok:   END__: amaroK::Color::Color(const QColor&) - Took 0.00012s
amarok:   BEGIN: EngineBase* EngineController::loadEngine()
amarok:     [static void PluginManager::unload(amaroK::Plugin*)]
amarok:     [PluginManager] Unloading library: libamarok_helixengine_plugin
amarok:     BEGIN: void EngineSubject::stateChangedNotify(Engine::State)
amarok:       BEGIN: virtual void ContextBrowser::engineStateChanged(Engine::State, Engine::State)
amarok:       END__: virtual void ContextBrowser::engineStateChanged(Engine::State, Engine::State) - Took 8.9e-05s
amarok:       BEGIN: virtual void PlayerWidget::engineStateChanged(Engine::State, Engine::State)
amarok:       END__: virtual void PlayerWidget::engineStateChanged(Engine::State, Engine::State) - Took 0.00022s
amarok:     END__: void EngineSubject::stateChangedNotify(Engine::State) - Took 0.0047s
amarok:     BEGIN: EngineBase* EngineController::loadEngine(const QString&)
amarok:       [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] != 'arts-engine' and [X-KDE-amaroK-rank] > 0
amarok:       [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 15 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == 'arts-engine' and [X-KDE-amaroK-rank] > 0
amarok:       [PluginManager] Trying to load: libamarok_artsengine_plugin
amarok:       [helix-engine] DELETING HelixConfigDialog
amarok:       [PluginManager] Trying to load: libamarok_xine-engine
amarok:
amarok:       PluginManager Service Info:
amarok:       ---------------------------
amarok:       name                          : xine Engine
amarok:       library                       : libamarok_xine-engine
amarok:       desktopEntryPath              : amarok_xine-engine.desktop
amarok:       X-KDE-amaroK-plugintype       : engine
amarok:       X-KDE-amaroK-name             : xine-engine
amarok:       X-KDE-amaroK-authors          : (Max Howell)
amarok:       X-KDE-amaroK-rank             : 255
amarok:       X-KDE-amaroK-version          : 1
amarok:       X-KDE-amaroK-framework-version: 15
amarok:
amarok:       BEGIN: virtual bool XineEngine::init()
amarok:         [xine-engine] 'Bringing joy to small mexican gerbils, a few weeks at a time.'
amarok:         [xine-engine] w00t/home/rednovember/.kde/share/apps/amarok/xine-config
ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3962:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM default
amarok:       END__: virtual bool XineEngine::init() - Took 1.3s
amarok:       [controller] [WARNING!] Could not init() an engine
amarok:       [PluginManager] Trying to load: libamarok_gstengine_plugin
amarok:       [PluginManager] Trying to load: libamarok_helixengine_plugin
amarok:
amarok:       PluginManager Service Info:
amarok:       ---------------------------
amarok:       name                          : Helix Engine
amarok:       library                       : libamarok_helixengine_plugin
amarok:       desktopEntryPath              : amarok_helixengine_plugin.desktop
amarok:       X-KDE-amaroK-plugintype       : engine
amarok:       X-KDE-amaroK-name             : helix-engine
amarok:       X-KDE-amaroK-authors          : (Paul Cifarelli)
amarok:       X-KDE-amaroK-rank             : 75
amarok:       X-KDE-amaroK-version          : 1
amarok:       X-KDE-amaroK-framework-version: 15
amarok:
amarok:       Initializing HelixEngine
amarok:     END__: EngineBase* EngineController::loadEngine(const QString&) - Took 6.9s
amarok:   END__: EngineBase* EngineController::loadEngine() - Took 7s
amarok: END__: void App::applySettings(bool) - Took 7s
amarok: Starting HelixConfigDialog
amarok: [helix-engine] NPLUGINS: 0
amarok: amaroK is crashing...
 
Old 02-27-2006, 02:25 PM   #3
RedNovember
Member
 
Registered: Oct 2005
Distribution: Debian etch
Posts: 103

Original Poster
Rep: Reputation: 15
Any help? amaroK is what I use for listening to all my music, and I'm suffering under the whole "sound driver not initialized" thing. It says on startup, "/dev/dsp could not be initialized. Continuing with the null output driver."
 
Old 02-27-2006, 05:58 PM   #4
artistikone
Member
 
Registered: Jul 2003
Distribution: slackware-current
Posts: 76

Rep: Reputation: 15
Check your Swaret log and see what packages were updated. What were you previously running prior to the upgrade? Did any of the package updates fail? Is depenancy support enabled?

From a quick review of the console output you posted it looks to be a Alsa issue. If this was upgraded, try rolling it back.
 
Old 02-27-2006, 09:06 PM   #5
RedNovember
Member
 
Registered: Oct 2005
Distribution: Debian etch
Posts: 103

Original Poster
Rep: Reputation: 15
Running alsaconf tells me I have no supported PCI card, which is wrong because I know for a fact that I do. Also, where is my swaret log located? I know for a fact that three libraries were necessary, of which 1 (libcairo.so.2) I installed to make things like Firefox work.
 
Old 02-27-2006, 09:09 PM   #6
JockVSJock
Member
 
Registered: Jan 2004
Posts: 602

Rep: Reputation: 31
Quote:
Originally Posted by RedNovember
Any help? amaroK is what I use for listening to all my music, and I'm suffering under the whole "sound driver not initialized" thing. It says on startup, "/dev/dsp could not be initialized. Continuing with the null output driver."
Did you post this under the Slackware forum?

There are alot of helpful people in there who could really help you.
 
Old 02-28-2006, 09:06 PM   #7
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 66
Moved at users request.
 
Old 02-28-2006, 09:10 PM   #8
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Try using aplay to listen some .wav file. Probably you updated alsa-* packages, which you shouldn't if you didn't update the kernel too. Reverting back to original alsa packages should fix it.
 
Old 02-28-2006, 09:22 PM   #9
RedNovember
Member
 
Registered: Oct 2005
Distribution: Debian etch
Posts: 103

Original Poster
Rep: Reputation: 15
Output from aplay:
Code:
rednovember@slackware:~$ aplay xine-out.wav
ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3962:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM default
aplay: main:544: audio open error: No such device
I think it doesn't detect my sound card, but I'm not sure on this.
How do I revert packages?

Last edited by RedNovember; 02-28-2006 at 09:28 PM.
 
Old 03-01-2006, 01:00 AM   #10
IceChant
Member
 
Registered: Jan 2006
Location: Israel
Distribution: Windows Xp, Slackware
Posts: 316
Blog Entries: 3

Rep: Reputation: 30
What about alsaconf again ?
 
Old 03-01-2006, 01:00 AM   #11
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
Quote:
Originally Posted by RedNovember
How do I revert packages?
Find the correct (alsa-driver) package for your kernel and use upgradepkg.

More importantly:

Add ALSA to swaret's exclude.

Run
Code:
upgradepkg
swaret --dep
For any missing libraries, use the package browser (look on the Slackware website) to see what packages are missing. "upgradepkg --install-new" those packages.

A side note, alsa-driver package problems magically disappear if you use the modules supplied with the kernel (requires kernel compiling, but worth it IMHO).
 
Old 03-01-2006, 04:13 PM   #12
RedNovember
Member
 
Registered: Oct 2005
Distribution: Debian etch
Posts: 103

Original Poster
Rep: Reputation: 15
alsaconf still doesn't work. I've got a question - If I was to upgrade (recompile) my kernel, would this work? I would like to have the latest kernel out there. How would I use the modules?
 
Old 04-06-2006, 12:05 AM   #13
Atmchicago
Member
 
Registered: Apr 2003
Location: Baltimore
Distribution: Fedora
Posts: 216

Rep: Reputation: 30
I am getting the same error after updating through swaret. I have an external soundcard, and it works fine with other things under aRts, such as Noatun etc. Any solutions?
 
Old 05-18-2006, 10:36 PM   #14
RedNovember
Member
 
Registered: Oct 2005
Distribution: Debian etch
Posts: 103

Original Poster
Rep: Reputation: 15
I still don't have this working. I upgraded to 2.6.16, but I still get the 'null sound driver' message on startup. Any help? No sound apps work at all, including KMix. Alsaconf doesn't detect my card still.
 
Old 05-19-2006, 02:00 AM   #15
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
Recompile yor kernel. If you are using "make menuconfig", it's something like this:

First:
Code:
Device Drivers -> 
  Sound ->
    Sound Card Support <M>
Then:
Code:
Device Drivers ->
  Sound ->
    Sound Card Support ->
      Advanced Linux Sound Architecture ->
        <M> Advanced Linux Sound Architecture
        <M> Sequencer Support
        <M> Sequencer Dummy Client
        <M> OSS Mixer API
        <M> OSS PCM (digital audio)API
[*] OSS Sequencer API
Next:
Code:
Device Drivers ->
  Sound ->
    Sound Card Support ->
      Advanced Linux Sound Architecture ->
        PCI Devices ->
          <M> next to your card (you can <M> more than one if not sure)
Finally:
Code:
Device Drivers ->
  Sound ->
    Sound Card Support ->
      Open Sound System ->
        < > Open Sound System (DEPRECATED)
This will automatically create the proper ALSA modules for you.

As an alternative, if you are running the kernel from -current, just install the modules and ALSA packages that go with it. SOme prefer this method. I prefer the first method. Makes upgrading kernels a little less painful (no tracking down the proper module packages to go with your kernel). Of course the second method is "easier" if you don't compile your own kernels.

You have another issue with Amarok, too. Don't know where your package came from, but it has a dependency on gstreamer-0.8. You will want to fix that, as well, but the sound issue seemed more pressing...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kaboodle and noatun broken after swaret upgrade peeks Slackware 1 05-06-2004 07:41 AM
Upgrade of Slack Gnome to current via swaret justaguynsrq Slackware 8 04-07-2004 06:38 AM
Slack 9.1 won't boot after Swaret upgrade Glock Shooter Slackware 12 03-27-2004 09:44 AM
GDM Broken After Upgrade Via Swaret 2Gnu Slackware 5 03-20-2004 11:28 PM
Slack 9.0- upgrade to 9.1 or just Swaret to Current? Frank_Drebin Slackware 1 03-11-2004 11:53 PM


All times are GMT -5. The time now is 04:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration