LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-24-2006, 11:49 AM   #1
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
after install some commands not found - cant configure X


i'm a linux newb and installing slackware 10.2 on a 533mhz pIII,128MB ram, 16GB IDE (5=root,11=local, 512 swap).

i have tried to install twice now, once 'for newbies' and now just selecting 'full' install option. I'm using the default kernel (as recommended by setup) but have the same problem both times.

everything seems to go along as the docs say except when i get to trying to configure X. In the slackware manual it says to run 'xorgconig' but i type that and get:

'-bash: xf86config: command not found'

so i look back to the very helpful "what i do thread" and see they recommend running xf86conifg, but again i get command not found. i did the slocate update and tried to find both but:
slocate xorgconfig (or xf86config)

goes back to

root@darkstar:/#

the only things i've noticed not listed in the slackware manual were some extra or just different setup options. also after using the 'full' option for install this time LILO does not show up at all.

thanks
 
Old 04-24-2006, 11:57 AM   #2
the.madjack
Member
 
Registered: Apr 2006
Distribution: Slackware 10.2
Posts: 52

Rep: Reputation: 15
maybe your install CD is corrupted. try to re-burn the disc or check your iso's md5 checksum. good luck!
 
Old 04-24-2006, 12:11 PM   #3
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
at the risk of sounding even dumber... how do i check the md5 checksum?

once i posted, some other ('similar threads') were shown at the bottom, something about the PATH not being set up correctly?
 
Old 04-24-2006, 12:16 PM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by bioe007
at the risk of sounding even dumber... how do i check the md5 checksum?
Under Windows, you can get MD5Summer and get it to generate the sums for the ISOs. You should be able to find a file containing the checksums on any Slackware mirror, so you can see if the ones you generated match.

Quote:
once i posted, some other ('similar threads') were shown at the bottom, something about the PATH not being set up correctly?
I don't know to be honest, as any time I've installed Slack, the folders where the X stuff was were in the $PATH by default. What does "ls /var/log/packages | grep x11" show?
 
Old 04-24-2006, 12:19 PM   #5
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Nylex
What does "ls /var/log/packages | grep x11" show?
i do this:

# ls /var/log/packages | grep x11

i get

#
 
Old 04-24-2006, 12:24 PM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You don't have the X packages installed then, that's the problem. You'll need at least x11-<version>, not sure which others are required. It'd be wise to install x11-devel-<version> too, though. You can get the packages from http://slackware.it/en/pb and install them using installpkg, e.g.

# installpkg x11-6.8.2-i486-3.tgz.

Edit: you might want to install a desktop environment/window manager as well, as the one that comes with X.org (it's called TWM) is quite basic. If you want to install KDE, get the packages from the same site above and install them in the same way. You don't need all of those for KDE and kde.org has a list of which ones are required here.

Last edited by Nylex; 04-24-2006 at 12:57 PM.
 
Old 04-24-2006, 01:02 PM   #7
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
wasnt X supposed to be on the ISOs?

i d/led and put these onto a CD (from my windows machine, cause obviously i'm not doing so well with linux)

now i do:
# installpkg x11-6.8.2-i486-3.tgz
Cannot install x11-6.8.2-i486-3.tgz: package does not end in .tgz

so i tried leaving the .tgz off and it didnt help. also when i:

#ls mnt/cdrom
# (no directory - can linux not read my CD? or is there a driver problem with the CDROM?)
 
Old 04-25-2006, 12:25 AM   #8
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Yeah, the X stuff is on the CDs, not sure why it didn't install though :/. Did you run installpkg from the directory in which the file is?

Also, you should be using "ls /mnt/cdrom", don't leave off that first /! If you did use the correct path, did you mount the CD before doing ls? If not, then you'd mount with something like

# mount /dev/cdrom /mnt/cdrom.
 
Old 04-26-2006, 12:29 AM   #9
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
you're a genius... thank you.

my X is now "working" (at least I think, startx is there now) but my KDE is not

i get a grey screen that says (in a white box near the top)

'Could not start kdeinit. Check your installation.'

after closing this I get a bunch of errors on the black screen (bash?)

there were too many errors and the screen scrolled down, but there were 3 'directory doesnt exist' errors and some other 'library not found errors'

i'm loving this.
 
Old 04-26-2006, 05:55 AM   #10
nutronix
Member
 
Registered: Jan 2003
Location: montreal
Distribution: Slackware and XUbuntu
Posts: 110
Blog Entries: 1

Rep: Reputation: 17
ls /var/log/packages | grep x11 .... should be= ls /var/log/packages | grep X11
to be clear X not x gotta be weary of typos in linux !

And i do not know if the above (xorgconig) is a typo also....should be xorgconfig
good luck
 
Old 04-26-2006, 07:07 AM   #11
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Quote:
there were too many errors and the screen scrolled down, but there were 3 'directory doesnt exist'
It looks like KDE isn't installed. From the command line type:

Code:
$whereis KDE
If it returns just the init files and nothing else, KDE is not installed.

Bob
 
Old 04-26-2006, 07:11 AM   #12
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Also try: locate kde
 
Old 04-26-2006, 04:07 PM   #13
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by nutronix
ls /var/log/packages | grep x11 .... should be= ls /var/log/packages | grep X11
to be clear X not x gotta be weary of typos in linux !
No, the lowercase x is correct as the package names begin with lowercase letters.
 
Old 04-26-2006, 06:03 PM   #14
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
just for the record,

# ls /var/log/packages | grep x11
x11-6.8.2-i486-3
x11-devel-6.8.2-i486-3
x11-misc-6.8.2-noarch-3
#

(it was the little x, big X returns nothing)

# $whereis kde
-bash: kde: command not found
# locate kde
(so much stuff the screen scrolls for a few seconds
the bottom of the list includes)
/root/.kde
/root/.kde/tmp-darkstar
/root/.kde/socket-darkstar
/root/.kde/cache-darkstar
#

btw - similar results found for these commands + gnome (i didnt know which one i'd prefer so i installed both gnome and kde)

sorry for the typos, id did run xorgconfig with no problems (after installing X)

thanks
 
Old 04-26-2006, 08:48 PM   #15
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
After you install the KDE packages (get all of them, not just the base package), you need to add 'startkde' to your /home/<username>/.xinitrc file. Should load up ok after that. Also, you might want to run 'xorgsetup' instead of xorgconfig. It usually autodetects all of the proper settings. You can then modify the /etc/X11/xorg.conf file as you see fit. This is just a matter of preference though, if you got it working with 'xorgconfig' then that's cool too.

FYI, you can scroll up in the console by hitting shift+PgUp

regards,
...drkstr
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to install php5 - configure: error: libjpeg.(a|so) not found. vikram_cvk Linux - Software 6 11-01-2009 08:00 AM
BASH problems: "configure, make, make install" commands don't work ditch* Linux - General 3 07-19-2005 04:37 PM
why some of my commands not found sleepyguy Linux - Newbie 4 01-10-2005 09:07 PM
Webalizer: configure: error: png library not found... please install png. mikeshn Linux - Software 5 01-10-2005 02:28 PM
configure, make and make install commands don't work for me Fenster Fedora 8 08-18-2004 10:58 AM


All times are GMT -5. The time now is 03:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration