LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   after install some commands not found - cant configure X (http://www.linuxquestions.org/questions/slackware-14/after-install-some-commands-not-found-cant-configure-x-438386/)

bioe007 04-24-2006 11:49 AM

after install some commands not found - cant configure X
 
i'm a linux newb and installing slackware 10.2 on a 533mhz pIII,128MB ram, 16GB IDE (5=root,11=local, 512 swap).

i have tried to install twice now, once 'for newbies' and now just selecting 'full' install option. I'm using the default kernel (as recommended by setup) but have the same problem both times.

everything seems to go along as the docs say except when i get to trying to configure X. In the slackware manual it says to run 'xorgconig' but i type that and get:

'-bash: xf86config: command not found'

so i look back to the very helpful "what i do thread" and see they recommend running xf86conifg, but again i get command not found. i did the slocate update and tried to find both but:
slocate xorgconfig (or xf86config)

goes back to

root@darkstar:/#

the only things i've noticed not listed in the slackware manual were some extra or just different setup options. also after using the 'full' option for install this time LILO does not show up at all.

thanks

the.madjack 04-24-2006 11:57 AM

maybe your install CD is corrupted. try to re-burn the disc or check your iso's md5 checksum. good luck!

bioe007 04-24-2006 12:11 PM

at the risk of sounding even dumber... how do i check the md5 checksum?

once i posted, some other ('similar threads') were shown at the bottom, something about the PATH not being set up correctly?

Nylex 04-24-2006 12:16 PM

Quote:

Originally Posted by bioe007
at the risk of sounding even dumber... how do i check the md5 checksum?

Under Windows, you can get MD5Summer and get it to generate the sums for the ISOs. You should be able to find a file containing the checksums on any Slackware mirror, so you can see if the ones you generated match.

Quote:

once i posted, some other ('similar threads') were shown at the bottom, something about the PATH not being set up correctly?
I don't know to be honest, as any time I've installed Slack, the folders where the X stuff was were in the $PATH by default. What does "ls /var/log/packages | grep x11" show?

bioe007 04-24-2006 12:19 PM

Quote:

Originally Posted by Nylex
What does "ls /var/log/packages | grep x11" show?

i do this:

# ls /var/log/packages | grep x11

i get

#

Nylex 04-24-2006 12:24 PM

You don't have the X packages installed then, that's the problem. You'll need at least x11-<version>, not sure which others are required. It'd be wise to install x11-devel-<version> too, though. You can get the packages from http://slackware.it/en/pb and install them using installpkg, e.g.

# installpkg x11-6.8.2-i486-3.tgz.

Edit: you might want to install a desktop environment/window manager as well, as the one that comes with X.org (it's called TWM) is quite basic. If you want to install KDE, get the packages from the same site above and install them in the same way. You don't need all of those for KDE and kde.org has a list of which ones are required here.

bioe007 04-24-2006 01:02 PM

wasnt X supposed to be on the ISOs?

i d/led and put these onto a CD (from my windows machine, cause obviously i'm not doing so well with linux)

now i do:
# installpkg x11-6.8.2-i486-3.tgz
Cannot install x11-6.8.2-i486-3.tgz: package does not end in .tgz

so i tried leaving the .tgz off and it didnt help. also when i:

#ls mnt/cdrom
# (no directory - can linux not read my CD? or is there a driver problem with the CDROM?)

Nylex 04-25-2006 12:25 AM

Yeah, the X stuff is on the CDs, not sure why it didn't install though :/. Did you run installpkg from the directory in which the file is?

Also, you should be using "ls /mnt/cdrom", don't leave off that first /! If you did use the correct path, did you mount the CD before doing ls? If not, then you'd mount with something like

# mount /dev/cdrom /mnt/cdrom.

bioe007 04-26-2006 12:29 AM

you're a genius... thank you.

my X is now "working" (at least I think, startx is there now) but my KDE is not :(

i get a grey screen that says (in a white box near the top)

'Could not start kdeinit. Check your installation.'

after closing this I get a bunch of errors on the black screen (bash?)

there were too many errors and the screen scrolled down, but there were 3 'directory doesnt exist' errors and some other 'library not found errors'

i'm loving this.

nutronix 04-26-2006 05:55 AM

ls /var/log/packages | grep x11 .... should be= ls /var/log/packages | grep X11
to be clear X not x gotta be weary of typos in linux !

And i do not know if the above (xorgconig) is a typo also....should be xorgconfig
good luck

BobNutfield 04-26-2006 07:07 AM

Quote:

there were too many errors and the screen scrolled down, but there were 3 'directory doesnt exist'
It looks like KDE isn't installed. From the command line type:

Code:

$whereis KDE
If it returns just the init files and nothing else, KDE is not installed.

Bob

BobNutfield 04-26-2006 07:11 AM

Also try: locate kde

Nylex 04-26-2006 04:07 PM

Quote:

Originally Posted by nutronix
ls /var/log/packages | grep x11 .... should be= ls /var/log/packages | grep X11
to be clear X not x gotta be weary of typos in linux !

No, the lowercase x is correct as the package names begin with lowercase letters.

bioe007 04-26-2006 06:03 PM

just for the record,

# ls /var/log/packages | grep x11
x11-6.8.2-i486-3
x11-devel-6.8.2-i486-3
x11-misc-6.8.2-noarch-3
#

(it was the little x, big X returns nothing)

# $whereis kde
-bash: kde: command not found
# locate kde
(so much stuff the screen scrolls for a few seconds
the bottom of the list includes)
/root/.kde
/root/.kde/tmp-darkstar
/root/.kde/socket-darkstar
/root/.kde/cache-darkstar
#

btw - similar results found for these commands + gnome (i didnt know which one i'd prefer so i installed both gnome and kde)

sorry for the typos, id did run xorgconfig with no problems (after installing X)

thanks

drkstr 04-26-2006 08:48 PM

After you install the KDE packages (get all of them, not just the base package), you need to add 'startkde' to your /home/<username>/.xinitrc file. Should load up ok after that. Also, you might want to run 'xorgsetup' instead of xorgconfig. It usually autodetects all of the proper settings. You can then modify the /etc/X11/xorg.conf file as you see fit. This is just a matter of preference though, if you got it working with 'xorgconfig' then that's cool too.

FYI, you can scroll up in the console by hitting shift+PgUp

regards,
...drkstr


All times are GMT -5. The time now is 11:44 PM.