LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-02-2013, 09:45 AM   #1
pleasepleasedme
LQ Newbie
 
Registered: Apr 2013
Posts: 2

Rep: Reputation: Disabled
Talking After install proprietary driver of AMD, console resolution isn't optimal.


Im a noob here, so sorry for asking this. just installed 14 64bit on a fujitsu laptop with amd 6320 video adapter. running ok. suddenly something wrong happened, sometimes when boot process the screen goes black or vert. stripe (bw); then i decided to install the proprietary driver for video adapter. after installation the problems that i had is gone,but the resolution when boot process is to small, the text looks big.
ive tried to change the vga mode on the lilo.conf but nothing seems like the first one after installing slackware, the optimal resolution of my laptop is 1366x768. is there any easy way to solve this? thanks :3
 
Old 04-02-2013, 10:57 AM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Hi, welcome to LQ,

I have a Radeon 5470 in my Laptop. I've noticed that since some weeks the opensource-driver (module radeon) is better then the proprietary one.

I would recommend that you uninstall the proprietary driver (you could blacklist fglrx and rename the xorg.conf file which has been created while installation (BTW: did you run aticonfig after installing the proprietary driver??? (aticonfig --initial))

Then after booting you could check which module is loaded, as root execute
Code:
lspci -k | grep -iA3 vga
this should show you some information about your graphics-adapter and which module is in use.

As of the proprietary driver, it uses an xorg.conf file, you could edit this and check which resolution is configured.

Markus
 
1 members found this post helpful.
Old 04-02-2013, 01:56 PM   #3
pleasepleasedme
LQ Newbie
 
Registered: Apr 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by markush View Post
Hi, welcome to LQ,

I have a Radeon 5470 in my Laptop. I've noticed that since some weeks the opensource-driver (module radeon) is better then the proprietary one.

I would recommend that you uninstall the proprietary driver (you could blacklist fglrx and rename the xorg.conf file which has been created while installation (BTW: did you run aticonfig after installing the proprietary driver??? (aticonfig --initial))

Then after booting you could check which module is loaded, as root execute
Code:
lspci -k | grep -iA3 vga
this should show you some information about your graphics-adapter and which module is in use.

As of the proprietary driver, it uses an xorg.conf file, you could edit this and check which resolution is configured.

Markus
thanks for the suggestion, i ended up uninstalling the proprietary driver, now Kernel driver in use: radeon; i hope things that happened before *black screen & stripes* won't happen again.
 
Old 04-02-2013, 02:11 PM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
Originally Posted by pleasepleasedme View Post
thanks for the suggestion, i ended up uninstalling the proprietary driver, now Kernel driver in use: radeon; i hope things that happened before *black screen & stripes* won't happen again.
Put the lines into a script
Code:
#!/bin/sh
lspci -k | grep -iA3 vga > /tmp/lspci.txt
then put the file as (for example) lspci.sh to /etc/rc.d and create a link
Code:
ln -s /etc/rc.d/lspci.sh /etc/rc.d/rc.local_shutdown
and be sure to make the script executable
Code:
chmod 755 /etc/rc.d/lspci.sh
then the script will be executed at shutdown or reboot and write it's output to /tmp/lspci.txt You can then examine the file when the system started next time.

Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia wrong resolution after installing proprietary driver huskarl21 Slackware 4 08-01-2014 06:29 AM
Amd/Ati proprietary driver mesa 9 xorg 1.13 issue Amrod78 Slackware 6 02-26-2013 12:11 PM
AMD Dropping Proprietary Driver Support For Radeon HD 2000/3000/4000 Cultist Linux - News 1 04-23-2012 02:37 PM
NVIDIA proprietary driver, resolution changes not saved on restart, Fedora 14 mbvpixies78 Linux - Hardware 7 12-23-2010 03:24 AM
does the vesa console framebuffer driver conflict with the proprietary nvidia driver? mr.v. Linux - Hardware 2 01-28-2007 06:51 AM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration