LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Adobe Flash Player Plugin (http://www.linuxquestions.org/questions/slackware-14/adobe-flash-player-plugin-4175431429/)

tb75252 10-09-2012 11:48 PM

Adobe Flash Player Plugin
 
I have Slackware 14, 32-bit, with KDE environment.
I am not much of an expert with Linux...

I just installed flash-player-plugin (11.2.202.238) from the SlackBuilds repository.

Everything seems to have gone ok, but when I launch Firefox and type about:plugin, Flash Player is not mentioned and I cannot get sites that use this plug-in to work properly.

I don't thing that there are dependencies that I need to install, so what exactly do I need to do to get Flash Player to work?

TommyC7 10-10-2012 12:31 AM

Check to make sure /usr/lib/mozilla/plugins has a file called "libflashplayer.so"

Don't forget to check to make sure that you installed flash for the correct architecture. You say you're using 32-bit, but did you download the 32-bit tarball, or the 64-bit one for the script to use?

xslc 10-10-2012 12:33 AM

did you try to install it manual ? i means
1. download flash here http://get.adobe.com/flashplayer/?no_redirect
2. tar xzvf install_flash_player_11_linux_*.tar
2. mkdir /home/user/.mozilla/plugins
3. then cp file libflashplayer.so to /home/usr/.mozilla/plugins

done :)

saopedrodaserra 10-10-2012 08:55 AM

plugin
 
Hi,
It's better install manual from www.adobe.com. Download flash 32 bits as explained above && enjoy!

folkenfanel 10-10-2012 10:52 AM

Happiness is best found at home
 
ftp://ftp.slackware.com/pub/slackwar...player-plugin/

cwizardone 10-10-2012 11:36 AM

Even after it is properly installed, that doesn't mean it will work as it should.

First it was the blue skin, reversed color problem and now the plug-in crashes almost every time I try and use it. Sometimes the video won't play or sometimes it will start, but crash shortly afterwards. It has gotten to the point that if the video is one I really want to watch, I boot to Xp first so I know I can watch it without interruption.

T3slider 10-10-2012 11:56 AM

Quote:

Originally Posted by cwizardone (Post 4802320)
Even after it is properly installed, that doesn't mean it will work as it should.

First it was the blue skin, reversed color problem and now the plug-in crashes almost every time I try and use it. Sometimes the video won't play or sometimes it will start, but crash shortly afterwards. It has gotten to the point that if the video is one I really want to watch, I boot to Xp first so I know I can watch it without interruption.

I did have the blue skin problem, but that only affects nVidia chips (and it is fixed [well, worked around] with new libvdpau and/or new nVidia drivers). I haven't had Flash crash anything for at least a year or two. Perhaps you should take a look at your browser settings/profile and/or your system itself...

For the record, I just use Alien Bob's flashplayer-plugin package, which includes the flash-player-properties configuration utility (not that it's very useful). It looks like Adobe just released a new version a couple of days ago and Alien Bob's package isn't updated yet, but he's usually pretty good at packaging in a timely manner.

cwizardone 10-10-2012 12:04 PM

Quote:

Originally Posted by T3slider (Post 4802332)
I did have the blue skin problem, but that only affects nVidia chips (and it is fixed [well, worked around] with new libvdpau and/or new nVidia drivers). I haven't had Flash crash anything for at least a year or two. Perhaps you should take a look at your browser settings/profile and/or your system itself...

Well, no it is not fixed in the new nVidia drivers, and, yes, I've check my browser sitting/profile, but the plug-in crashes with Opera, Firefox and Konqueror.


Quote:

Originally Posted by T3slider (Post 4802332)
For the record, I just use Alien Bob's flashplayer-plugin package, which includes the flash-player-properties configuration utility (not that it's very useful). It looks like Adobe just released a new version a couple of days ago and Alien Bob's package isn't updated yet, but he's usually pretty good at packaging in a timely manner.

I also use Alien Bob's package and have also tried Salix's package, but the results are the same.

T3slider 10-10-2012 12:52 PM

Quote:

Originally Posted by cwizardone (Post 4802338)
Well, no it is not fixed in the new nVidia drivers

304.51 includes the workaround, assuming you use nVidia's bundled libvdpau (libvdpau.so.304.51). If you use standalone libvdpau then you need to get the latest (0.5), which I haven't tested. If you use SlackBuilds for the nVidia drivers then you will definitely NOT be using the bundled nVidia libvdpau. I can pretty much confirm that the workaround is present and works in 304.51 -- I just upgraded to it yesterday, and I can enable hardware acceleration again and everything looks as it should (whereas, testing just before the upgrade using 304.37, it did not). 64-bit, FYI.

stormtracknole 10-10-2012 12:57 PM

Quote:

Originally Posted by T3slider (Post 4802358)
304.51 includes the workaround, assuming you use nVidia's bundled libvdpau (libvdpau.so.304.51). If you use standalone libvdpau then you need to get the latest (0.5), which I haven't tested. If you use SlackBuilds for the nVidia drivers then you will definitely NOT be using the bundled nVidia libvdpau. I can pretty much confirm that the workaround is present and works in 304.51 -- I just upgraded to it yesterday, and I can enable hardware acceleration again and everything looks as it should (whereas, testing just before the upgrade using 304.37, it did not). 64-bit, FYI.

Interesting...I didn't know that nvidia bundled their own version of libvdpau. Does that get installed when using their install script by default? I will have to give it a try as I always have the "inverted colors" flash video problems. I usually have to disable the hardware acceleration to make it work correctly.

cwizardone 10-10-2012 01:27 PM

Quote:

Originally Posted by T3slider (Post 4802358)
304.51 includes the workaround, assuming you use nVidia's bundled libvdpau (libvdpau.so.304.51). If you use standalone libvdpau then you need to get the latest (0.5), which I haven't tested. If you use SlackBuilds for the nVidia drivers then you will definitely NOT be using the bundled nVidia libvdpau. I can pretty much confirm that the workaround is present and works in 304.51 -- I just upgraded to it yesterday, and I can enable hardware acceleration again and everything looks as it should (whereas, testing just before the upgrade using 304.37, it did not). 64-bit, FYI.

I'm using the latest nvidia bundle and it does not solve the problem.

cwizardone 10-11-2012 11:47 AM

Quote:

Originally Posted by T3slider (Post 4802332)
For the record, I just use Alien Bob's flashplayer-plugin package, which includes the flash-player-properties configuration utility (not that it's very useful). It looks like Adobe just released a new version a couple of days ago and Alien Bob's package isn't updated yet, but he's usually pretty good at packaging in a timely manner.

Alien Bob's latest update of the flashplayer-plugin, released yesterday, has taken care of the crashing problem.

Richard Cranium 10-11-2012 11:45 PM

Quote:

Originally Posted by cwizardone (Post 4802389)
I'm using the latest nvidia bundle and it does not solve the problem.

Turn off flash hardware acceleration and the blue goes away.

(EDIT: I just turned hardware acceleration back on and there is no blue tint when watching, say, youtube flash videos. Slackware64 14.0. No multilib. Flash version 11.2.202.243)

cwizardone 10-12-2012 09:53 AM

Quote:

Originally Posted by Richard Cranium (Post 4803555)
Turn off flash hardware acceleration and the blue goes away.

(EDIT: I just turned hardware acceleration back on and there is no blue tint when watching, say, youtube flash videos. Slackware64 14.0. No multilib. Flash version 11.2.202.243)


This was discussed in another thread and here is what finally got rid of the blue (problem for me) without having to turn off hardware acceleration:

Quote:

Originally Posted by brianL (Post 4788344)
These two, mentioned in that forum thread, seem to work:
/etc/profile.d/fix_flash.sh
Code:

#!/bin/sh
export VDPAU_NVIDIA_NO_OVERLAY=1

/etc/adobe/mms.cfg
Code:

EnableLinuxHWVideoDecode=1

The thread is here: http://www.linuxquestions.org/questi...692/page3.html

jtsn 10-13-2012 04:13 PM

VDPAU_NVIDIA_NO_OVERLAY disables hardware acceleration simply on another layer.


All times are GMT -5. The time now is 11:29 AM.