LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-06-2004, 12:37 AM   #1
olscratch
LQ Newbie
 
Registered: Mar 2004
Location: Atlanta, Georgia
Distribution: Slackware-current
Posts: 26

Rep: Reputation: 15
adding pekwm to .xinitrc


I installed Pekwm today but when I ran xwmconfig it is not in the list of window managers. The install directions that came with Pekwm say you may need to add Pekwm to the .xinitrc file. I don't know anything about editing the .xinitrc file. I did notice that there were several files in the /etc/X11/initrc directory with names like xinitrc.fluxbox but there is not one for Pekwm. The only xinitrc file listed in this directory is a link to xinitrc.kde. How do I get Pekwm added to this directory or have it show up in the xwmconfig?
 
Old 05-06-2004, 01:51 AM   #2
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
Re: adding pekwm to .xinitrc

Quote:
Originally posted by olscratch
I installed Pekwm today but when I ran xwmconfig it is not in the list of window managers. The install directions that came with Pekwm say you may need to add Pekwm to the .xinitrc file. I don't know anything about editing the .xinitrc file. I did notice that there were several files in the /etc/X11/initrc directory with names like xinitrc.fluxbox but there is not one for Pekwm. The only xinitrc file listed in this directory is a link to xinitrc.kde. How do I get Pekwm added to this directory or have it show up in the xwmconfig?
the ~xinitrc editing is pretty straight forward. at the bottom you can specify what window manager to load at login.
 
Old 05-06-2004, 02:04 AM   #3
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
It sound sto me like you're just having trouble finding the .xinitrc file. Just type (as root or any user)
Code:
cd
ls -a
Do you see an .xinitrc file now? If not, you don't have one. Youll have to make one. One way is (from your home directory, which you are already in if you followed the above commands)
Code:
vi .xinitrc
that'll start up the vi editor for a new file named .xinitrc. If you don't like vi, use pico or gedit, or kate, or whatever.

That should do what you are looking for. Otherwise, I believe you can also create a file named /etc/X11/xinitrc/xinitrc.pekwm. Then use the file /etc/X11/xinitrc/xinitrc.fluxbox as aguide for what you should put in the file. Either way should work out for you.
 
Old 06-05-2004, 09:21 PM   #4
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
I've looked all over trying to find the answer to this question and haven't found it. How do I start pekwm? If I type 'pekwm' at a command line I get error messages about the display. The documentation doesn't give any useful information.

Thanks.

Kent
 
Old 06-05-2004, 09:58 PM   #5
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Create the file if it doesn't exist ~/.xinitrc and put in it
Code:
exec pekwm
That is if you boot to a console screen and startx. If you boot to a graphical display manager it depends on which one you are running.
 
Old 06-06-2004, 12:56 AM   #6
olscratch
LQ Newbie
 
Registered: Mar 2004
Location: Atlanta, Georgia
Distribution: Slackware-current
Posts: 26

Original Poster
Rep: Reputation: 15
Basically I think I may have cheated a little. In the directory /etc/X11/xinit there are several files, each one named after a window manager, like xinitrc.pekwm. On my pc they were all pretty much the same, except at the bottem of the file it will say something like exec pekwm. Or what ever window manager they point to that it should be name after. What I did was copy one of these xinitrc files and name it xinitrc.pekwm. Then at the botton of the file I put exec pekwm instead of what ever window manager it pointed to. When I want to change window managers I log out of the one I am using and in the console I type xwmconfig. This brings up an ncurses( I think that is what it is called) menu of the different xinitrc.windowmanager files you have in the directory /etc/X11/xinit. Simply use the arrow buttons to select the one you want to use and click enter. Below are examples of what I am talking about.

======The Directory :

root@slackware:/etc/X11/xinit# ls
README.Xmodmap xinitrc.e xinitrc.fvwm2 xinitrc.kde xinitrc.wmaker
xinitrc xinitrc.twm xinitrc.fvwm95 xinitrc.pekwm xinitrc.xfce
xinitrc.afterstep xinitrc.fluxbox xinitrc.gnome

======Now the file will look something like this:

#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/X11R6/lib/X11/xinit/.Xresources
sysmodmap=/usr/X11R6/lib/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
xmodmap $usermodmap
fi

# Start the window manager:
exec pekwm

I hope I have written this so that it makes sense to you and I hope it helps.
 
Old 06-06-2004, 06:26 PM   #7
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
But when I enter either 'exec pekwm' or 'pekwm' at the command line I get the error message:

Can not open display!
Your DISPLAY variable currently is set to:


Is there another configuration file I need so it works properly?

Kent
 
Old 06-08-2004, 10:21 AM   #8
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Type 'startx'. Pek doesn't start X; X starts pek. So 'startx' will initialize X and invoke pek. Otherwise, you're trying to chuck pek into the console and it can't handle that.

The last line of .xinitrc should say 'exec pekwm' - no need to type it again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE scrollbar widgets in Pekwm minck Linux - General 0 02-03-2005 04:59 AM
2 Questions about PekWM.. e0r Linux - Newbie 6 08-24-2004 08:36 PM
Two questions about pekwm S_Warlock Linux - Software 1 07-11-2004 12:23 PM
Dependancies say they're already at the newest version, PekWM argues (Debian) Insecure Linux - Software 2 03-15-2004 06:19 PM
.xinitrc mrsolo Linux - Software 5 10-30-2002 10:16 AM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration