LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-24-2007, 04:24 AM   #1
fireball003
Member
 
Registered: Apr 2005
Location: Bangladesh
Distribution: Soalris10 , Slackware11
Posts: 54

Rep: Reputation: 15
Add swap partiiton manually?


I've installed Slackware 11 and Solaris 10 last night. During Solaris installation I deleted the swap partition for some reason, but now I can't add my swap partition in Slackware.

How can I add swap partition in Slackware manually?

partition table:
/dev/hda1 1 1824 14651248+ 83 Linux
/dev/hda2 * 1825 3737 15366172+ bf Solaris
/dev/hda3 3738 3924 1502077+ 82 Linux swap

Thanks in advance.
 
Old 03-24-2007, 05:22 AM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,350

Rep: Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041Reputation: 1041
Code:
mkswap /dev/hda3
swapon /dev/hda3
Update fstab as appropriate.
 
Old 03-24-2007, 06:46 AM   #3
fireball003
Member
 
Registered: Apr 2005
Location: Bangladesh
Distribution: Soalris10 , Slackware11
Posts: 54

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by syg00
Update fstab as appropriate.
Thanks a lot. It works fine.

But why I need to update fstab? Because It works fine and shows the swap partition after reboot. If something else is there then plz tell me how will I update fstab?
 
Old 03-24-2007, 07:19 AM   #4
digen
Member
 
Registered: Dec 2005
Location: India
Distribution: Ubuntu Feisty Fawn
Posts: 107

Rep: Reputation: 15
It's showing because there is probably an entry for /dev/hda3 as swap. You may confirm for the same, cat /etc/fstab

If you want to create and use a new swap partition, the information has to be entered in /etc/fstab to permanently make use of it when the system boots.
 
Old 04-09-2007, 02:47 PM   #5
cwej
Member
 
Registered: Jul 2006
Location: Washington DC Metro Area
Distribution: Ubuntu 7.10 on a System 76 Pangolin Value laptop - sweeeet!
Posts: 41

Rep: Reputation: 15
dign:

I also add my thanks...I didn't ask, but found this post doing search. I had same problem when I got an error on boot one day.

This worked great for getting swap going for the current session...

sudo mkswap /dev/hda5
sudo swapon /dev/hda5

But, what are the edits for /etc/fstab to make the swap permanent so that its there everytime I reboot?

Right now when I run cat /etc/fstab I get:

{quote}

# /etc/fstab: static file system information
#
#<file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda1 -- converted during upgrade to edgy
UUID=a5549dd-f158-447f-81b2-20c33965d / ext3 defaults,errors=remount-ro 0 1
# /dev/hda5 -- converted during upgrade to edgy
UUID=6e58e1a4-1742-46d4-a5b1-bd279b77441c none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

{end quote}

Last edited by cwej; 04-09-2007 at 02:48 PM.
 
Old 04-09-2007, 03:00 PM   #6
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 384

Rep: Reputation: 34
The line is:
Code:
#<file system> <mount point> <type> <options> <dump> <pass>
 /dev/hda5     swap          swap   defaults  0      0

Last edited by General Failure; 04-09-2007 at 03:05 PM.
 
Old 04-09-2007, 04:35 PM   #7
cwej
Member
 
Registered: Jul 2006
Location: Washington DC Metro Area
Distribution: Ubuntu 7.10 on a System 76 Pangolin Value laptop - sweeeet!
Posts: 41

Rep: Reputation: 15
General F: Worked like a champ! Thanks!
 
Old 04-09-2007, 05:04 PM   #8
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 384

Rep: Reputation: 34
You're welcome
You might want to comment out the other swap entry in fstab (the one that doesn't work):
Code:
#UUID=6e58e1a4-1742-46d4-a5b1-bd279b77441c none swap sw 0 0
Edit: And no comment on why this Ubuntu UUID crap thing doesn't work
 
  


Reply

Tags
slackware, swap


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Manually add programs into the Gnome Application Browser in 10.2 Hawky Suse/Novell 2 02-22-2007 05:23 PM
Manually add depends to independent *.deb pljvaldez Debian 1 09-21-2006 09:51 PM
manually edit FC4 grub.conf to add Ubuntu alar Linux - General 2 09-19-2006 04:45 PM
Problems w/ manually add. a driver at install. time Toshi3 Linux - General 0 09-13-2004 11:35 PM
how do you add/remove Gnome menu entries manually? randomx Linux - General 2 10-16-2003 10:06 PM


All times are GMT -5. The time now is 05:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration