LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-09-2011, 03:33 AM   #1
Breeze
Member
 
Registered: Dec 2010
Distribution: ArchLinux,Slackware
Posts: 53

Rep: Reputation: 4
Question Add slackware to grub.conf


I boot my slackware through usb and I don't install lilo.
I want to add slackware to fedora grub.conf.I have tried some methods,but failed.
How can I do?

fedora grub.conf
Quote:
title Fedora (2.6.35.10-72.fc14.x86_64)
root (hd0,5)
kernel /vmlinuz-2.6.35.10-72.fc14.x86_64 ro root=UUID=5cc13bf9-725f-4e79-8c37-5ce4e15ab26b rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=zh_CN.UTF-8 KEYTABLE=us rhgb quiet nouveau.modeset=0 rdblacklist=nouveau
initrd /initramfs-2.6.35.10-72.fc14.x86_64.img
title Slackware
root (hd0,7)
kernel /boot/vmlinuz-generic-2.6.33.4 root=/dev/sda8 ro vga=773
initrd /boot/initrd.gz
slackware /boot
Quote:
boot.0808 diag2.img System.map-generic-2.6.33.4
boot.080A initrd.gz System.map-huge-2.6.33.4
boot_message.txt initrd-tree/ vmlinuz@
config@ map vmlinuz-generic-2.6.33.4
config-generic-2.6.33.4 README.initrd@ vmlinuz-huge-2.6.33.4
config-huge-2.6.33.4 slack.bmp
diag1.img System.map@
 
Old 04-09-2011, 04:31 AM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,630
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Have you tried running
Code:
update-grub
on the OS which grub is installed in? (from your post, I'm guessing Fedora)

This should hopefully detect OSes automagically and add them to the menu
 
Old 04-09-2011, 04:42 AM   #3
Breeze
Member
 
Registered: Dec 2010
Distribution: ArchLinux,Slackware
Posts: 53

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by Snark1994 View Post
Have you tried running
Code:
update-grub
on the OS which grub is installed in? (from your post, I'm guessing Fedora)

This should hopefully detect OSes automagically and add them to the menu
No,no need to update-grub.After the grub have installed,we can boot the OS added to the grub.conf.
 
Old 04-09-2011, 07:26 AM   #4
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Rep: Reputation: 184Reputation: 184
Quote:
slackware /boot
Quote:
boot.0808 diag2.img System.map-generic-2.6.33.4
boot.080A initrd.gz System.map-huge-2.6.33.4
boot_message.txt initrd-tree/ vmlinuz@
config@ map vmlinuz-generic-2.6.33.4
config-generic-2.6.33.4 README.initrd@ vmlinuz-huge-2.6.33.4
config-huge-2.6.33.4 slack.bmp
diag1.img System.map@
If that is all that is in your Slackware /boot directory you don't have any kernels installed. Vmlinuz-generic-2.6.33.4 and the initrd are not listed. Are they maybe installed on a different partition/boot? If so change the Slackware root (hd0,?) line to reflect the partition the Slackware kernel is located and keep everything else the same.
Or is this "boot.0808 diag2.img System.map-generic-2.6.33.4" your kernel? If so change the kernel line to /boot/boot.0808 diag2.img System.map-generic-2.6.33.4 and the initrd line also to match.

Last edited by colorpurple21859; 04-09-2011 at 07:32 AM.
 
Old 04-09-2011, 09:37 AM   #5
hakan56
Member
 
Registered: Nov 2004
Location: Sweden
Distribution: Slackware64-14.0
Posts: 53

Rep: Reputation: 9
I believe you are using grub-legacy (0.97) and I can't see anything wrong in grub.conf so I make a wild guess that your sda8 is to far away on the disk so Grub can't reach it...I have that problem.

Make a directory /boot/slack on the fedora partition (sda6) and copy all of slackware's /boot to it then change the entry for slackware...
Code:
title Slackware
root (hd0,5)
kernel /boot/slack/vmlinuz-generic-2.6.33.4 root=/dev/sda8 ro vga=773
initrd /boot/slack/initrd.gz
/Håkan
 
Old 04-09-2011, 10:26 AM   #6
Breeze
Member
 
Registered: Dec 2010
Distribution: ArchLinux,Slackware
Posts: 53

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by hakan56 View Post
I believe you are using grub-legacy (0.97) and I can't see anything wrong in grub.conf so I make a wild guess that your sda8 is to far away on the disk so Grub can't reach it...I have that problem.

Make a directory /boot/slack on the fedora partition (sda6) and copy all of slackware's /boot to it then change the entry for slackware...
Code:
title Slackware
root (hd0,5)
kernel /boot/slack/vmlinuz-generic-2.6.33.4 root=/dev/sda8 ro vga=773
initrd /boot/slack/initrd.gz
/Håkan
Thanks!
Yeah,I'm using grub 0.97.But not far.
Quote:
/dev/sda6 58605246 59585084 489919+ 83 Linux
/dev/sda7 59585148 67392674 3903763+ 82 Linux swap / Solaris
/dev/sda8 67394723 122463494 27534386 83 Linux
/dev/sda6 is my grub and /dev/sda8 is my slackware.
Anyway,I tried what you say,but not work.Thanks.

Last edited by Breeze; 04-09-2011 at 10:27 AM.
 
Old 04-09-2011, 10:40 AM   #7
hakan56
Member
 
Registered: Nov 2004
Location: Sweden
Distribution: Slackware64-14.0
Posts: 53

Rep: Reputation: 9
Is there any error message, grub use to print something when it stops.

/Håkan
 
Old 04-09-2011, 11:00 AM   #8
hakan56
Member
 
Registered: Nov 2004
Location: Sweden
Distribution: Slackware64-14.0
Posts: 53

Rep: Reputation: 9
I dont have grub on this computer and I dont remember the command you can give when grub start to get to the "prompt", but there you can use "find"...
http://www.gnu.org/software/grub/man...grub.html#find
Code:
grub> find /boot/vmlinuz-generic-2.6.33.4
grub> find /boot/initrd.gz
..that should give you where they are, and then...
http://www.gnu.org/software/grub/man...#GNU_002fLinux
..if it is /dev/sda8
Code:
grub> root (hd0,7)
grub> kernel /boot/vmlinuz-generic-2.6.33.4 root=/dev/sda8 ro
grub> initrd /boot/initrd.gz
grub> boot
/Håkan
Found the command, when grub start press c for the "prompt"

Last edited by hakan56; 04-09-2011 at 11:33 AM.
 
Old 04-09-2011, 03:16 PM   #9
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 87
1. Use the Huge kernel. You will have a better chance of booting from a USB drive.
2. include a rootdelay parameter in /etc/grub/menu.lst Slackware stanza: e.g.

title Slackware
root (hd0,7)
image=/boot/vmlinuz
append="rootdelay=10 root=/dev/sda8"
read-only
 
Old 04-09-2011, 08:38 PM   #10
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Rep: Reputation: 184Reputation: 184
Your grub legacy might not be able to see your Slackware partition if the slackware partition was formatted using the slackware installer. There are some distros that have that problem with grub legacy. If so you have one of Three options to try.
1. You can update your grub software and see if that helps.
2. Install lilo to the Slackware root partition using the Slackware installer and chainload
3. Use whatever software you use in the distro that your grub is located to format the Slackware partition, and when you go to reinstall Slackware do not format the slackware partition when asked.
 
Old 04-09-2011, 09:39 PM   #11
Breeze
Member
 
Registered: Dec 2010
Distribution: ArchLinux,Slackware
Posts: 53

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by hakan56 View Post
I dont have grub on this computer and I dont remember the command you can give when grub start to get to the "prompt", but there you can use "find"...
http://www.gnu.org/software/grub/man...grub.html#find
Code:
grub> find /boot/vmlinuz-generic-2.6.33.4
grub> find /boot/initrd.gz
..that should give you where they are, and then...
http://www.gnu.org/software/grub/man...#GNU_002fLinux
..if it is /dev/sda8
Code:
grub> root (hd0,7)
grub> kernel /boot/vmlinuz-generic-2.6.33.4 root=/dev/sda8 ro
grub> initrd /boot/initrd.gz
grub> boot
/Håkan
Found the command, when grub start press c for the "prompt"
Thanks.the same error before.
Quote:
/boot/initrd.gz:Loading kernel modules from initrd image:
mount:mounting /dev/sda8 on /mnt failed:No such device
ERROR:No /sbin/init found on rootdev (or not mounted).Trouble ahead.
You can try to fix it.Type 'exit' when things are done.
Why mount /dev/sda8 on /mnt?
 
Old 04-09-2011, 09:51 PM   #12
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Rep: Reputation: 184Reputation: 184
Quote:
root (hd0,7)
kernel /boot/vmlinuz root=/dev/sda8 ro
If Slackware will boot with this, then there is something wrong with the your /boot/initrd.gz
 
Old 04-09-2011, 10:18 PM   #13
Breeze
Member
 
Registered: Dec 2010
Distribution: ArchLinux,Slackware
Posts: 53

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by colorpurple21859 View Post
If Slackware will boot with this, then there is something wrong with the your /boot/initrd.gz
How can I do with this? What's the right way to boot? Thanks!
 
Old 04-09-2011, 10:47 PM   #14
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,342

Rep: Reputation: 184Reputation: 184
In most installs of Slackware /boot/vmlinuz is a link to the vmlinuz-huge-2.6.33.4 kernel which makes it easier to use instead of trying to remember what version of kernel to use.
The huge kernel has everthing installed into it so you do not have to use a initrd.gz file. however because of this, the huge kernel is larger therefore your system won't be as fast as it would be with the generic kernel. Until you get a correctly working initrd.gz you will have to boot your slackware with either /boot/vmlinuz or /boot/vmlinuz-huge-2.6.33.4. After booting into your slackware system with the huge kernel run the following to help with mkinitrd.
Quote:
"$(/usr/share/mkinitrd/mkinitrd_command_generator.sh)"
so for right now see if slackware will boot with this;
Quote:
title Slackware
root (hd0,7)
kernel /boot/vmlinuz root=/dev/sda8 ro vga=773

Last edited by colorpurple21859; 04-09-2011 at 10:52 PM.
 
1 members found this post helpful.
Old 04-09-2011, 11:03 PM   #15
Breeze
Member
 
Registered: Dec 2010
Distribution: ArchLinux,Slackware
Posts: 53

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by colorpurple21859 View Post
In most installs of Slackware /boot/vmlinuz is a link to the vmlinuz-huge-2.6.33.4 kernel which makes it easier to use instead of trying to remember what version of kernel to use.
The huge kernel has everthing installed into it so you do not have to use a initrd.gz file. however because of this, the huge kernel is larger therefore your system won't be as fast as it would be with the generic kernel. Until you get a correctly working initrd.gz you will have to boot your slackware with either /boot/vmlinuz or /boot/vmlinuz-huge-2.6.33.4. After booting into your slackware system with the huge kernel run the following to help with mkinitrd.

so for right now see if slackware will boot with this;
Thanks! I boot with this
Quote:
title Slackware
root (hd0,7)
kernel /boot/vmlinuz-huge-2.6.33.4 root=/dev/sda8 ro
and that's work. Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How Do I Add Slackware to Fedora's Grub.conf raziel23x Slackware 18 10-25-2007 12:38 PM
Grub.conf to add a windows partition SpartacusJones Linux - Software 4 06-16-2007 12:01 AM
manually edit FC4 grub.conf to add Ubuntu alar Linux - General 2 09-19-2006 04:45 PM
add linux booting partition / option to grub.conf powah Linux - General 2 04-04-2006 05:07 PM
syntax for grub.conf to add win98 to bootloader menu 7689mich Linux - Newbie 3 08-26-2004 12:13 AM


All times are GMT -5. The time now is 12:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration