LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Acer 5315, blank screen, sudden shutdowns (http://www.linuxquestions.org/questions/slackware-14/acer-5315-blank-screen-sudden-shutdowns-866803/)

pdi 03-06-2011 02:01 PM

Acer 5315, blank screen, sudden shutdowns
 
A quick heads-up.

An Acer Aspire 5315 ran Slackware 12.2 with no problems. Older attempts to install 13.1 on a second partition failed with sudden shutdowns, apparently due to ACPI related temperature/fan problems. This time round I attempted to install current. After some initial problems with shutdowns during install--resorted to minimal install from DVD, boot, and installed remainder from mounted DVD--I faced two show-stoppers.

Number 1: blank screen during boot, when DRM/KMS kicks in. The boot apparently completes OK, can log in typing blindly and shutdown/reboot. The VGA uses the i915 module and according to lspci, is:
Code:

VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
After much searching I came across this. Added
Code:

video=SVIDEO-1:d
to the append line in lilo.conf and the blank screen never happened again. Can't say I understand what it does, it seems to be related to kernel drm handling (DRM MODE CONNECTOR), but it works.

Number 2: sudden shutdown, still apparently due to ACPI. Decided to try upgrading BIOS first. The installed one was v1.19, Acer released a v1.45. Problem was it only runs from windows, not even dos. Nearly gave up here, since windows was long gone and seemed an overkill to re-install it for this reason. But luckily came across Hiren's Boot CD. This enabled me to boot in WinXP, use the incorporated Ext2Explore to access the ext3 partition where the BIOS upgrade was saved, copy it over to the desktop and make the upgrade with no fuss. The sudden shutdowns never occurred again.

I hope this helps :-)

pino_otto 03-06-2011 03:11 PM

I had a similar problem.

Here you can read some useful information about the solution:

http://giovanni.wordpress.com/2010/0...r-aspire-5315/

In my case I solved the problem by using the acer_fancontrol program.

allend 03-06-2011 04:40 PM

Quote:

video=SVIDEO-1:d
That was a new option to me. According to this it disables the SVIDEO output. http://lists.x.org/archives/xorg-dri...ne/016065.html

Thanks for sharing.

pdi 03-07-2011 11:28 PM

Thank you both for your input.

waynelloydsmith 11-06-2012 05:22 PM

Toshiba Satellite P200 - Blank boot screen - Slackware 14.0
 
This worked for me too.
Intel 945GM video.
Thanks .


All times are GMT -5. The time now is 11:16 PM.