LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-11-2003, 10:30 PM   #16
german
Member
 
Registered: Jul 2003
Location: Toronto, Canada
Distribution: Debian etch, Gentoo
Posts: 312

Rep: Reputation: 30

If you download the spec file, and look through it, it all makes sense how to add other fonts, provided you have a medium through which to send the files from one computer to the other. The script downloads files, puts them in a directory, and packages them for installation. Just add something to that where you cp them into the proper directory before it packages it all up, and you're set to go.

B.
 
Old 07-12-2003, 12:05 AM   #17
BearClaw
Member
 
Registered: Jun 2003
Location: USA
Distribution: Slackware-Current
Posts: 90

Rep: Reputation: 15
XP, In your xp-box, go to: c:\windows\fonts. Burn the fonts file to a CD, then in slack, copy them to /usr/X11/lib/fonts/TTF. Edit: /etc/fonts/fonts.conf, with the actual PATH to your personal-font stash, i.e: if you have them stored in your home dir in a file named TTFonts, add the line: <dir>/home/yourname/TTFonts</dir> . Adjust this to your actual PATH. Then go to control center-appearance-fonts and choose your fonts.

BC
 
Old 07-12-2003, 01:16 AM   #18
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Quote:
Originally posted by alba
Nope Anti Aliasing is on...

and i did gnome-font-properties it changed but still look weird, so i gonna try something else
try /usr/bin/X11/fc-cache -fv /where/your/fonts/are
 
Old 07-12-2003, 11:11 AM   #19
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
I tried gnome-font-properties and it worked but everytime I restart my box I have to change the fonts again and again. Is there any command to save the gnome fonts configuration?
 
Old 07-12-2003, 12:26 PM   #20
german
Member
 
Registered: Jul 2003
Location: Toronto, Canada
Distribution: Debian etch, Gentoo
Posts: 312

Rep: Reputation: 30
why not just make you puter run the command every time it starts? I know Slackware runs fc-cache on boot every time.

B.
 
Old 07-12-2003, 12:43 PM   #21
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Rep: Reputation: 30
I have all my ttf fonts copied over from my Windows XP partition, and I have run fc-cache -f on the directory and generated the fonts.cache-1 file. In addition I added the directory to the XF86Config file as a FontPath entry, and made that change to /etc/fonts/fonts.conf. The fonts work, but don't seem to be recognized by GTK2. In other words they don't appear in gnome-font-properties.

Edit: Nevermind, I moved the fonts to ~/.fonts and adjusted the FontPath entry in the XF86Config file, and for some reason it seemed to work. It's a pretty dumb solution if you ask me, but oh well, it works.

Last edited by Locura; 07-12-2003 at 01:34 PM.
 
Old 07-12-2003, 01:45 PM   #22
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
Quote:
Originally posted by german
why not just make you puter run the command every time it starts? I know Slackware runs fc-cache on boot every time.

B.
What do you mean? I don't want to change the fonts everytime I start my box.
XPediTioN
 
Old 07-12-2003, 01:48 PM   #23
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Rep: Reputation: 30
What do you mean by having to "change the fonts"?
 
Old 07-12-2003, 02:50 PM   #24
german
Member
 
Registered: Jul 2003
Location: Toronto, Canada
Distribution: Debian etch, Gentoo
Posts: 312

Rep: Reputation: 30
Sorry I think I understand, is your problem that gnome does not retain your font preferences for window titles, desktop, terminal, etc.? If so it could be a permissions thing and might be solved by doing

# chmod -R 644 ~/.gnome

so that it can write to the preferences files, but I could easily be wrong.

HTH

B.
 
Old 07-12-2003, 06:33 PM   #25
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
I mean that everytime I restart my box the fonts change. I change them to something different but they change back when I restart. Got it?
 
Old 07-13-2003, 06:54 AM   #26
appler
LQ Newbie
 
Registered: Mar 2003
Location: New Jersey
Distribution: Slackware 9.0
Posts: 22

Rep: Reputation: 15
I'm having the same problem as the starter of this thread... I've recompiled freetype with the bytecode interpreter on and installed those Vera Bitstream fonts, and everything still looks like crap, even with antialiasing turned off. What should I do now?
 
Old 07-13-2003, 08:08 AM   #27
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
okay. first of all windows xp fonts is in c:/winnt/Fonts

What you have to do is to mount your c: partition of your windows xp in Linux.
mount -t ntfs /dev/hdXX /mnt/hd (example only).

After that copy the folder
cp -r /mnt/hd/winnt/fonts /somewhere/uwant/it/tobe

and then follow the steps I mentioned earlier. that is by editing /etc/fonts/fonts.conf

You may have to remove some of the fonts which doesn't work in linux. Maybe it is just the files. But it is okay to just leave it as it is.

also, you may have to ( I did, not sure what is the effects if u don't) add the path in your /etc/X11/XF86Config file too.

all the best.
 
Old 07-13-2003, 12:53 PM   #28
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
I copied all the fonts from Windows XP to the directory you told but I haven't changed anything in /etc/fonts/fonts.conf because I don't know what. What do I have to do?
 
Old 07-13-2003, 01:00 PM   #29
Locura
Member
 
Registered: May 2003
Distribution: Ubuntu 6.10 SE, Mac OS 10.4.8
Posts: 370

Rep: Reputation: 30
Quote:
Originally posted by XPediTioN
I mean that everytime I restart my box the fonts change. I change them to something different but they change back when I restart. Got it?
No, I don't. Your fonts for what? KDE? Gnome? GTK 1.2 apps? GTK 2.0 apps?
 
Old 07-13-2003, 01:35 PM   #30
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
Fonts for gnome-font-properties
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need better fonts in slackware 10.1 thorney Linux - Newbie 3 08-03-2005 04:21 PM
[slackware 10.0]Fonts hylke Linux - Newbie 5 07-31-2004 06:43 AM
Slackware 9.1 non-AA fonts ncognito Linux - Software 1 09-29-2003 11:15 PM
Slackware Fonts Gerardoj Linux - General 1 08-15-2003 09:59 AM
Fonts in Slackware 9.0 zybreak Linux - Software 0 03-29-2003 10:43 AM


All times are GMT -5. The time now is 06:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration