LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-21-2007, 11:51 AM   #1
Basslord1124
Member
 
Registered: Jun 2004
Location: Ashland, KY
Distribution: Debian, Puppy/Slacko
Posts: 351

Rep: Reputation: 31
a slight annoyance....


All right, I have a 3 Samba shares on my Slack server that I connect to from my Slack desktop. I have edited fstab so that they will connect during boot time. What I have noticed during boot time on Slack desktop is that sometimes eth0 doesn't come up in time for it to connect to all 3 shares. Sometimes during boot it will connect to all 3, and the rest of the time just 2 of them while I have to manually mount the 3rd (when eth0 doesn't come up in time). I figure it's this just b/c configuration is right AND my switch LED (a Cisco one) for that port remains amber right up to that point basically. So is there anyway I could buy a few extra seconds during boot time so that all shares will connect all the time?
 
Old 01-21-2007, 12:14 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
You could have the option "noauto" in fstab so it won't be mounted at the normal mount time, and then run a separate script at the end of the boot process to mount the shares.
 
Old 01-21-2007, 12:16 PM   #3
hussar
Member
 
Registered: Oct 2003
Location: Heidelberg, Germany
Distribution: Slackware 11.0; Kubuntu 6.06; OpenBSD 4.0; OS X 10.4.10
Posts: 345

Rep: Reputation: 30
You could perhaps change fstab so that those shares don't automatically mount and then put mount commands in your rc.local. You'd still get them mounted during boot pretty much automatically. By the time rc.local is run, your network should be up.
 
Old 01-21-2007, 12:21 PM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
LOL hussar... great minds must think alike.
 
Old 01-21-2007, 12:44 PM   #5
Basslord1124
Member
 
Registered: Jun 2004
Location: Ashland, KY
Distribution: Debian, Puppy/Slacko
Posts: 351

Original Poster
Rep: Reputation: 31
All righty, thanks...I'll give it a try.
 
Old 01-21-2007, 09:17 PM   #6
Basslord1124
Member
 
Registered: Jun 2004
Location: Ashland, KY
Distribution: Debian, Puppy/Slacko
Posts: 351

Original Poster
Rep: Reputation: 31
Works fine, I had a feeling it had to do with rc.local file as I read that someplace else. Thanks again.
 
Old 01-22-2007, 10:33 PM   #7
Basslord1124
Member
 
Registered: Jun 2004
Location: Ashland, KY
Distribution: Debian, Puppy/Slacko
Posts: 351

Original Poster
Rep: Reputation: 31
Rather than create a new thread I'll keep this one going. I have ran into a new obstacle that should be a quick fix...and I have done my part to try and fix it with no luck.

The drives get mounted fine using the rc.local script BUT it completely screws up the permissions for the root directory of that directory. So basically it goes like this...

Say this is the directory...
/MP3 ......after the mounting, it assigns root as the owner of that directory.

But any subdirectory of that directory has the correct normal user non-root permissions.

Now, I have tried just adding the chown option to those directories (to the user who should own the files) in the rc.local file but it tells me that that option cannot be permitted. Even manually doing it will not work. I am guessing what is happening is when the rc.local file gets processed, since it is owned by root, it automatically places root as the owner of that directory it is mounting. This is really a pain just b/c I do create directories in the main directory and it tells me access is denied.

I have thought what I could do is create a mount command script under the actual users home directory and have rc.local call it. Would that work? I am not too sure if I need any more options in the mount command just b/c fstab covers a lot of the permissions options as is.

Any ideas?
 
Old 01-22-2007, 11:05 PM   #8
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
It would still be run as root and thus, commands would be executed as root. You might be able to add -o user=USERID to the mount command to get it mounted as that user. There are also smb-specific options you may want to explore. See smbmount(8).
 
Old 01-23-2007, 01:02 PM   #9
hussar
Member
 
Registered: Oct 2003
Location: Heidelberg, Germany
Distribution: Slackware 11.0; Kubuntu 6.06; OpenBSD 4.0; OS X 10.4.10
Posts: 345

Rep: Reputation: 30
I just tried `mount -t smbfs -o guest,uid=myusername,gid=users //server/sharename /mnt/mountedshare` on my machine to mount an smb share from my fileserver, and it worked.

As Matir suggested, take a look at the smbmount man page, or for the quick start, take a look at the information you get when you enter `smbmount --help` at the command prompt.
 
Old 01-23-2007, 01:51 PM   #10
Basslord1124
Member
 
Registered: Jun 2004
Location: Ashland, KY
Distribution: Debian, Puppy/Slacko
Posts: 351

Original Poster
Rep: Reputation: 31
I got it. Thanks guys.
 
  


Reply

Tags
mount, smb, smbfs, smbmount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Little Annoyance brianthegreat Fedora 1 07-29-2006 09:15 AM
A slight irritant cwwilson721 Slackware 9 05-25-2006 06:12 AM
Just a slight problem. Pendu Debian 6 09-10-2005 06:22 PM
VMWare Annoyance inescapeableus Linux - Software 3 12-29-2004 01:41 AM
Slight problem with my TV-Out traku Linux - Newbie 0 10-27-2003 07:25 PM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration