LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Closed Thread
 
LinkBack Search this Thread
Old 12-02-2006, 10:51 AM   #391
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 58

What is your fstab line for tmpfs? It should be something like

Code:
tmpfs        /dev/shm        tmpfs        defaults    0   0
Also just an idea out of left field, is your user in the video group? Although I don't think this makes a difference
 
Old 12-02-2006, 02:56 PM   #392
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,397

Rep: Reputation: 81
Hi,

Thanks, however I have tmpfs in /etc/fstab (also confirmed with "mount"), and user is in video group....

So far,
1. fglrx modules is loaded.
2. When "Load dri" is commented out at Module section (xorg.conf), 3d does not work even root (fglrxinfo returns same as user).
3. Permissions for modules look good (x for other)
4. I do not know any other config files than xorg.conf. (so nothing else to check)
5. ???

Happy Penguins!
 
Old 12-06-2006, 05:55 PM   #393
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 58
I can only suggest reread this thread and perhaps the Gentoo Wiki howto on the fglrx drivers and try again. Hopefully you will succeed. It took me almost 2 years (not continuous effort, though) to get DRI and OpenGL working properly on my 9600XT. It won't take you so long.

EDIT This thread and the Gentoo Wiki are the 2 best sources I found to help me. Although the wiki has become more Gentoo specific than it used to be, it should still help.

Last edited by Eternal_Newbie; 12-06-2006 at 06:00 PM.
 
Old 12-07-2006, 08:37 AM   #394
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,397

Rep: Reputation: 81
Hi,

SOLVED

Gento Wiki suggested by Eternal Newbie (I would say ALWAYS GURU) had solution. (at the very end) I will make new thread on this later today.

Thanks a lot.

Happy Penguins!
 
Old 12-07-2006, 09:10 AM   #395
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Don't start a new thread.

Post solution here, so it can be added.

Thats the EXACT reason this thread was started:

One place, find the answer
 
Old 12-07-2006, 01:07 PM   #396
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,397

Rep: Reputation: 81
Hi,

I changed my mind. I will post solution here.

For ATI drivers to work, (or detect correct module), following script has to be done to set environmental variable.
Code:
### START ATI FGLRX ###
### Automatically modified by ATI Proprietary driver scripts
### Please do not modify between START ATI FGLRX and END ATI FGLRX

if [ $LD_LIBRARY_PATH ]
then
  if ! set | grep LD_LIBRARY_PATH | grep /usr/lib/fglrx > /dev/null
  then
    LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/fglrx
    export LD_LIBRARY_PATH
  fi
else
  LD_LIBRARY_PATH=/usr/lib/fglrx
  export LD_LIBRARY_PATH
fi

if [ $LIBGL_DRIVERS_PATH ]
then
  if ! set | grep LIBGL_DRIVERS_PATH | grep /usr/lib/dri > /dev/null
  then
    LIBGL_DRIVERS_PATH=$LIBGL_DRIVERS_PATH:/usr/lib/dri
    export LIBGL_DRIVERS_PATH
  fi
else
  LIBGL_DRIVERS_PATH=/usr/lib/dri
  export LIBGL_DRIVERS_PATH
fi

### END ATI FGLRX ###
This is installed by ATI installer to /etc/profile, however, I use "tcsh" on my penguins.... these are not set!

My solution is modify .tcshrc on my penguin.

I also tried the solution posted in gentoo wiki (see msg #393 above), make symbolic link to "fglrx_dri.so" and it works.

Another useful trick is
Code:
setenv LIBGL_DEBUG verbose
, and run glxgears, fgl_glxgears.... and look for error message unless otherwise seen.

Happy Penguins!!

Last edited by kaz2100; 12-07-2006 at 01:09 PM.
 
Old 12-08-2006, 03:13 PM   #397
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Cool.

For the rewrite (which looks like I won't be able to get to untill after christmas), I'll add that as a 64-bit subsection to the ATI section.
 
Old 12-22-2006, 05:48 AM   #398
Yalla-One
Member
 
Registered: Oct 2004
Location: Norway
Distribution: Slackware, CentOS
Posts: 635

Rep: Reputation: 35
DRI only for root, despite Section "DRI" in xorg.conf

All,

Having followed the description herein earlier with great success earlier, I cannot make it work for non-root users after a re-install.

My xorg.conf has the following lines:

Code:
Section "Module"
Load  "record"
Load  "extmod"
Load  "dbe"
Load  "dri"
Load  "glx"
Load  "xtrap"
Load  "freetype"
Load  "type1"
Load  "synaptics"
EndSection
And towards the end:

Quote:
Section "DRI"
Mode 0666
EndSection
The /var/log/Xorg.0.conf has:
Code:
(II) Module drm: vendor="X.Org Foundation"
    compiled for 6.9.0, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
    compiled for 6.9.0, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "GLcore"
..and..
Code:
(II) RADEON(0): [DRI] installation complete
However, DRI still only works for root, not the other users.

glxinfo simply gives:

NON-root:
Code:
libGL error: open DRM failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect
While ROOT gives:
Code:
display: :0  screen: 0
direct rendering: Yes
Seems clear that it's a permission problem, but my understanding was that the Section "DRI" Mode 0666 would take care of that, so what have I missed?

I have searched and browsed through this thread without finding anything directly touching it, but it's getting rather long, so apologies in advance if I missed something..

-Y1
 
Old 12-22-2006, 09:04 AM   #399
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,397

Rep: Reputation: 81
Hi,

set environment variable LIBGL_DEBUG (see post on 7/Dec) as accordingly. I think you can find more information (hopefully helpful.)

Happy Penguins!
 
Old 12-22-2006, 09:54 AM   #400
Yalla-One
Member
 
Registered: Oct 2004
Location: Norway
Distribution: Slackware, CentOS
Posts: 635

Rep: Reputation: 35
Thanks kaz2100,

Seems like the problem is /dev/dri/card0 which has the wrong permissions:

Code:
[106] yalla1@asterix:/dev/dri>ll -a
total 0
drwxr-xr-x  2 root root      60 2006-12-22 08:08 ./
drwxr-xr-x 20 root root   13960 2006-12-22 12:54 ../
crw-rw----  1 root video 226, 0 2006-12-22 08:08 card0
[107] yalla1@asterix:/dev/dri>
What puzzles me is why this file is mode 660 when xorg.conf says mode 0666.... Anyone?

-Y1
 
Old 12-24-2006, 10:48 AM   #401
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,397

Rep: Reputation: 81
Hi,

I do not have answer, however, I have
Code:
ls -l /dev/dri
crw-rw-rw- 1 root root 226, 0 Dec 24 11:10 card0
I somewhat think, with your penguin, video group members have an access.

Happy Penguins!

PS somebody made this thread.
http://www.linuxquestions.org/questi...d.php?t=513068

Last edited by kaz2100; 12-24-2006 at 12:39 PM.
 
Old 12-24-2006, 05:38 PM   #402
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Quote:
Originally Posted by kaz2100
Most of that is already in this thread, in the ATI section...
 
Old 12-25-2006, 06:29 AM   #403
Yalla-One
Member
 
Registered: Oct 2004
Location: Norway
Distribution: Slackware, CentOS
Posts: 635

Rep: Reputation: 35
The way I read it, the ATI section only applies when using the ATI specific drivers, no?

I'm using the opensource ATI settings, and don't really understand how or why this affects the rights on the /dev/dri/card0 permissions?

What am I missing here, or what part has more relevance than I give it?

-Y1
 
Old 12-28-2006, 07:13 AM   #404
Yalla-One
Member
 
Registered: Oct 2004
Location: Norway
Distribution: Slackware, CentOS
Posts: 635

Rep: Reputation: 35
Solved - incorrect DRI rights

All,

Found the answer to my own question.

Turns out the Section "dri" must be in small, non-capital letters. Then the Mode 0666 statement works, and /dev/dri/card0 gets the correct permissions for the (non-root) users to get DRI.

-Y1
 
Old 12-28-2006, 11:04 PM   #405
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
Hello,

Yalla-One could you post your xorg file in it's entirety and what card you are using (assuming it's all working)?

I think I'm going to grab a radeon 9200 and since my experience is only ATI propritary driver's that'd help me and others out.

Thanks in advance.

Fogie.
 
  


Closed Thread

Tags
3d, acceleration, ati, enabling, fglrx, glx, intel, nvidia, s3, savage, slackware, via, video, x11, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enabling hardware acceleration PennyroyalFrog Linux - Newbie 5 02-26-2010 11:21 AM
xorg-x11 7.0 and exa acceleration jtshaw Linux - Software 0 12-19-2005 07:42 AM
3d acceleration and X11 bspus Linux - Newbie 3 09-06-2005 06:05 AM
Problem Enabling 3D Hardware acceleration. mir_sheely Linux - Hardware 0 06-14-2004 12:37 PM
Audigy Sound card and enabling 3D acceleration for GeoForce3 ti 500 heavyarmor4ever Linux - Newbie 1 01-03-2003 09:27 PM


All times are GMT -5. The time now is 08:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration