LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Closed Thread
 
LinkBack Search this Thread
Old 04-15-2006, 01:38 PM   #136
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62

No Via or Sis here at the residence.

I gave up on via back in windows 98 days becuase of their USB issues; and was not happy w/them as a company. Maybe they changed but they are on my do not buy list.

I have a Sis AGP two card from 'umpteen million' years ago, I try and throw it in one of my boxes here.

Jeebiz how r u making out any luck yet?
 
Old 04-15-2006, 02:04 PM   #137
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,074

Rep: Reputation: 187Reputation: 187
No luck Old_Fogie. I tried downloading drivers from the Freedesktop project page, and as soon as I loaded the drivers, I got in error from my Xorg.0.log stating a version mismatch from my drivers and X. So then I simply tried removing all xorg packages, and reinstalling them, didn't work, I ended up reinstalling 10.2 again, with no DRI still. I am thinking of going back to 10.0, if I am no longer to have DRI with a generic Radeon driver, like before, unless you or anyone else might have some ideas I haven't tried yet.
 
Old 04-19-2006, 06:58 PM   #138
rsiby
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware
Posts: 14

Rep: Reputation: 0
Quote:
Originally Posted by evilDagmar
All that's necessary is to have a copy of the kernel source installed configured to match the running kernel...
Ok, I need to do this, however, I got a few questions. What does "configured to match the running kernel" mean? Do I need to put the nVidia installer in the same location as the kernel source?

Thank you,

Rob
 
Old 04-19-2006, 07:01 PM   #139
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
No. You have to have the kernel source that the running kernel was compiled against
 
Old 04-29-2006, 09:30 AM   #140
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
I've been using this here from your link you give and so far since you gave that wiki link I've been golden thank you.

kde crashes:

change: /opt/kde/share/config/kdm/kdmrc.
you have to add following to the section [X-:*-Core]
TerminateServer=true

Bye for now





Quote:
Originally Posted by Absolute_P
Code:
Kernel-specific troubles

Using ATI driver 8.21.7 and earlier with kernel 2.6.15 or later needs a patch. (see table below for detail.) If you can't compile the driver modules with 2.6.15 or later, you should apply this patch instead.

If you do not use one of these patches, you may experience peculiar lockups of X. Try $ fglrxinfo - if your shell hangs at the end of this command, you may have an issue and should try the patch.

Although unproven, there is a substantial amount of user / developer concern that the above patches prevent hard lockups but do not provide full reliability with 2.6.15 and there are larger / redisgn issues preventing compatibility. It seems surprising that ATI would not have implemented such a simple page count fix in their latest two driver releases since kernel 2.6.15 has been available. Given the closed-source nature of the driver, it is difficult to know for sure. As of now only 2.6.14.x kernels are officially supported by the fglrx driver.
I took this section from thinkwiki.org because it relates to my problem with with the shell hanging, I also get hard feeze's with X when i try to logout,reboot,etc.... prior to finding this post the only way i could get around the hanging and so forth was by commenting out the "dri" in my xorgconf file but my problem is i have never applied a patch b4 and so i dont know how, Could some one please tell me how to do this.
 
Old 04-29-2006, 10:07 AM   #141
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Cool. Nice piece of detectin' Fogie
 
Old 04-29-2006, 11:01 AM   #142
Pier
Member
 
Registered: Oct 2005
Location: Italy
Distribution: Gentoo
Posts: 83

Rep: Reputation: 17
Hi everybody,
this is really spooky... I have to startx twice after a reboot in order to have dri working!!! First time glxinfo returns a -> direct rendering: No. Yet after logging out and in a second time glxinfo | grep rendering returns -> direct rendering: Yes. In the first fase glxgear returns 1240 fps and eventually after the second log in to x 3260fps.
How can this be avoided?
Thanks,
Pier
 
Old 04-29-2006, 11:50 AM   #143
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
Quote:
Originally Posted by Jeebizz
No luck Old_Fogie. I tried downloading drivers from the Freedesktop project page, and as soon as I loaded the drivers, I got in error from my Xorg.0.log stating a version mismatch from my drivers and X. So then I simply tried removing all xorg packages, and reinstalling them, didn't work, I ended up reinstalling 10.2 again, with no DRI still. I am thinking of going back to 10.0, if I am no longer to have DRI with a generic Radeon driver, like before, unless you or anyone else might have some ideas I haven't tried yet.
Sorry I have no idea on the older cards <8500.
 
Old 04-29-2006, 11:54 AM   #144
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
Quote:
Originally Posted by Pier
Hi everybody,
this is really spooky... I have to startx twice after a reboot in order to have dri working!!! First time glxinfo returns a -> direct rendering: No. Yet after logging out and in a second time glxinfo | grep rendering returns -> direct rendering: Yes. In the first fase glxgear returns 1240 fps and eventually after the second log in to x 3260fps.
How can this be avoided?
Thanks,
Pier

What make and model video card.
What version slack and kernel.
How are you logging on first and second time. e.g. root, normal user.

Take a look in syslog after first enter of X and second too so u can see if anything logged.
 
Old 04-29-2006, 12:16 PM   #145
Pier
Member
 
Registered: Oct 2005
Location: Italy
Distribution: Gentoo
Posts: 83

Rep: Reputation: 17
Hi,
Slack 10.2 Ker 2.6.15.1
ATI Radeon 9250 128Mb ddr.
I always log as user.
The first log returns:
http://pastebin.com/688869

whereas the second log reads:

http://pastebin.com/688878

Thanks a lot,
Pier
 
Old 04-29-2006, 04:02 PM   #146
Pier
Member
 
Registered: Oct 2005
Location: Italy
Distribution: Gentoo
Posts: 83

Rep: Reputation: 17
This is what happen at the first startx:
cat /var/log/Xorg.......
...
(==) RADEON(0): Write-combining range (0xd8000000,0x8000000)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
(II) RADEON(0): [drm] loaded kernel module for "radeon" driver
(II) RADEON(0): [drm] DRM interface version 1.2
...

and here is what happens at the second startx:

...
(==) RADEON(0): Write-combining range (0xd8000000,0x8000000)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
(II) RADEON(0): [drm] DRM interface version 1.2
...

Is there an order to follow in loading modules in Xorg.conf that,
if not respected, can cause this?
Thanks,
Pier
 
Old 04-30-2006, 04:04 PM   #147
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
you know I get a bunch of "node errors" too as I start up, and I think it is becuase the fglrx is not open yet, and then eventually as I'm booting it takes effect.

below is my xorg.0.log from my last boot up, from the point I get errors until I get DRI enabled as I boot. so I dont think your logs are showing us anything really different than what I get.

however I think you upgraded your xorg itself! becuase your DRI version is more recent then mine. did you update your XORG?

you see below my DRM interface version is 1.0 and yours is 1.2. Could that be it? could you have updated your xorg and it conflicts somehow?

I am using the latest ATI video drivers on the web as I type this with 2.6.10 kernel.

here is my xorg log:

drmOpenByBusid: drmOpenMinor returns -1023
drmOpenDevice: node name is /dev/dri/card14
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -1023
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 6, (OK)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 6, (OK)
drmGetBusid returned ''
(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:3:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0x00002000
(II) fglrx(0): [drm] mapped SAREA 0x00002000 to 0xb7ab7000
(II) fglrx(0): [drm] framebuffer handle = 0x00003000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 8.24.8
(II) fglrx(0): Date: Apr 11 2006
(II) fglrx(0): Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0): Build-Kernel UTS_RELEASE: 2.6.10
(II) fglrx(0): Build-Kernel MODVERSIONS: no
(II) fglrx(0): Build-Kernel __SMP__: yes
(II) fglrx(0): Build-Kernel PAGE_SIZE: 0x1000
(II) fglrx(0): [drm] register handle = 0x00004000
(II) fglrx(0): [agp] Mode=0x1f00421b bridge: 0x10de/0x01e0
(II) fglrx(0): [agp] AGP v1/2 disable mask 0x00000000
(II) fglrx(0): [agp] AGP v3 disable mask 0x00000000
(II) fglrx(0): [agp] enabling AGP with mode=0x1f00431a
(II) fglrx(0): [agp] AGP protocol is enabled for graphics board. (cmd=0x1f004312)
(II) fglrx(0): [agp] graphics chipset has AGP v3.0 (native mode)
(II) fglrx(0): [drm] ringbuffer size = 0x00100000 bytes
(II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 28672
(II) fglrx(0): [drm] texture shared area handle = 0x00008000
(II) fglrx(0): shared FSAAScale=1
(II) fglrx(0): DRI initialization successfull!
 
Old 04-30-2006, 04:07 PM   #148
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
oh here is my xorg that pertains to your xorg questions:

Section "Module"

# This loads the DBE extension module.
# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
# This loads the font modules
# This loads the GLX module
# Load "dri"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "type1"
# Load "speedo"
Load "freetype"
# Load "xtt"
Load "glx"
# This loads the DRI module
Load "dri"
Load "mouse"
EndSection

Section "Monitor"
Identifier "aticonfig Monitor 0"
HorizSync 31.5 - 90.0
VertRefresh 50.0 - 160.0
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
Option "UseInternalAGPGART" "off"
Option "UseFastTLS" "on"
Option "Capabilities" "0x00000000"
Option "PseudoColorVisuals" "on"
Option "FSAAEnable" "on"
Option "BlockSignalsOnLock" "on"
BusID "PCI:3:0:0"
EndSection

Section "Screen"
Identifier "aticonfig Screen 0"
Device "ATI Graphics Adapter 0"
Monitor "aticonfig Monitor 0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1152x864"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 05-02-2006, 02:04 AM   #149
hsimah
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Slackware 12.1
Posts: 173

Rep: Reputation: 30
I have the same problem. I have to start x twice after booting. I thought 915resolution wasnt working at first, but if I start x as a user I get an error running glxgears, but after I restart it the error goes away.

I am running slackware 10.2 on a 2.6.13 kernel. Using Xorg 6.9. I have an Intel 915GM onboard graphics card. My xorg.conf if pretty much the same as yours there Old Fogie, except my DRI section is further up (just under modules). I didnt think that would affect it though.
 
Old 05-02-2006, 04:54 AM   #150
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Original Poster
Rep: Reputation: 65
Did you look at my xorg.conf (Link in original post)?
Post your xorg.conf.
 
  


Closed Thread

Tags
3d, acceleration, ati, enabling, fglrx, glx, intel, nvidia, s3, savage, slackware, via, video, x11, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enabling hardware acceleration PennyroyalFrog Linux - Newbie 5 02-26-2010 11:21 AM
xorg-x11 7.0 and exa acceleration jtshaw Linux - Software 0 12-19-2005 07:42 AM
3d acceleration and X11 bspus Linux - Newbie 3 09-06-2005 06:05 AM
Problem Enabling 3D Hardware acceleration. mir_sheely Linux - Hardware 0 06-14-2004 12:37 PM
Audigy Sound card and enabling 3D acceleration for GeoForce3 ti 500 heavyarmor4ever Linux - Newbie 1 01-03-2003 09:27 PM


All times are GMT -5. The time now is 05:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration