LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-18-2003, 09:55 PM   #1
jmull
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Rep: Reputation: 0
A few small problems with Slack 9.1


I just installed Slack 9.1, and it installed fine. I loaded up KDE and it also starts up fine, but the mouse pointer doesent detect fine movements, and while I have about 140 megs of memory free, everything takes around 30 seconds to load up. Also, how do I change my GUI to Blackbox or FLuxbox?
 
Old 11-18-2003, 10:02 PM   #2
QtCoder
Member
 
Registered: Aug 2003
Location: USA
Distribution: Slackware 12.0 RC1
Posts: 129

Rep: Reputation: 15
Hi there.

I can help on changing GUI's.

Here's what you can do (in the command-line):

cd /etc/X11/xinit
rm xinitrc
ln -s xinitrc.blackbox xinitrc
startx

That's all! That will make blackbox your default window manager. To use fluxbox, just replace xinitrc.blackbox with xinitrc.fluxbox.
 
Old 11-18-2003, 10:06 PM   #3
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
re: whatever the topic was (I'm drunk)

Short version: mouse pointer: don't know; slow performance: don't know

BUT....

as for the starting window manager...

try (as root) checking out you /etc/X11/xinit directory.

you should see a bunch of xinitrc.blahblah stuff and one xinitrc (which is a symlink to the blahblah stuff).

So, for example, I've got (after #ls /etc/X11/xinit -al):

bash-2.05b# ls /etc/X11/xinit -al
total 44
drwxr-xr-x 2 root root 4096 Oct 4 19:22 .
drwxr-xr-x 23 root root 4096 Oct 21 17:21 ..
-rw-r--r-- 1 root root 0 Sep 16 18:16 .Xmodmap
-rw-r--r-- 1 root root 321 Sep 16 18:16 README.Xmodmap
lrwxrwxrwx 1 root root 13 Oct 4 19:22 xinitrc -> xinitrc.gnome
-rwxr-xr-x 1 root root 556 Mar 16 2003 xinitrc.blackbox
-rwxr-xr-x 1 root root 555 Mar 16 2003 xinitrc.fluxbox
-rwxr-xr-x 1 root root 559 Jun 5 20:15 xinitrc.fvwm2
-rwxr-xr-x 1 root root 539 Feb 21 2002 xinitrc.fvwm95
-rwxr-xr-x 1 root root 630 Sep 10 17:27 xinitrc.gnome
-rwxr-xr-x 1 root root 536 Sep 14 23:29 xinitrc.kde
-r--r--r-- 1 root root 664 Sep 16 18:15 xinitrc.twm
-rwxr-xr-x 1 root root 788 Feb 11 2003 xinitrc.wmaker
lrwxrwxrwx 1 root root 16 Sep 30 14:43 xinitrc.xfce -> ../xfce4/xinitrc


you say you want fluxbox as default?

If I want fluxbox (instead of gnome which I'm obviously using given my ls) I would (in the /etc/X11/xinit directory):

#rm xinitrc
#ln -s xinitrc.fluxbox xinitrc

that should do it...

startx as regular flavor user should now use fluxbox as default.

Hope this helps some, but you may already have known this.
 
Old 11-18-2003, 10:15 PM   #4
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
To select the default windowmanager use xwmconfig.

About your mouse, what kind of mouse you've got and what are the settings in your XF86Config file for it ?
 
Old 11-18-2003, 10:50 PM   #5
jmull
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Its a generic PS/2 scroll mouse. As far as the XF86config file, I couldent locate it anywhere. The same mouse did work with Fedora Core, however.
 
Old 11-18-2003, 11:03 PM   #6
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
XF86Config...

Try:

/etc/X11/XF86Config
 
Old 11-18-2003, 11:25 PM   #7
jmull
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Here it is:

Quote:
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
EndSection
 
Old 11-18-2003, 11:43 PM   #8
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
Maybe I am missing somthing. When kdm comes up, you can choose fluxbos or blackbox If you did a full install they are already their.


this was added later(edited)
-----------------------------------------------------------------------------------------------------------------
This way would work if your default runlevel is 4, then you get the KDM screen which gives you the option to use any of the may differrent windows managers.

Last edited by shanenin; 11-18-2003 at 11:48 PM.
 
Old 11-19-2003, 08:27 AM   #9
Kjetil4455
Member
 
Registered: Jul 2003
Location: Norway/Drammen
Distribution: Slackware~
Posts: 250

Rep: Reputation: 30
easy way to change? "xwmconfig"
 
Old 11-19-2003, 11:14 AM   #10
karthikrr
Member
 
Registered: Nov 2003
Location: India
Distribution: Slackware 13.0 32-bit
Posts: 129

Rep: Reputation: 16
HEY, I have the same prob with the mouse.... No matter what Threshold settigns I use, its till too unresponsive when it comes to fine movements.... And I havent been able to find a single line that can be added to XF86Config to adjust this....

BTW, jmull, if u have a scroll mouse, u also need to add / Option "ZAxisMapping" "4 5" / to ur XF86Config, and change the protocol to "IMPS/2" from auto, and also edit the gpm conf file to make the mouse behave properly in the Console.... I dont remember where the gpm conf file is, somebody else can tell u... :-) And hope somebody can correct the movment problem too....
 
Old 11-19-2003, 11:17 AM   #11
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
An easy way to try different windows managers is this. As root type in kde, that will bring you to a graphical login screen. Then you can log in as regular user or root and choose your windows manager.
 
Old 11-19-2003, 05:13 PM   #12
jmull
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Well, ive got the the WM changing, any ideas on how I can improve the loading speed on apps and fix my mouse problem?
 
Old 11-19-2003, 06:00 PM   #13
murray_linux
Member
 
Registered: Nov 2003
Distribution: Slackware Current
Posts: 210

Rep: Reputation: 30
A nice way to improve performance on Linux is to turn on DMA on your hard disks, which is turned off by default.

Try out something like this:

hdparm -qm128 -qu1 -qc3 -qW1 -qA1 -qd1 -qX66 /dev/hda

see if that improves performance, and then add it to your /etc/rc.d/rc.local script.

more info:

http://www.faqs.org/docs/securing/chap6sec74.html
 
Old 11-19-2003, 06:42 PM   #14
jmull
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by murray_linux
A nice way to improve performance on Linux is to turn on DMA on your hard disks, which is turned off by default.

Try out something like this:

hdparm -qm128 -qu1 -qc3 -qW1 -qA1 -qd1 -qX66 /dev/hda

see if that improves performance, and then add it to your /etc/rc.d/rc.local script.

more info:

http://www.faqs.org/docs/securing/chap6sec74.html
When I do this, I get:
HDIO_SET_MULTCOUNT failed: Invalid argument
 
Old 11-19-2003, 07:57 PM   #15
Hiper
Member
 
Registered: Aug 2003
Location: Portugal
Distribution: Slackware 10.0
Posts: 100

Rep: Reputation: 15
I used to have that weird mouse behavior, i think it's related to the mouse HW itself
but adding:

Option "Resolution" "5000"

in my mouse device, in XF86Config, did the trick for me.

I don't know what this is actually supost to do, neither what values i should use, anyway I think it's worth a shot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
which small utility would you like to see for slack? acidjuice Slackware 17 04-08-2005 06:43 PM
2 small problems hongman Linux - Newbie 13 02-27-2005 05:04 PM
Slack 10 KDE dsktp the Moz 1.7 font too small acummings Slackware 2 07-17-2004 01:35 AM
Partitioning a small drive for slack? neocookie Slackware - Installation 13 05-12-2004 08:59 PM
3 small problems in 1 small post vzzt! Linux - Software 10 02-27-2003 08:40 PM


All times are GMT -5. The time now is 06:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration