LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   A few small problems with Slack 9.1 (http://www.linuxquestions.org/questions/slackware-14/a-few-small-problems-with-slack-9-1-a-117617/)

jmull 11-18-2003 08:55 PM

A few small problems with Slack 9.1
 
I just installed Slack 9.1, and it installed fine. I loaded up KDE and it also starts up fine, but the mouse pointer doesent detect fine movements, and while I have about 140 megs of memory free, everything takes around 30 seconds to load up. Also, how do I change my GUI to Blackbox or FLuxbox?

QtCoder 11-18-2003 09:02 PM

Hi there.

I can help on changing GUI's.

Here's what you can do (in the command-line):

cd /etc/X11/xinit
rm xinitrc
ln -s xinitrc.blackbox xinitrc
startx

That's all! That will make blackbox your default window manager. To use fluxbox, just replace xinitrc.blackbox with xinitrc.fluxbox.

187807 11-18-2003 09:06 PM

re: whatever the topic was (I'm drunk)
 
Short version: mouse pointer: don't know; slow performance: don't know

BUT....

as for the starting window manager...

try (as root) checking out you /etc/X11/xinit directory.

you should see a bunch of xinitrc.blahblah stuff and one xinitrc (which is a symlink to the blahblah stuff).

So, for example, I've got (after #ls /etc/X11/xinit -al):

bash-2.05b# ls /etc/X11/xinit -al
total 44
drwxr-xr-x 2 root root 4096 Oct 4 19:22 .
drwxr-xr-x 23 root root 4096 Oct 21 17:21 ..
-rw-r--r-- 1 root root 0 Sep 16 18:16 .Xmodmap
-rw-r--r-- 1 root root 321 Sep 16 18:16 README.Xmodmap
lrwxrwxrwx 1 root root 13 Oct 4 19:22 xinitrc -> xinitrc.gnome
-rwxr-xr-x 1 root root 556 Mar 16 2003 xinitrc.blackbox
-rwxr-xr-x 1 root root 555 Mar 16 2003 xinitrc.fluxbox
-rwxr-xr-x 1 root root 559 Jun 5 20:15 xinitrc.fvwm2
-rwxr-xr-x 1 root root 539 Feb 21 2002 xinitrc.fvwm95
-rwxr-xr-x 1 root root 630 Sep 10 17:27 xinitrc.gnome
-rwxr-xr-x 1 root root 536 Sep 14 23:29 xinitrc.kde
-r--r--r-- 1 root root 664 Sep 16 18:15 xinitrc.twm
-rwxr-xr-x 1 root root 788 Feb 11 2003 xinitrc.wmaker
lrwxrwxrwx 1 root root 16 Sep 30 14:43 xinitrc.xfce -> ../xfce4/xinitrc


you say you want fluxbox as default?

If I want fluxbox (instead of gnome which I'm obviously using given my ls) I would (in the /etc/X11/xinit directory):

#rm xinitrc
#ln -s xinitrc.fluxbox xinitrc

that should do it...

startx as regular flavor user should now use fluxbox as default.

Hope this helps some, but you may already have known this.

rotvogel 11-18-2003 09:15 PM

To select the default windowmanager use xwmconfig.

About your mouse, what kind of mouse you've got and what are the settings in your XF86Config file for it ?

jmull 11-18-2003 09:50 PM

Its a generic PS/2 scroll mouse. As far as the XF86config file, I couldent locate it anywhere. The same mouse did work with Fedora Core, however.

187807 11-18-2003 10:03 PM

XF86Config...
 
Try:

/etc/X11/XF86Config

jmull 11-18-2003 10:25 PM

Here it is:

Quote:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
EndSection

shanenin 11-18-2003 10:43 PM

Maybe I am missing somthing. When kdm comes up, you can choose fluxbos or blackbox If you did a full install they are already their.


this was added later(edited)
-----------------------------------------------------------------------------------------------------------------
This way would work if your default runlevel is 4, then you get the KDM screen which gives you the option to use any of the may differrent windows managers.

Kjetil4455 11-19-2003 07:27 AM

easy way to change? "xwmconfig"

karthikrr 11-19-2003 10:14 AM

HEY, I have the same prob with the mouse.... No matter what Threshold settigns I use, its till too unresponsive when it comes to fine movements.... And I havent been able to find a single line that can be added to XF86Config to adjust this....

BTW, jmull, if u have a scroll mouse, u also need to add / Option "ZAxisMapping" "4 5" / to ur XF86Config, and change the protocol to "IMPS/2" from auto, and also edit the gpm conf file to make the mouse behave properly in the Console.... I dont remember where the gpm conf file is, somebody else can tell u... :-) And hope somebody can correct the movment problem too....

shanenin 11-19-2003 10:17 AM

An easy way to try different windows managers is this. As root type in kde, that will bring you to a graphical login screen. Then you can log in as regular user or root and choose your windows manager.

jmull 11-19-2003 04:13 PM

Well, ive got the the WM changing, any ideas on how I can improve the loading speed on apps and fix my mouse problem?

murray_linux 11-19-2003 05:00 PM

A nice way to improve performance on Linux is to turn on DMA on your hard disks, which is turned off by default.

Try out something like this:

hdparm -qm128 -qu1 -qc3 -qW1 -qA1 -qd1 -qX66 /dev/hda

see if that improves performance, and then add it to your /etc/rc.d/rc.local script.

more info:

http://www.faqs.org/docs/securing/chap6sec74.html

jmull 11-19-2003 05:42 PM

Quote:

Originally posted by murray_linux
A nice way to improve performance on Linux is to turn on DMA on your hard disks, which is turned off by default.

Try out something like this:

hdparm -qm128 -qu1 -qc3 -qW1 -qA1 -qd1 -qX66 /dev/hda

see if that improves performance, and then add it to your /etc/rc.d/rc.local script.

more info:

http://www.faqs.org/docs/securing/chap6sec74.html

When I do this, I get:
HDIO_SET_MULTCOUNT failed: Invalid argument

Hiper 11-19-2003 06:57 PM

I used to have that weird mouse behavior, i think it's related to the mouse HW itself
but adding:

Option "Resolution" "5000"

in my mouse device, in XF86Config, did the trick for me.

I don't know what this is actually supost to do, neither what values i should use, anyway I think it's worth a shot. :D


All times are GMT -5. The time now is 03:42 PM.