LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-23-2009, 07:08 PM   #1
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Rep: Reputation: 35
A few issues, Slackware 13 64bit


Hi Guys,

Just a few issues. I've just gotten back into slackware after a few years, and I'm not quite sure how to solve these issues. I have tried searching, but none of what I found seemed to apply to my problems..

My hardware is a core 2 duo laptop, a radeon 3650 video card, 4gb ram and a sata hdd. I am using the default xorg.conf that ships with slackware, from the xorg-skel package.

The only change I have made, is to change the driver from vesa to radeon. both worked fine playing an xvid film with xine, however changing to the radeon driver allowed smooth fullscreen playback.

My issues are that:

1. The X server will crash with MTRR errors. Somewhat randomly, but generally doing somewhat intensive stuff, such as moving a xine window around while a video is playing with firefox in the background.

How would I troubleshoot this?

2. I am unable to switch to virtual terminals outside of X. I used to use ctrl + tab + Fn to get outside of X, and then back with alt + tab + f7. These key combinations do not work, nor does ctrl + alt + backspace. I use fluxbox, and to kill X, I have to kill xinit from an xterm.

How would I enabled these key combos? I am using the default Xorg.config, and DontSwitchVT is still commented out by default.

3. I am frustrated with the slackware version of mplayer. It requires a few libaries I would never use, such as aalib, and I installed them anyway, and now it complains about missing libsmbclient. Do I really need to install samba just to use mplayer?

4. Fonts. I used expert/menu mode to install packages, and left most fonts out by default. Is there a list of the fonts I would need/that are used by most programs? Purely english language based setup. At the moment, I have installed the Xfree86 fonts, adobe fonts and misc-misc fonts. Are the adboe fonts necessary? What other fonts are/are not necessary?

Thanks, I appreciate any assistance with these issues.

Cheers
 
Old 09-24-2009, 02:11 AM   #2
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 50
1) try scrapping your xorg.conf and see if xorg works properly. In older Slackware versions you needed to set this up, but the newer xorg doesn't require this--it worked better for me not using an xorg.conf at all! I just have a minimal one that aticonfig --initial gave me (for the proprietary ATI drivers).
2) in kde, try ctrl-alt-f6. use ctrl-alt-f7 to go back to the desktop environment.
3) My suggestion is download the source for mplayer off their site and run ./configure --help in the directory you extract the source in. This will tell you what option disables the samba dependency. I built mplayer on Slackware 12.2 and it didn't require this--weird. Anyway, find a slackbuild for mplayer, tweak the configure flags, create the package and install it.
4) Not sure about this one, but you probably want to keep whatever fonts you have. I don't know if you're missing any; hopefully the program will degrade gracefully if it doesn't find the font it wants. I usually install the webcorefonts from slackbuilds.org as well.

Last edited by vik; 09-24-2009 at 02:18 AM.
 
Old 09-24-2009, 02:33 AM   #3
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
Quote:
Originally Posted by vik View Post
1) try scrapping your xorg.conf and see if xorg works properly. In older Slackware versions you needed to set this up, but the newer xorg doesn't require this--it worked better for me not using an xorg.conf at all! I just have a minimal one that aticonfig --initial gave me (for the proprietary ATI drivers).
2) in kde, try ctrl-alt-f6. use ctrl-alt-f7 to go back to the desktop environment.
3) My suggestion is download the source for mplayer off their site and run ./configure --help in the directory you extract the source in. This will tell you what option disables the samba dependency. I built mplayer on Slackware 12.2 and it didn't require this--weird. Anyway, find a slackbuild for mplayer, tweak the configure flags, create the package and install it.
4) Not sure about this one, but you probably want to keep whatever fonts you have. I don't know if you're missing any; hopefully the program will degrade gracefully if it doesn't find the font it wants. I usually install the webcorefonts from slackbuilds.org as well.
Hey, thanks for your reply.

1. I actually was running by default without an xorg.conf, as I had not installed the xorg-skel package. It was working quite fine, but was not using the radeon driver by default. It still crashes either way however without the .conf and using vesa, with the .conf and usin vesa, or with the .conf and using radeon.

2. I don't use KDE, nor do I have it installed, however those commands did nothing in fluxbox...

3. Yeah, I think I will end up doing this. I was just surprised the mplayer that comes with slack had so many dependencies. I mean samba, for mplayer?

4. Something only time will tell I guess. I still have to make firefox look decent in fluxbox before I should worry about fonts....

Last edited by Josh000; 09-24-2009 at 02:42 AM.
 
Old 09-24-2009, 02:38 AM   #4
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 6

Rep: Reputation: 50
1) I think your card is new enough for the propietary drivers--try them out. I've had good luck with them so far. AFAIK the open source ones are still behind (some cards have 3D support, most don't). Maybe take a look at ~/.xsession-errors as well...
2) Sorry, my assumption. Can't help with fluxbox.
3) I agree. That seems pretty optional to me as well. That's like Debian telling me that X depends on Xine.

Last edited by vik; 09-24-2009 at 02:45 AM.
 
Old 09-24-2009, 03:08 AM   #5
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 4,015

Rep: Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962
2) I use Fluxbox too (startup at runlevel 3) and switch to a virtual console with Ctrl+Alt+Fn with 1<n<7, Alt+F7 to go back to X. As a reminder, tune ~/.fluxbox/keys if you want to change keys' behaviour under X.
4) Why don't you install all fonts shipped with Slackware, even if you don't use all? Don't you have enough disk space ?
 
Old 09-24-2009, 05:13 AM   #6
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
Quote:
Originally Posted by Didier Spaier View Post
2) I use Fluxbox too (startup at runlevel 3) and switch to a virtual console with Ctrl+Alt+Fn with 1<n<7, Alt+F7 to go back to X. As a reminder, tune ~/.fluxbox/keys if you want to change keys' behaviour under X.
4) Why don't you install all fonts shipped with Slackware, even if you don't use all? Don't you have enough disk space ?
It seems we have very different philosophies of running slackware...

It is no question of disk space. I don't install unneeded packages, which includes fonts, for the same reason I don't use a generic kernel with hundreds of modules that I don't need. Optimization and efficiency are a part of that reason, but it is also more to do with having fine control over my system. A sense of security and satisfaction of knowing what is on my system, where it is, and why it is being used.

I suppose I could simply install all fonts, but since most of them don't apply to me, being only an English speaker, I would not see the point.

The keys to switch to virtual consoles are not specific to any window manager, fluxbox, KDE, or any other. They are built into the X server, which is why I am stumped that they are not working.

Last edited by Josh000; 09-24-2009 at 06:09 AM.
 
Old 09-24-2009, 07:01 AM   #7
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 4,015

Rep: Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962Reputation: 962
4) On that topic, you are on your own. All I can say is I never miss a font.

About optimization and efficiency: if you mean optimize for speed, I don't believe that removing a never_loaded_module can speed up your system. Now if you mean optimize for space, that's another story.

IMHO having fine control of a Slackware system depend al lot more of what applications you use and how it is configured, mainly in editing files in /etc, that of what is installed.

Nevertheless I understand that you see things differently and I respect that.

2) Here Ctrl+alt+backspace do not work either (dunno why) but I saw in ~/.fluxbox/keys that Ctrl+Alt+Del exit Fluxbox (and kill X) so that's how I do it.

Here keys to switch to virtual consoles do work, though not with Ctrl + Tab + Fn but with Ctrl + Alt + Fn as with any other Linux system AFAIK, so I don't see your point.
 
Old 09-24-2009, 09:19 AM   #8
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
I have a radeon hd3100 and I'm using the radeon driver.
Code:
01:05.0 VGA compatible controller: ATI Technologies Inc RS780MC [Radeon HD 3100 Graphics]
You can use a very minimal xorg.conf, here's mine:
Code:
Section "Device"
	Option      "AccelMethod" "exa" # default shadowfb
	Option      "DRI" "on"
	Identifier  "Card0"
	Driver      "radeon"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device "Card0"
	Monitor "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes "1680x1050" "1440x900" "1280x800"
	EndSubSection
EndSection
I will say that I had to update libdrm though. Before updating, the performance was horrible. Slow redraws on everything. Here's the link. And thanks to alexiy for that link too.
 
Old 09-24-2009, 12:45 PM   #9
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
Quote:
Originally Posted by Didier Spaier View Post
4)
About optimization and efficiency: if you mean optimize for speed, I don't believe that removing a never_loaded_module can speed up your system. Now if you mean optimize for space, that's another story.
Speed comes into it, in that programs will not have to trawl through hundreds of never used fonts to look for the one they need. I will grant you that on a modern system, it is not so much an issue.

It does not matter though. Not installing excess you don't need is simply good practice. How is having a hundred fonts in different languages you are never going to use optimal or efficient?

Quote:
IMHO having fine control of a Slackware system depend al lot more of what applications you use and how it is configured, mainly in editing files in /etc, that of what is installed.
Isn't that statement a bit contradictory? Just because some applications happen to come with slackware shouldn't matter. It is no different from downloading and choosing to install them.

Quote:
Nevertheless I understand that you see things differently and I respect that.
Likewise..., it is always good to get new opinions

Quote:
Here keys to switch to virtual consoles do work, though not with Ctrl + Tab + Fn but with Ctrl + Alt + Fn as with any other Linux system AFAIK, so I don't see your point.
My point is that it is basic functionality built into the X server and common across all platforms, so I don't understand why it is not working.

Fluxbox can be configured to be killed, and since you started it with xinit, it will also kill X, but ctrl + alt + backspace should kill X independent of any WM.

Last edited by Josh000; 09-24-2009 at 12:48 PM.
 
Old 09-24-2009, 12:55 PM   #10
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
Quote:
font-alias-1.0.1-noarch-1
font-cursor-misc-1.0.0-noarch-2
font-misc-misc-1.0.0-noarch-3
These were the fonts that you needed to get X to start in 12.2, they might be the same in 13.0, but then again they might not. You may have to install in a different order e.g. font-misc-misc will not install properly unless encodings, mkfontdir and mkfontscale are installed before it.

Hope this helps.

samac
 
Old 01-19-2010, 02:35 PM   #11
ahwm
Member
 
Registered: Jan 2010
Location: Idaho
Distribution: Slackware 13.0
Posts: 40

Rep: Reputation: 15
I have a similar problem, but with Slackware 13 32-bit...

It used to work, but now they won't... I'm using KDE... But after reinstalling Slackware, they stopped working. I can use F1 and see system messages, but tty6 is the only console that works. F6 is the only one I can press to get any kind of prompt. 2~5 just give a blinking cursor (actually, they just don't change at all) after going to one of them...

Any ideas?
 
Old 01-19-2010, 06:14 PM   #12
GazL
Senior Member
 
Registered: May 2008
Posts: 3,319

Rep: Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881
That is normal for runlevel 4, ahwm. Have a look in /etc/inittab. You'll soon spot the difference between tty1-5 and tty6.

To be honest, I don't know why Pat even bothers to disable them. It's not as if it saves all that much in system resources and it's one of those things that seems to catch people out.
 
Old 01-20-2010, 01:01 AM   #13
ahwm
Member
 
Registered: Jan 2010
Location: Idaho
Distribution: Slackware 13.0
Posts: 40

Rep: Reputation: 15
The thing is, it worked before...

This is from /etc/inittab

Code:
#These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux
That's the default file, if I'm not mistaken. And it looks to me that this should go ahead and work. Am I wrong?
 
Old 01-20-2010, 03:59 AM   #14
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Your quote of /etc/inittab proves the point GazL was making. Check which tty's are configured to have agetty running in runlevel 4. Only that last line, so only tty6.

Adam
 
Old 01-20-2010, 11:08 PM   #15
ahwm
Member
 
Registered: Jan 2010
Location: Idaho
Distribution: Slackware 13.0
Posts: 40

Rep: Reputation: 15
In Slackware, tty6 is used for the startup of X. That's the default file and they normally work with default settings.

It actually doesn't prove much of anything, in other words. runlevel 4 is for X and 3 is for the basic console. So they can all run the basic console. And even still, to get to X, you use ctrl+alt+F7 -- NOT F6.

That probably doesn't make a whole lot of sense...

To make it easy, here's the whole file:

Code:
#                                     
# inittab       This file describes how the INIT process should set up
#               the system in a certain run-level.                    
#                                                                     
# Version:      @(#)inittab             2.04    17/05/93        MvS   
#                                       2.10    02/10/95        PV    
#                                       3.00    02/06/1999      PV    
#                                       4.00    04/10/2002      PV    
#                                                                     
# Author:       Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified by:  Patrick J. Volkerding, <volkerdi@slackware.com>        
#                                                                      

# These are the default runlevels in Slackware:
#   0 = halt                                   
#   1 = single user mode                       
#   2 = unused (but configured the same as runlevel 3)
#   3 = multiuser mode (default Slackware runlevel)   
#   4 = X11 with KDM/GDM/XDM (session managers)       
#   5 = unused (but configured the same as runlevel 3)
#   6 = reboot                                        

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:                         

# System initialization (runs when system boots).
si:S:sysinit:/etc/rc.d/rc.S                      

# Script to run when going single user (runlevel 1).
su:1S:wait:/etc/rc.d/rc.K                           

# Script to run when going multi user.
rc:2345:wait:/etc/rc.d/rc.M           

# What to do at the "Three Finger Salute".
ca::ctrlaltdel:/sbin/shutdown -t5 -r now  

# Runlevel 0 halts the system.
l0:0:wait:/etc/rc.d/rc.0      

# Runlevel 6 reboots the system.
l6:6:wait:/etc/rc.d/rc.6        

# What to do when power fails.
pf::powerfail:/sbin/genpowerfail start

# If power is back, cancel the running shutdown.
pg::powerokwait:/sbin/genpowerfail stop         

# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

# Local serial lines:
#s1:12345:respawn:/sbin/agetty -L ttyS0 9600 vt100
#s2:12345:respawn:/sbin/agetty -L ttyS1 9600 vt100

# Dialup lines:
#d1:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS0 vt100
#d2:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS1 vt100

# Runlevel 4 used to be for an X window only system, until we discovered
# that it throws init into a loop that keeps your load avg at least 1 all
# the time. Thus, there is now one getty opened on tty6. Hopefully no one
# will notice. ;^)
# It might not be bad to have one text console anyway, in case something
# happens to X.
x1:4:respawn:/etc/rc.d/rc.4

# End of /etc/inittab
Note: It performed the exact same (all 6 consoles PLUS the X system) before AND after setting the default runlevel to 4. That is, until I reinstalled a week or so ago. One time (AFTER setting default runlevel to 4) I commented out c4, c5 and c6 and changed c3 to read 12345 and I was STILL able to switch to VTs 1, 2, and 3 -- with X STILL on F7.

Last edited by ahwm; 01-20-2010 at 11:18 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SVN compile issues - centos 5 64bit neocontrol Linux - Server 1 11-06-2007 11:07 AM
slackware 64bit? Youri Slackware 3 04-25-2006 04:46 PM
64bit Eval Issues...switched to 64bit OSS and WOW RedShirt Suse/Novell 6 01-23-2006 09:07 PM
VMWare 4.5 Sound Issues Running Windoze under linux 64bit Hkrboy27 Linux - Software 2 10-04-2004 02:18 PM
Quake 3, openGL issues, FC2 64bit Zurvan Linux - Games 13 09-29-2004 08:37 AM


All times are GMT -5. The time now is 07:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration