LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-15-2009, 10:45 AM   #1
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Rep: Reputation: 18
A bug about QT in current


KDE 4 programs cannot be launched to open files from paths containing diacritics
https://bugs.kde.org/show_bug.cgi?id=186038
 
Old 03-15-2009, 10:54 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
If so then an upgrade to KDE 4.2.2
-or-
downgrade to Qt 4.4

will fix the problem.
 
Old 03-15-2009, 11:55 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,240

Rep: Reputation: Disabled
Quote:
Originally Posted by zhoun View Post
KDE 4 programs cannot be launched to open files from paths containing diacritics
https://bugs.kde.org/show_bug.cgi?id=186038
I tested this in Slackware -current (KDE 4.2.1 and qt-r931082 which equals roughly to 4.5-rc1).
Like in that bug report, I created the directory cărţi and copied a PDF file into it, then started okular from that directory:
Code:
eha@darkstar:mkdir ~/work/cărţi
eha@darkstar:cd ~/work/cărţi
eha@darkstar:~/work/crţi$ okular xmltutorial.pdf
okular(4444): Attempt to use QAction "bookmark_action_0" with KXMLGUIFactory!
The warning about KXMLGUIFactory is harmless. Okular starts and displays the PDF.
Note that I do not even have an UTF-8 enabled locale, but I have no problems working with the diacritics in that directory name.

Eric
 
Old 03-15-2009, 01:02 PM   #4
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 89
I noticed this problem here with Portuguese characters ( / / etc) but I sort of abandoned KDE4 for now... At least will wait for KDE 4.2.2 before trying again.
 
Old 03-15-2009, 05:50 PM   #5
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 421

Rep: Reputation: 45
Quote:
Originally Posted by Alien Bob View Post
I tested this in Slackware -current (KDE 4.2.1 and qt-r931082 which equals roughly to 4.5-rc1).
Like in that bug report, I created the directory cărţi and copied a PDF file into it, then started okular from that directory:
Code:
eha@darkstar:mkdir ~/work/cărţi
eha@darkstar:cd ~/work/cărţi
eha@darkstar:~/work/crţi$ okular xmltutorial.pdf
okular(4444): Attempt to use QAction "bookmark_action_0" with KXMLGUIFactory!
The warning about KXMLGUIFactory is harmless. Okular starts and displays the PDF.
Note that I do not even have an UTF-8 enabled locale, but I have no problems working with the diacritics in that directory name.

Eric
Launch apps from konsole will not have any problems in my memory, but in _Dolphin_ it Will have the problem. Try to click "crţi.pdf" in Dolphin

From this blog:

http://vizzzion.org/?blogentry=906

I see that Qt4.5 is incompatible with kde4.2 in some degree. But, OK, I know I'm in current branch so maybe everything is rushing and will be fixed in the next release.

But I will be _very_ happy if you fix the bug. Because click-and-open in Dolphin is very convenient for daily using Thanks.

Last edited by grissiom; 03-15-2009 at 10:40 PM.
 
Old 03-15-2009, 09:14 PM   #6
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Original Poster
Rep: Reputation: 18
It's ok in Konqueror and Konsole, only not work in Dolphin.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Python bug in -current? Rupa Slackware 2 04-06-2008 05:46 PM
slackware current - java / xcb bug dulait Slackware 10 03-22-2007 01:13 PM
slack-current (25 sep 06) kernel bug? slak05 Slackware 8 09-27-2006 02:10 PM
Is this a bug in current? slackware_newbie Slackware 3 09-19-2006 01:46 PM
bug in KDE 3.5.2 (slackware current) perfect_circle Slackware 3 04-19-2006 04:22 PM


All times are GMT -5. The time now is 09:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration