LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-04-2002, 02:28 PM   #1
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
3 little problems


I'm a Slackware user since 1 year and half now, and every thing is working good... Except 3 little thing. This are not bad problems but... I was wondering if any of you can give me some tricks.

1-Shutdown. My box can't shutdown proprely. I have already enabled APM, tried all the option, added "modprobe apm" to my rc.modules, but nothing seems to work.


2-Kde and other language support. English isn't my native language, I suppose you already notice... I want to enable the canadian french keyboard in kde, but this keyboard option doesn't exist. In console, I have the canadian french keyboard (cf) but not in X. This is really annoying! Any ways to bypass kde and to force X to use the same keyboard than console?

3-(Damn) Pango and GTK2.0 . I want to try the new GTK2. Just a little problem : I can't install it. Everything compile fine except pango. It give me 2 pages of disgusting error during make, but configure was good. I tried to pass almost every option in configure, nothing works, it's just like Pango was badly made. I can't find any help about this
 
Old 10-04-2002, 04:48 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,537

Rep: Reputation: 149Reputation: 149
Problem 3: Could you sen d the output? I guess you don't have one of the libraries needed by pango installed.
 
Old 10-04-2002, 05:12 PM   #3
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 45
Mara: I already post about it.... no one was able to answer
Here it is:

ake[3]: Entering directory `/usr/local/lib/pango-1.0.4/pango/mini-xft'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/usr/local/lib/pango-1.0.4/pango/mini-xft'
make[3]: Entering directory `/usr/local/lib/pango-1.0.4/pango'
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPANGO_ENABLE_BACKEND -DPANGO_ENABLE_ENGINE -DSYSCONFDIR=\"/usr/local/etc\" -DLIBDIR=\"/usr/local/lib\" -DMODULE_VERSION=\"1.0.0\" -DG_DISABLE_DEPRECATED -I/usr/X11R6/include -I/usr/local/include -I/usr/local/include/freetype2 -I.. -g -O2 -Wall -D_REENTRANT -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -c pangoxft-font.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -DPANGO_ENABLE_BACKEND -DPANGO_ENABLE_ENGINE -DSYSCONFDIR=\"/usr/local/etc\" -DLIBDIR=\"/usr/local/lib\" -DMODULE_VERSION=\"1.0.0\" -DG_DISABLE_DEPRECATED -I/usr/X11R6/include -I/usr/local/include -I/usr/local/include/freetype2 -I.. -g -O2 -Wall -D_REENTRANT -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -c pangoxft-font.c -fPIC -DPIC -o pangoxft-font.lo
make[3]: Leaving directory `/usr/local/lib/pango-1.0.4/pango'
make[2]: Leaving directory `/usr/local/lib/pango-1.0.4/pango'
make[1]: Leaving directory `/usr/local/lib/pango-1.0.4'
In file included from pangoxft.h:27,
from pangoxft-private.h:25,
from pangoxft-font.c:26:
../pango/pango-ot.h:43: parse error before `face'
In file included from pangoxft-private.h:25,
from pangoxft-font.c:26:
pangoxft.h:64: parse error before `pango_xft_font_get_face'
pangoxft.h:64: warning: type defaults to `int' in declaration of `pango_xft_font_get_face'
pangoxft.h:64: warning: data definition has no type or storage class
In file included from pangoxft-font.c:27:
/usr/X11R6/include/X11/Xft/XftFreetype.h:34: parse error before `_XftFTlibrary'
/usr/X11R6/include/X11/Xft/XftFreetype.h:34: warning: type defaults to `int' in
declaration of `_XftFTlibrary'
/usr/X11R6/include/X11/Xft/XftFreetype.h:34: warning: data definition has no type or storage class
/usr/X11R6/include/X11/Xft/XftFreetype.h:37: parse error before `FT_Face'
/usr/X11R6/include/X11/Xft/XftFreetype.h:37: warning: no semicolon at end of struct or union
/usr/X11R6/include/X11/Xft/XftFreetype.h:41: parse error before `size'
/usr/X11R6/include/X11/Xft/XftFreetype.h:41: warning: type defaults to `int' in
declaration of `size'
/usr/X11R6/include/X11/Xft/XftFreetype.h:41: warning: data definition has no type or storage class
/usr/X11R6/include/X11/Xft/XftFreetype.h:54: parse error before `matrix'
/usr/X11R6/include/X11/Xft/XftFreetype.h:54: warning: type defaults to `int' in
declaration of `matrix'
/usr/X11R6/include/X11/Xft/XftFreetype.h:54: warning: data definition has no type or storage class
/usr/X11R6/include/X11/Xft/XftFreetype.h:71: parse error before `face'
pangoxft-font.c: In function `get_mini_font':
pangoxft-font.c:164: `FT_Face' undeclared (first use in this function)
pangoxft-font.c:164: (Each undeclared identifier is reported only once
pangoxft-font.c:164: for each function it appears in.)
pangoxft-font.c:164: parse error before `face'
pangoxft-font.c:176: `face' undeclared (first use in this function)
pangoxft-font.c:181: warning: implicit declaration of function `FT_Get_Char_Index'
pangoxft-font.c: In function `pango_xft_real_render':
pangoxft-font.c:290: `FT_Face' undeclared (first use in this function)
pangoxft-font.c:290: parse error before `face'
pangoxft-font.c:312: `face' undeclared (first use in this function)
pangoxft-font.c: In function `pango_xft_font_get_coverage':
pangoxft-font.c:531: `FT_Face' undeclared (first use in this function)
pangoxft-font.c:531: parse error before `face'
pangoxft-font.c:544: `face' undeclared (first use in this function)
pangoxft-font.c:549: `FT_UInt' undeclared (first use in this function)
pangoxft-font.c:549: parse error before `gindex'
pangoxft-font.c:550: `FT_ULong' undeclared (first use in this function)
pangoxft-font.c:552: `charcode' undeclared (first use in this function)
pangoxft-font.c:552: warning: implicit declaration of function `FT_Get_First_Char'
pangoxft-font.c:552: `gindex' undeclared (first use in this function)
pangoxft-font.c:556: warning: implicit declaration of function `FT_Get_Next_Char'
pangoxft-font.c: At top level:
pangoxft-font.c:681: parse error before `face'
pangoxft-font.c: In function `set_unicode_charmap':
pangoxft-font.c:685: `face' undeclared (first use in this function)
pangoxft-font.c:686: `ft_encoding_unicode' undeclared (first use in this function)
pangoxft-font.c:688: `FT_Error' undeclared (first use in this function)
pangoxft-font.c:688: parse error before `error'
pangoxft-font.c:689: `error' undeclared (first use in this function)
pangoxft-font.c:689: `FT_Err_Ok' undeclared (first use in this function)
pangoxft-font.c: In function `load_fallback_font':
pangoxft-font.c:717: dereferencing pointer to incomplete type
pangoxft-font.c: In function `pango_xft_font_get_font':
pangoxft-font.c:766: dereferencing pointer to incomplete type
pangoxft-font.c: At top level:
pangoxft-font.c:834: parse error before `pango_xft_font_get_face'
pangoxft-font.c:835: warning: return-type defaults to `int'
pangoxft-font.c: In function `pango_xft_font_get_face':
pangoxft-font.c:838: warning: return makes integer from pointer without a cast
pangoxft-font.c:843: warning: return makes integer from pointer without a cast
pangoxft-font.c:845: dereferencing pointer to incomplete type
pangoxft-font.c:846: warning: control reaches end of non-void function
pangoxft-font.c: In function `pango_xft_font_get_ot_info':
pangoxft-font.c:867: `FT_Face' undeclared (first use in this function)
pangoxft-font.c:867: parse error before `face'
pangoxft-font.c:869: `face' undeclared (first use in this function)
make[3]: *** [pangoxft-font.lo] Error 1
make[3]: Leaving directory `/usr/local/lib/pango-1.0.4/pango'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/lib/pango-1.0.4/pango'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/lib/pango-1.0.4'
make: *** [all-recursive-am] Error 2


It is a good error, isn't it?
 
Old 10-04-2002, 09:33 PM   #4
pesho_p
Member
 
Registered: Oct 2002
Location: 42 42' N, 23 19' E
Distribution: Slackware 8.1
Posts: 77

Rep: Reputation: 15
Why don't you try to install Dropline GNOME instead?

Quote:
Dropline GNOME is a version of the GNOME Desktop that has been tweaked for Slackware Linux systems. It is available in Slackware's standard .tgz package format, in addition to the usual source code. The current release is based off of the latest GNOME 2 distribution from the GNOME Project.
The address is: http://www.dropline.net/gnome/index.html

Works just fine here on my Slackware 8.1 (2048x768@32bpp)
 
Old 10-04-2002, 09:52 PM   #5
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
I installed Dropline last night, and I've just posted a blurb about it at p-two.net. Recomended for any slacker who wants gnome 2.
 
Old 10-05-2002, 01:50 AM   #6
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Re: 3 little problems

Quote:
Originally posted by Half_Elf

1-Shutdown. My box can't shutdown proprely. I have already enabled APM, tried all the option, added "modprobe apm" to my rc.modules, but nothing seems to work.


2-Kde and other language support. English isn't my native language, I suppose you already notice... I want to enable the canadian french keyboard in kde, but this keyboard option doesn't exist. In console, I have the canadian french keyboard (cf) but not in X. This is really annoying! Any ways to bypass kde and to force X to use the same keyboard than console?
Ok, for (2), in the file:

/etc/X11/xkbd/X0-config.keyboard

change (or create) it so that it reads:


Rules = "xfree86"
Model = "pc101"
Layout = "ca"
MouseKeysCurve = 0

(unless you different from 101 keys, in which case change the Model)

For (1), what do you mean by this? Do you mean that when you hit the
power button, it doesn't shut down cleanly, or do you mean that when you
do a "/sbin/shutdown" it goes into "halt" mode, but doesn't poweroff?

Some motherboards aren't Linux friendly in that they don't send the code
that APM is looking for when it allows you to hit the power button to send
it into poweroff mode. My new MB isn't friendly to APM, while my old
one was, yours may be one of the unfriendly ones.

I actually use /sbin/poweroff to go into power off mode, and I'm not
running APM or any other power manager, /sbin/poweroff just works.

APM isn't sophisticated enough to allow you to go into suspend mode
correctly right now unless you have a toshiba laptop, in which case some
great people have extended the functionality to work with toshiba
hardware. . .
 
Old 10-05-2002, 02:07 AM   #7
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 45
[/B]
Quote:
Why don't you try to install Dropline GNOME instead?
[B]

Well, In fact, I just want gtk2, I don't really use gnome as desktop, but I really like gnome apps... New gnome apps are usually built for gtk2

What's dropline? The site you give me contain very small info. Look like dropline is a "close to" gnome desktop, made for slack... I don't really want to install a huge desktop manager in order to make gtk2 works
 
Old 10-05-2002, 02:22 AM   #8
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Dropline is gnome 2. It's designed to install on slackware 8.1 and is probably the easiest way to get GTK-2 installed. Not all gnome apps have been ported to GTK-2 yet and dropline installs the ones that have been ported while leaving the old GTK and the gnome apps that need it installed, the packages are in slacks .tgz format so you can always use pkgtool to remove the ones you don't want. All up when I installed it last night it downloaded 97mb worth of packages.
 
Old 10-05-2002, 03:37 PM   #9
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,537

Rep: Reputation: 149Reputation: 149
To Half_Elf: have you installed freetype?
 
Old 10-05-2002, 04:40 PM   #10
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Rep: Reputation: 30
I got Dropline installed in my home pc a week ago and I like it a lot, looks very nice. I got it installed in my work pc, and I like it even more. I recomend it. So far no problems from me.
 
Old 10-05-2002, 07:43 PM   #11
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 45
Quote:
Ok, for (2), in the file: /etc/X11/xkbd/X0-config.keyboard change (or create) it so that it reads:
this directory (/etc/X11) doesn't exist and no "something"-configkeyboard exists on my system


Quote:
Why don't you try to install Dropline GNOME instead?
I just tried dropline, but I need libgr to install and this library refuse to install and give me tons of sense-less error msg.

Oh and... Yes, I ave free-type mara

Last edited by Half_Elf; 10-06-2002 at 01:04 AM.
 
Old 10-06-2002, 01:13 AM   #12
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Sorry, a mis-type on my part. You need the directory xkb (which on my
system is under /etc/X11. Did you install XFree86 after Slackware?)

To find the directory, do a:

locate xkb

You could also do:

xf86cfg -xfree86config PATH/TO/YOUR/XF86Config

EDIT: This SHOULD be: xf86cfg -xf86config
PATH/TO/YOUR/XF86Config



click on the keyboard icon, choose configure keyboard, change the
Keyboard layout to be Canadian

Last edited by moses; 10-06-2002 at 02:14 PM.
 
Old 10-06-2002, 12:55 PM   #13
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 45
moses: yeah, I (re)install xfree after slackware, but it's in the same directory. But in the directory /etc/X11/xkb , there is no X0-config.keyboard.

Also, I want to add the canadian-french (cf) to my X. I already have Canadian (ca) but this is the "english canadian" keyboard... it's near the same, but some characters are missing

I know Redhat/Mandrake have this keyboard, and it exists in my console, too.
 
Old 10-06-2002, 02:12 PM   #14
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
You can create the file /etc/X11/xkb/X0-config.keyboard with the following
in it:

Rules = "xfree86"
Model = "pc101"
Layout = "ca_enhanced"
MouseKeysCurve = 0

(Again, if the Model for your keyboard is correct)
After this file is created, you'll have to restart your X session.


In the directory:

/etc/X11/xkb/symbols

You will find the description of ca_enhanced. If you feel it's not quite what
you want, you can edit it. . .
 
Old 10-06-2002, 11:06 PM   #15
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 45
moses: AHHHH my keyboard works!!!! Amazing!!!
At least, I'm not searching my keys!!!

Now, moses, I want you to explain me how this works, what point to *-config.keyboard. If I'm right, the X0 means the first X session, so if I start another ones, this tricks will not works, right?

Hehe, in any case, THANK YOU VERY MUCH
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethernet Adsl Modem Driver Problems And Install Problems... akhilnair Linux - Hardware 12 11-28-2004 08:19 AM
cisco 350 wireless problems and suse x-server problems incognito9 Linux - Wireless Networking 5 10-14-2004 07:53 AM
Problems with OSS while trying to avoid problems in ALSA (scratchy sound) GT_Onizuka Linux - General 1 02-05-2004 11:55 PM
Problems, problems, problems. Lets start with the soundcard Kre8ive Linux - Newbie 5 08-07-2003 01:20 AM
Problems, problems, problems. Lets start with the ES 1868 AudioDrive Kre8ive Linux - Newbie 1 08-06-2003 07:04 PM


All times are GMT -5. The time now is 02:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration