LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-30-2006, 04:19 PM   #1
skbranch3
LQ Newbie
 
Registered: Jul 2004
Location: saskatchewan canada
Distribution: slackware current
Posts: 7

Rep: Reputation: 0
Question 2 nics getting base addresses confused


Hello Worldfirst post here)
I send this from a zenwalk machine - but a slackware 10.2 install on a different partition does the same. One has 2.4.31 and zenwalk is 2.6.16.1
Most times I reboot this machine the onboard nic and the pci one change their base addresses. As long as - Base address:0xed00 stays with the same nic and the thus the same eth* then the network is fine. But it seems to get a different Base address for the other nic each boot until they "switch". Then one of three things happen 1- switching the nic cables fixes it. 2- switching cables fixes one network but the other wont work. 3 - like two but the other network seems to connect about 500 times slower than normal (a ping takes 243 instead of .542. Some lines from several boots pasted below show this. I cut them out from an ifconfig each time.
My question is how can I get it to pick Base address:0xed00 every time for eth0. I choose this address as it seems to always turn up.
glenS
PS - the answer to "why reboot" is I use the slackware but am "playing" with the zenwalk.
g.
-----------------
eth0 Link encap:Ethernet HWaddr 00:11:096:20:A3
inet addr:192.168.1.60 Bcast:192.168.1.255 Mask:255.255.255.0
Interrupt:18 Base address:0x6000
eth1 Link encap:Ethernet HWaddr 00:50:FC:71:7D:33
inet addr:142.165.59.237 Bcast:142.165.59.255 Mask:255.255.255.0
Interrupt:20 Base address:0xed00
this one worked.
--------------
--------------
eth0 Link encap:Ethernet HWaddr 00:11:096:20:A3
inet addr:192.168.1.60 Bcast:192.168.1.255 Mask:255.255.255.0
Interrupt:18
eth1 Link encap:Ethernet HWaddr 00:50:FC:71:7D:33
inet addr:142.165.59.237 Bcast:142.165.59.255 Mask:255.255.255.0
Interrupt:19 Base address:0xed00
this one worked.
--------------
--------------
eth0 Link encap:Ethernet HWaddr 00:11:096:20:A3
inet addr:192.168.1.60 Bcast:192.168.1.255 Mask:255.255.255.0
Interrupt:18 Base address:0x6000
eth1 Link encap:Ethernet HWaddr 00:50:FC:71:7D:33
inet addr:142.165.59.237 Bcast:142.165.59.255 Mask:255.255.255.0
Interrupt:19 Base address:0xed00
this one worked.
--------------
--------------
eth0 Link encap:Ethernet HWaddr 00:11:096:20:A3
inet addr:192.168.1.60 Bcast:192.168.1.255 Mask:255.255.255.0
Interrupt:18 Base address:0xed00
eth1 Link encap:Ethernet HWaddr 00:50:FC:71:7D:33
inet addr:142.165.59.237 Bcast:142.165.59.255 Mask:255.255.255.0
Interrupt:19 Base address:0x4000

inet addr:127.0.0.1 Mask:255.0.0.0
this one din't work!!!!!!!!
switch nic cables and it did!!!!!!!!::
--------------
--------------
eth0 Link encap:Ethernet HWaddr 00:11:096:20:A3
inet addr:192.168.1.60 Bcast:192.168.1.255 Mask:255.255.255.0
Interrupt:18 Base address:0xed00
eth1 Link encap:Ethernet HWaddr 00:50:FC:71:7D:33
inet addr:142.165.59.237 Bcast:142.165.59.255 Mask:255.255.255.0
Interrupt:19 Base address:0x8000
inet addr:127.0.0.1 Mask:255.0.0.0
this one worked.
--------------
--------------
eth0 Link encap:Ethernet HWaddr 00:11:096:20:A3
inet addr:192.168.1.60 Bcast:192.168.1.255 Mask:255.255.255.0
Interrupt:18 Base address:0xe000
eth1 Link encap:Ethernet HWaddr 00:50:FC:71:7D:33
inet addr:142.165.59.237 Bcast:142.165.59.255 Mask:255.255.255.0
Interrupt:20 Base address:0xed00
inet addr:127.0.0.1 Mask:255.0.0.0
this one din't work!!!!!!!!
switch nic cables not helping!!!!!!!!::
--------------
--------------
eth0 Link encap:Ethernet HWaddr 00:11:096:20:A3
inet addr:192.168.1.60 Bcast:192.168.1.255 Mask:255.255.255.0
Interrupt:18 Base address:0x6000
eth1 Link encap:Ethernet HWaddr 00:50:FC:71:7D:33
inet addr:142.165.59.237 Bcast:142.165.59.255 Mask:255.255.255.0
Interrupt:19 Base address:0xed00
inet addr:127.0.0.1 Mask:255.0.0.0
this one din't work!!!!!!!!
switch nic cables made eth0 work but not eth1!!!!!!!!::
--------------
--------------
eth0 Link encap:Ethernet HWaddr 00:11:096:20:A3
inet addr:192.168.1.60 Bcast:192.168.1.255 Mask:255.255.255.0
Interrupt:17 Base address:0xed00
eth1 Link encap:Ethernet HWaddr 00:50:FC:71:7D:33
inet addr:142.165.59.237 Bcast:142.165.59.255 Mask:255.255.255.0
Interrupt:18 Base address:0xa000
inet addr:127.0.0.1 Mask:255.0.0.0
this one din't work!!!!!!!!
switch nic cables back and it did!!!!!!!!::
--------------
--------------
eth0 Link encap:Ethernet HWaddr 00:11:096:20:A3
inet addr:192.168.1.60 Bcast:192.168.1.255 Mask:255.255.255.0
Interrupt:17 Base address:0xed00
eth1 Link encap:Ethernet HWaddr 00:50:FC:71:7D:33
inet addr:142.165.59.237 Bcast:142.165.59.255 Mask:255.255.255.0
Interrupt:18 Base address:0xa000
inet addr:127.0.0.1 Mask:255.0.0.0
this one worked.
--------------
--------------
 
Old 05-31-2006, 01:51 PM   #2
ledow
Member
 
Registered: Apr 2005
Location: UK
Distribution: Slackware 13.0
Posts: 241

Rep: Reputation: 34
Well, to be honest it shouldn't be doing this. If something is changing addresses between reboots and you're not moving or changing the hardware then it's a bit of a problem.

First, I would make sure that you aren't changing hardware between boots (quite obvious).

You could try the latest BIOS for your motherboard or set the BIOS options to fixed defaults to stop stuff moving about (it's probably all on auto under PCI Config, if you even have that option at all in your BIOS).

You could try moving the PCI card to a different slot entirely (this may stop it "fighting" for an address and give it a stable one). You could try just re-seating the PCI card in the same slot.

You could try a newer kernel but I don't see anything between your kernels and the latest that would affect this. I suppose the latest udev/hotplug could also play a part depending on what version you have now (note that recent 2.6.16 kernels have a higher udev requirement - 0.74 I think)

Finally, if after all that the addresses are still pretty much random, you could try a utility like nameif - this lets you name an interface whatever you want depending on it's MAC address (unique to each nic), so you could make one ALWAYS be eth0 and one ALWAYS be eth1, no matter which order they were detected in. This would "solve" the problem but it doesn't come with Slackware by default. There may also be a way to do this using udev if you know what you're doing. It's also quite a basic and "old" solution and I don't know if it will still work with modern udev - anyone else know?
 
Old 05-31-2006, 03:42 PM   #3
skbranch3
LQ Newbie
 
Registered: Jul 2004
Location: saskatchewan canada
Distribution: slackware current
Posts: 7

Original Poster
Rep: Reputation: 0
thanks
I haven't moved hardware; but I'll try moving the card later tonite(I hope)
udevinfo -V says version 088
actually I have the MAC address saying it stays with the same ETH by specifying in in rc.inet1.conf - its the irq /base address that keeps changing around. So well it looks like eth1 always connect to 00:50:.... and eth0 always says its connected to 00:11... somehow unless Base address:0xed00 stays with the same HWaddress between boots it goes south.
I have looked in the BIOS and will look again but it seemed to me that I couldn't do what I needed.
 
  


Reply

Tags
networking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
epplet-base-0.7 rose_bud4201 Linux - Software 4 07-04-2005 11:38 PM
Intel D845GLLY + Multiple Intel Pro 100 NICs + kernel 2.6.x = NICs don't work egable Linux - Hardware 0 02-04-2005 03:30 PM
Ip Addresses responding on wrong NICs vimes Linux - Networking 1 10-16-2004 09:10 AM
Ip Addresses responding on wrong NICs vimes Suse/Novell 1 10-16-2004 08:50 AM
Base Install Matty_Cross Linux - General 4 05-07-2002 09:43 AM


All times are GMT -5. The time now is 01:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration