LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-10-2008, 06:24 PM   #1
orbit
Member
 
Registered: Sep 2006
Location: Australia
Distribution: Slackware
Posts: 176

Rep: Reputation: 30
2.6.27.5-smp Generic + Nvidia (*.run) Driver = Failure


Hi all,

Yesterday I upgraded to the 2.6.27.5-smp generic kernel from http://packages.slackware.it.

Before the upgrade, I had altered my xorg.conf back to the vesa driver (as nvidia module does not transfer to new kernels).

The upgrade went quite smoothly and after I had successfully booted the new kernel, I removed all the old 2.6.24.5 kernels/modules/source from my system.

After the upgrade I went to reinstall the NVIDIA-Linux-x86-96.43.07-pkg1.run file to use the proprietary nvidia driver again.

The Nvidia driver (That I have been using successfully for a long time) failed to compile/install on the new 2.6.27.5-smp kernel?

Has anyone else experienced this? Does anyone have any suggestions?

Cheers

Last edited by orbit; 11-10-2008 at 06:26 PM.
 
Old 11-10-2008, 06:35 PM   #2
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64 14.0
Posts: 981

Rep: Reputation: 88
What's the .config for the 2.6.27.5-smp generic kernel look like?

What was the error you received?

I roll my own kernel all of the time and have not run into your situation.
 
Old 11-10-2008, 06:37 PM   #3
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,409

Rep: Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835Reputation: 835
Just had the same problem with my machine. Download the latest nVidia driver 177.80. That compiles just fine.
 
Old 11-10-2008, 07:33 PM   #4
orbit
Member
 
Registered: Sep 2006
Location: Australia
Distribution: Slackware
Posts: 176

Original Poster
Rep: Reputation: 30
Hello, thanks for the replies;

SqdnGuns, the kernel config was standard (generic), except for the addition of a bootsplash patch (something I have been doing for ages).

allend, I am unable to use the 177.80 as this machine is old, and uses the legacy 96* driver.
 
Old 11-10-2008, 07:35 PM   #5
orbit
Member
 
Registered: Sep 2006
Location: Australia
Distribution: Slackware
Posts: 176

Original Poster
Rep: Reputation: 30
*Fixed*

I have resolved the problem by using two nvidia slackbuild's designed specifically for the 96* nvidia driver against the 2.6.27.5 kernel.

Thanks very much to the author of the nvidia slackbuilds

Cheers

Last edited by orbit; 11-10-2008 at 07:39 PM.
 
Old 11-10-2008, 11:01 PM   #6
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
Quote:
Originally Posted by orbit View Post
*Fixed*

I have resolved the problem by using two nvidia slackbuild's designed specifically for the 96* nvidia driver against the 2.6.27.5 kernel.

Thanks very much to the author of the nvidia slackbuilds

Cheers
Wow, thank you, you saved me some hair. I just upgraded the laptop to -current and was about to have this problem. The driver I need is even older: 71.86.06
I can confirm that it also works applying the nvidia-71.86.06-2.6.27.patch.
Thanks again to the Slackbuilds team and to ppr:kut.

* Just a note, and I know this is not the best place to report this:
If you do a search for nvidia you'll get this:
Code:
nvidia-driver	System	177.80	12.1
nvidia-kernel	System	177.80	12.1
nvidia-legacy173-driver	System	173.14.12	12.1
nvidia-legacy173-kernel	System	173.14.12	12.1
nvidia-legacy71-driver	System	71.86.06	12.1
nvidia-legacy71-driver	System	71.86.06	12.1
nvidia-legacy96-driver	System	96.43.07	12.1
nvidia-legacy96-kernel	System	96.43.07	12.1
For some reason it's missing:
slackbuilds.org/repository/12.1/system/nvidia-legacy71-kernel

If you happen to be @ irc.freenode.net #slackbuilds please tell the crew, I'm about to crash atm, good night and thanks again to all
edit: nvm I just did

Last edited by MannyNix; 11-10-2008 at 11:09 PM.
 
Old 11-11-2008, 03:39 AM   #7
ppr:kut
Member
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 359

Rep: Reputation: 93
Quote:
Thanks very much to the author of the nvidia slackbuilds
Quote:
Thanks again to the Slackbuilds team and to ppr:kut.
My pleasure
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC9 XFX Nvidia Geforce 260 generic driver error shickidyshade Linux - Hardware 9 10-31-2008 05:07 PM
ndiswrapper and generic smp kernel Bazzaah Slackware 13 05-17-2008 02:31 AM
nvidia driver on smp kernel fiz Linux - Hardware 21 02-20-2008 05:46 PM
smp oops in kernel 2.6.20-16-generic anirudhvij Linux - Kernel 0 08-19-2007 06:02 AM
problems installing NVIDIA graphics driver and SMP littleneutral1 Debian 0 11-24-2004 12:24 PM


All times are GMT -5. The time now is 01:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration