LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   14.1 RC2 nouveau, glxgears sync v-blank (http://www.linuxquestions.org/questions/slackware-14/14-1-rc2-nouveau-glxgears-sync-v-blank-4175481914/)

GazL 10-23-2013 05:26 PM

14.1 RC2 nouveau, glxgears sync v-blank
 
Code:

test@rc2:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
VGA-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
  1920x1080      60.0*+
  1680x1050      60.0 
  1280x1024      75.0    60.0 
  1152x864      75.0 
  1024x768      75.1    60.0 
  800x600        75.0    60.3 
  640x480        75.0    60.0 
  720x400        70.1 
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
test@rc2:~$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.

7616 frames in 5.0 seconds = 1523.152 FPS
7619 frames in 5.0 seconds = 1523.626 FPS
7903 frames in 5.0 seconds = 1580.545 FPS

Not the most earth shattering of issues, but is this usual when using nouveau/mesa rendering? That'd be one hell of a vertical refresh rate!

mats_b_tegner 10-24-2013 02:45 PM

FYI under nVidia R319.60 glxgears gives me:
bash-4.2$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
300 frames in 5.0 seconds = 59.954 FPS
298 frames in 5.0 seconds = 59.443 FPS
299 frames in 5.0 seconds = 59.647 FPS
299 frames in 5.0 seconds = 59.645 FPS
299 frames in 5.0 seconds = 59.645 FPS
298 frames in 5.0 seconds = 59.446 FPS

Mats

GazL 10-24-2013 03:05 PM

Yep. I get the same with the NVIDIA driver when sync to vblank is enabled (I think it's on by default these days, but it didn't used to be). What seems to be happening with nouveau however is that glxgears thinks sync is enabled when it isn't. When sync isn't enabled you usually don't get that "Running synchronized to the vertical refresh. The framerate should be approximately the same as the monitor refresh rate." message.

When I turn sync off while using the proprietary drivers I get around 15,000 - 16,000 fps, with this card.


Anyway, as I said, not an earth shattering issue.

ReaperX7 10-24-2013 11:16 PM

Are you using driconf to set the sync to vblank?

GazL 10-25-2013 03:57 AM

I was testing on a completely fresh install of 14.1RC2 so it will have been whatever the default value us.

ReaperX7 10-25-2013 03:50 PM

The default value is usually disabled vblank so it's running at the highest speed possible.

GazL 10-25-2013 04:01 PM

Yes, that was clear from the reported fps values and was what lead me to post this query in the first place.

gabrielmagno 10-25-2013 07:43 PM

Have you tried changing the variable vblank_mode?

In my machine (not NVIDIA, just for exemplification):

Code:

$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
302 frames in 5.0 seconds = 60.259 FPS
300 frames in 5.0 seconds = 59.947 FPS
300 frames in 5.0 seconds = 59.954 FPS


Code:

$ vblank_mode=1 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
17436 frames in 5.0 seconds = 3487.076 FPS
17606 frames in 5.0 seconds = 3520.454 FPS
17709 frames in 5.0 seconds = 3541.699 FPS


Code:

$ vblank_mode=2 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
302 frames in 5.0 seconds = 60.281 FPS
300 frames in 5.0 seconds = 59.950 FPS
300 frames in 5.0 seconds = 59.951 FPS

GazL 10-26-2013 03:08 AM

Code:

test@rc2:~$ glxgears   
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
7559 frames in 5.0 seconds = 1511.667 FPS
^C
test@rc2:~$ vblank_mode=0 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
7617 frames in 5.0 seconds = 1523.288 FPS
^C
test@rc2:~$ vblank_mode=1 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
7617 frames in 5.0 seconds = 1523.270 FPS
7620 frames in 5.0 seconds = 1523.851 FPS
^C
test@rc2:~$ vblank_mode=2 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
7615 frames in 5.0 seconds = 1522.801 FPS
7616 frames in 5.0 seconds = 1523.098 FPS
^C
test@rc2:~$

Doesn't seem to make the slightest difference in default mode.

However, after adding:
Code:

# /etc/X11/xorg.conf.d/90-nouveau.conf #################################

Section "Device"
  Identifier "nouveau"
    Driver "nouveau"
    Option "GLXVBlank" "on"
EndSection

########################################################################

I get the same behaviour as you:
Code:

test@rc2:~$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
303 frames in 5.0 seconds = 60.425 FPS
300 frames in 5.0 seconds = 59.998 FPS
^C
test@rc2:~$ vblank_mode=1 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
7618 frames in 5.0 seconds = 1523.443 FPS
7619 frames in 5.0 seconds = 1523.650 FPS
^C
test@rc2:~$ vblank_mode=2 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
303 frames in 5.0 seconds = 60.406 FPS
300 frames in 5.0 seconds = 59.998 FPS
^C

So, seems if the setting is on in xorg.conf, I can override it to 'off', but if the setting is 'off', it thinks it's 'on', but it's actually 'off' and the override makes little difference.

Oh well... I'll just put this down to nouveau/mesa being buggy.

GazL 10-26-2013 03:17 AM

BTW, seems you're getting twice the unsynced frame-rate I do, what card do you have?

gabrielmagno 10-26-2013 08:22 AM

Quote:

Originally Posted by GazL (Post 5052590)
BTW, seems you're getting twice the unsynced frame-rate I do, what card do you have?

It's an Intel HD Graphics 4000.


All times are GMT -5. The time now is 12:24 AM.