LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-19-2013, 07:51 PM   #1
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 262

Rep: Reputation: 29
14.1 0 folders, 0 files connecting usb camera, worked in 14.0


Hi all.

Using slackware64-14.0, connected usb camera, device notifier prompted couple actions, like file manager, clicked that, list of folders/files was shown, copied pics from camera.

With slackware64-14.1 all works like 14.0, device notifier says 'portable media player', select file manager, dolphin opens, lists camera:, says 0 folders, 0 files, I know there are pictures in the camera.

Not sure if this is something KDE or some part of the system.

usb hard drives, thumb drives work fine.

Any ideas please. Thanks
 
Old 11-20-2013, 01:02 PM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 147Reputation: 147
Which camera model? Can you change (on the camera) the USB protocol from PTP to Mass Storage?
 
Old 11-20-2013, 08:53 PM   #3
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 262

Original Poster
Rep: Reputation: 29
Thanks guanx

Canon Powershot SD200

Can't change anything, LCD has been cracked and unreadable forever, it was hand me down that takes adequate pictures for my needs.

I have vbox xp vm and if I connect the camera there I can get at the images.
 
Old 11-20-2013, 09:06 PM   #4
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 527

Rep: Reputation: 140Reputation: 140
guanx might be on to something. Do a "lsusb" or "lsusb -v" to see if it reports as PTP mode. Since you can't see the screen, it might have switched on you. Some ideas:

-> check out http://www.gphoto.org/
-> can you remove the SD memory card to with with a USB SD card reader?
 
Old 11-21-2013, 05:09 AM   #5
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,960

Rep: Reputation: 978Reputation: 978Reputation: 978Reputation: 978Reputation: 978Reputation: 978Reputation: 978Reputation: 978
Quote:
Originally Posted by glorsplitz View Post
Hi all.

Using slackware64-14.0, connected usb camera, device notifier prompted couple actions, like file manager, clicked that, list of folders/files was shown, copied pics from camera.

With slackware64-14.1 all works like 14.0, device notifier says 'portable media player', select file manager, dolphin opens, lists camera:, says 0 folders, 0 files, I know there are pictures in the camera.

Not sure if this is something KDE or some part of the system.

usb hard drives, thumb drives work fine.

Any ideas please. Thanks
Try to open it with Gwenview instead of Dolphin. Works for me.
 
Old 11-21-2013, 11:16 AM   #6
szentike
LQ Newbie
 
Registered: Nov 2013
Location: Hungary, Veszprém
Distribution: Slackware
Posts: 2

Rep: Reputation: Disabled
Hi all!
I've got same problem.
My camera's model is Fuji S5700.
 
Old 11-21-2013, 11:18 AM   #7
szentike
LQ Newbie
 
Registered: Nov 2013
Location: Hungary, Veszprém
Distribution: Slackware
Posts: 2

Rep: Reputation: Disabled
Here is some picture:
http://i.imgur.com/qwRPVZQ.png
http://i.imgur.com/bpckCMw.png
http://i.imgur.com/KHpoloH.png
 
Old 11-21-2013, 07:31 PM   #8
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 262

Original Poster
Rep: Reputation: 29
lsusb:
Bus 004 Device 008: ID 04a9:30c0 Canon, Inc. Digital IXUS 30 (PTP mode) / PowerShot SD200 (PTP mode)

Gwenview shows same thing szentike attached pics shows.

Using gimp, so I did file/open, under places found Canon Digital Camera, folders list appeared, clicked to where there's pictures, clicked a picture, gimp says:
Opening 'gphoto2://[usb:004,008]/DCIM/186CANON/IMG_8601.JPG' failed:
Operation not supported by backend

If I take camera:/ from dolphin into Geeqie, it aborts altogether.

Borrowed a card reader: Bus 004 Device 009: ID 3207:0300
device notifier pops up file manager or gwenview, both worked fine. So I guess I should get a card reader since I don't know how if I can change PTP to Mass Storage without the lcd working on the camera to see if that would work.

Thanks everyone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] sharing files and connecting to usb camera Virtualbox pottzie Linux - Virtualization and Cloud 1 10-30-2012 02:23 PM
Best camera phone for USB downloading files to Linux? tomrobla Linux - Hardware 1 11-20-2008 02:05 AM
Computer is not connecting with usb printer, camera, cardreaders etc mattnorb Linux - Software 12 06-19-2008 11:08 AM
Problems copying files from USB camera Lul2x Linux - Hardware 1 04-18-2004 10:47 PM
Digital Camera connecting problem on usb realos Linux - Hardware 4 05-28-2003 10:30 AM


All times are GMT -5. The time now is 10:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration