LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-29-2012, 07:05 AM   #1
j9x.inca
Member
 
Registered: Jul 2012
Location: Fort Drum, NY, US
Distribution: Arch Linux
Posts: 63

Rep: Reputation: 2
Unhappy 13.37 Wireless Help


Just in advanced I'd like to say I've looked everywhere i could. I've been up all night trying to figure this out. Sorry for my post I rarely use forums so I have bad etiquette, and sorry for any typos. Ok here we go:

I have a fresh install of 13.37 on my HP Mini netbook. Broadcom BCM4312. I download the firmware for it and SlackBuild for broadcom-sta. Installed it, and rebooted. Install went fine because its now listed under 'eth1' instead of 'wlan0'.

Now i have edited my rc.inet1.conf and my wpa_supplicant.conf according to: http://alien.slackbook.org/dokuwiki/...wpa_encryption

My network is WPA2 PSK AES encrypted.So i followed the above guide posted. I did have some problems along the way because my password for my network containts exclamations marks (!!) at the end, and was throwing off wpa_supplicant, so i put ' around it. All is good.

Now after i am done configuring both the inet1 and wpa_supplicant confs i go to restart my device using:
Code:
/etc/rc.d/rc.inet1 eth1_restart
and I get the following errors (which I have searched around but no clear conclusions):

Code:
Error for wireless request "Set Encode" (8B2A):
SET failed on device eth1 ; Invalid argument.
Error for wireless request "Set Encode" (8B2A) :
Set failed on device eth1 ; Invalid argument.
... ...

I'm really not sure what to do here. Here is my wpa_supplicant.conf and inet1:

rc.inet1.conf This is at the end of my file:
Code:
##CONFIG FOR ETH1
IFNAME[1]="eth1"
WLAN_MODE[1]=Managed
WLAN_ESSID[1]=Xibalba    <---Name of router
WLAN_KEY[1]="s:mypassword!!"   <--- password w/ s: in front of it so it doesnt trip out because of the exclamation marks
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]="slackbox"  <-not name of anything, not sure if i needed to put something random for router to identify my computer as
DHCP_TIMEOUT[1]=20
WLAN_WPA="wpa_supplicant"
WLAN_WPADRIVER[1]="wext"  <-- ?
DHCP_IPADDR[1]=""
*when using wpa_supplicant command i only see wext, n180211, and wired listed under drivers. Not sure if broadcom should be listed after the installation of firmware i did with SlackBuild


And here is wpa_supplicant.conf:

Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
scan_ssid=0 ssid="Xibalba" proto=WPA WPA2 key_mgmt=WPA-PSK WPA-EAP pairwise=CCMP TKIP #psk="mypassword!!" psk=89723918273918273192873912837912837129 <-not actual psk key just didnt want to type it out
}
 
Old 07-31-2012, 08:02 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,342

Rep: Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387
I can't test it right now, but I think the "invalid argument" is "eth1_restart."

My guess is that it should be "eth1 restart"--eth1 is the device; restart is the argument.
 
Old 07-31-2012, 09:05 PM   #3
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,795
Blog Entries: 15

Rep: Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731
BCM4312... Did you blacklist modules "b43" and "ssb" from loading?

This chipset has been known to be problematic for some people to get proper connections. Have you tried a connection manager like Wicd by chance?
 
Old 07-31-2012, 09:10 PM   #4
Mercury305
Member
 
Registered: Jul 2012
Location: Rockville, MD
Distribution: CrunchBang / Ubuntu
Posts: 540

Rep: Reputation: Disabled
just install wicd from extras... life will get much easier.
 
Old 07-31-2012, 09:16 PM   #5
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,795
Blog Entries: 15

Rep: Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731
Wicd isn't always the best solution actually. In fact it can have issues sometimes dropping connections. NetworkManager is a bit better of a connection management toolkit and runs a bit smoother and doesn't tend to have too many issues, at least by comparison to Wicd sometimes.
 
Old 08-01-2012, 03:58 AM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,184

Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
I can't test it right now, but I think the "invalid argument" is "eth1_restart."

My guess is that it should be "eth1 restart"--eth1 is the device; restart is the argument.
The argument "eth1_restart" is correct.

Eric
 
1 members found this post helpful.
Old 08-01-2012, 04:06 AM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,184

Rep: Reputation: Disabled
If you are using wpa_supplicant then this line in rc.inet1.conf is wrong - it causes the error you mention:
Code:
WLAN_KEY[1]="s:mypassword!!"
The WLAN_KEY is for WEP encryption only. Delete it.

Eric
 
1 members found this post helpful.
Old 08-01-2012, 08:55 PM   #8
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,342

Rep: Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387Reputation: 1387
Quote:
The argument "eth1_restart" is correct.
Thank you, Alien_Bob.
 
Old 08-03-2012, 05:34 PM   #9
j9x.inca
Member
 
Registered: Jul 2012
Location: Fort Drum, NY, US
Distribution: Arch Linux
Posts: 63

Original Poster
Rep: Reputation: 2
Wink

Quote:
Originally Posted by Alien Bob View Post
If you are using wpa_supplicant then this line in rc.inet1.conf is wrong - it causes the error you mention:
Code:
WLAN_KEY[1]="s:mypassword!!"
The WLAN_KEY is for WEP encryption only. Delete it.

Eric
Thank you Alien Bob for helping the Slackware community. I'm fairly new to Slackware community and your articles that I've read have helped. I redid my config files and its all good now. Thank you everyone for the replies
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware wireless networking setup w/Broadcom Wireless BCM4311 NIC on HP DV9000 astanton Slackware 14 12-30-2010 07:37 PM
Wireless device crash when wireless network is lost (ubuntu/gutsy on ThinkPad) daganesh Linux - Wireless Networking 6 11-24-2008 05:06 AM
"Linux supported wireless card driver for Linksys wireless-g adaptor? northcoastrat Linux - Desktop 4 07-18-2008 06:33 PM


All times are GMT -5. The time now is 11:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration