LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-03-2010, 02:51 AM   #1
TheSoftRock
LQ Newbie
 
Registered: Apr 2008
Posts: 5

Rep: Reputation: 0
13 2.6.29.6 cryptsetup luks wrong device name in /dev/mapper/*


Slackware 13 Kernel 2.6.29.6 have three hard drives. Root is on own drive sda1. sdb and sdc are raid via mdadm with two partitions. one for /home raid0 md0 one for swap raid1 md1. md0 is encrypted vi cryptsetup. md1 is encrypted vi fstab. everything boots fine and is accessible. However, /dev/mapper/* shows sda1 as block device connected to the raid md0. swap crypted device is correct in /dev/mapper/*. fstab is set correctly. problem seems to be with initrd. I would like the correct device in /dev/mapper so that I can access drive info; size, available space, etc. now info shows only sda1 info. Any help would be appreciated.

Last edited by TheSoftRock; 03-03-2010 at 02:52 AM. Reason: misreference
 
Old 03-04-2010, 05:51 PM   #2
slackwaredanny
Member
 
Registered: Feb 2010
Location: Sweden
Distribution: Slackware
Posts: 88
Blog Entries: 3

Rep: Reputation: 20
alienbob has a guide to make luks/lvm work. And a mkinitrdscript that is very good, maybe that does the trick!

Last edited by slackwaredanny; 03-04-2010 at 06:31 PM. Reason: confusion
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Device Mapper stats wrong markseger Linux - General 0 03-16-2009 12:13 PM
luks cryptsetup and lvm question ruzzed Linux - Software 3 09-16-2007 07:21 PM
cryptsetup-luks question nomb Linux - Software 4 06-14-2007 10:22 AM
cryptsetup and device-mapper problem avallach Linux - Software 5 03-08-2007 11:38 AM
cryptsetup-luks error flying-tuxman Linux - Security 2 11-20-2006 11:08 AM


All times are GMT -5. The time now is 04:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration