LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-30-2011, 04:15 AM   #1
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 308

Rep: Reputation: 22
Question 13.1: sysctl does works at boot time


My aim is to disable ipv6.
So I have:
In /etc/rc.d/rc.S there is(from box)
Code:
# Configure runtime kernel parameters:
if [ -x /sbin/sysctl -a -r /etc/sysctl.conf ]; then
  /sbin/sysctl -e -p /etc/sysctl.conf
fi
my /etc/sysctl.conf
Code:
net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.default.disable_ipv6=1
After bootup and login ifconfig shows my interfaces have linklocal address(fe80:*/64). It is impossible because of /etc/sysctl.conf.
Checking manually /proc/sys/net/ipv6/conf/{default|all}/disable_ipv6 - 0 instead of expected 1.
I rerun /sbin/sysctl -e -p /etc/sysctl.conf manually - all ok.

Why sysctl does not works?! Usually it prints configs it applies, but not during boot seq?
 
Old 06-30-2011, 04:27 AM   #2
Lexus45
Member
 
Registered: Jan 2010
Location: Kurgan, Russia
Distribution: Slackware, Ubuntu
Posts: 339
Blog Entries: 3

Rep: Reputation: 47
Have a try http://blog.zantsev.com/page/2
Write please, if it helped or not.
 
Old 06-30-2011, 07:08 AM   #3
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 308

Original Poster
Rep: Reputation: 22
Lexus45, I know it will help, but this is not I want. I want ipv6 be enabled, but disabled by default(I will enable it later)
 
  


Reply

Tags
boot, ipv6, sysctl


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Start X server and app at boot time (or services load) time. scmbg Linux - General 5 10-15-2009 11:34 PM
Internet works about 5% of the time (Slackware 12.1) Dachy Linux - Networking 8 10-07-2008 02:50 AM
Problem w/ iptables...works most of the time but not always. bitpail Linux - Security 16 12-11-2006 05:01 PM
no signal when starting xorg for the 1st time (but the second time works fine) bungalowbill Linux - Software 0 06-04-2004 10:56 AM
Soundcard works sometimes, not all the time Forezt Fedora 8 03-02-2004 09:18 PM


All times are GMT -5. The time now is 11:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration