LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-05-2014, 07:27 PM   #1
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
0ad error on -current


Hi,

I'm trying to run 0ad which I build using slackbuilds.org/sbopkg. I've run into a number of errors. the first two errors I solved by creating a /usr/share/games/0ad directory and a /usr/share/games/0ad/config directory. Now I'm getting:

Code:
Cache: 200 (total: 5873) MiB
TIMER| InitVfs: 687.44 us
Sound: AlcInit success, using OpenAL Soft
TIMER| CONFIG_Init: 538.239 us
TIMER| InitScripting: 2.19144 ms
ATTENTION: default value of option force_s3tc_enable overridden by environment.
ERROR: CVFSFile: file hwdetect/hwdetect.js couldn't be opened (vfs_load: -110100)
ERROR: Failed to load hardware detection script
TIMER| RunHardwareDetection: 347.708 us
TIMER| write_sys_info: 19.4788 ms
vfs.cpp(105): Function call failed: return value was -110100 (VFS directory not found)
Function call failed: return value was -110100 (VFS directory not found)
Location: vfs.cpp:105 (GetDirectoryEntries)

Call stack:

(0x844e4fc) /usr/games/pyrogenesis() [0x844e4fc]
(0x83ff19c) /usr/games/pyrogenesis() [0x83ff19c]
(0x83ff4e7) /usr/games/pyrogenesis() [0x83ff4e7]
(0x841a8ba) /usr/games/pyrogenesis() [0x841a8ba]
(0x841bab8) /usr/games/pyrogenesis() [0x841bab8]
(0x8174870) /usr/games/pyrogenesis() [0x8174870]
(0x837a877) /usr/games/pyrogenesis() [0x837a877]
(0x81faea9) /usr/games/pyrogenesis() [0x81faea9]
(0x8064e73) /usr/games/pyrogenesis() [0x8064e73]
(0x8058784) /usr/games/pyrogenesis() [0x8058784]
(0xb6cc07a3) /lib/libc.so.6(__libc_start_main+0xf3) [0xb6cc07a3]
(0x8064279) /usr/games/pyrogenesis() [0x8064279]

errno = 0 (?)
OS error = ?
I'm running -current, which is pretty much still 14.1. Can anyone help me with this? I'd really like to try this game.

Thanks in advance.
Brian
 
Old 02-06-2014, 05:13 AM   #2
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
I have the game running here but I updated it to the latest release.

You'll have to use the SlackBuilds directly (no sbopkg) as you need to modify them for the .15 release but other than changing the version number and I think one extra dependency (gloox) and it should be up and running.

FYI gloox is on slackbuilds so it's easy to add to your system
 
Old 02-06-2014, 06:18 AM   #3
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,447

Rep: Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875Reputation: 875
here both the versions on SBo and the latest work fine.
Quote:
Originally Posted by BCarey View Post
I've run into a number of errors. the first two errors I solved by creating a /usr/share/games/0ad directory and a /usr/share/games/0ad/config directory.
that stuff is included in Oad-data (that you have to install as a dependency of 0ad), maybe you have to check that 0ad-data (still from SBo) is installed correctly.
 
Old 02-07-2014, 09:50 AM   #4
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Original Poster
Rep: Reputation: Disabled
Ponce, I reinstalled 0ad-data and all is well. I don't know why it seems to have silently failed the first time. Thanks a lot.

Wildwizard, thanks for the pointer. Now it's running I'll go ahead and upgrade like you suggested.

Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error gdb on current AndreyMaraev Slackware 1 09-25-2012 02:57 PM
[SOLVED] Audacious 3.2.4 error in current cesarion76 Slackware 19 07-20-2012 09:00 AM
[SOLVED] 0AD on Debian Sid. Can I use Ubuntu "PPA"? 273 Debian 15 05-05-2012 07:12 PM
error after upgrading to current o2bfishn Slackware 6 04-18-2006 02:54 PM
error after upgrade to current :( marlor Slackware 2 07-07-2004 04:31 PM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration