LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   *ERROR* mtrr allocation failed (-22) (http://www.linuxquestions.org/questions/slackware-14/%2Aerror%2A-mtrr-allocation-failed-22-a-245841/)

nemesi 10-22-2004 02:15 AM

*ERROR* mtrr allocation failed (-22)
 
Hi guys,
the title of this thread is the output of "dmesg | grep fglrx". Hardware acceleration on my radeon 9600 pro works fine but I wanna solve this little problem. I found this trick but it doesn't work:

Quote:

Where to set the boot parameter: This might be a bit trickier. If you use grub you should check /boot/grub/menu.lst or /boot/menu.lst depending on where your file is located. If you use LILO, check you /etc/lilo.conf file. Open your menu.lst/lilo.conf file and go to the line which says "kernel". There you should find something like:

kernel /boot/vmlinuz root=/dev/hda1 video=vesafb:ywrap,mtrr,vga=0x31X <---- here you need to add the code foun
After changes lilo tell me there is an error! My lilo.conf is:


Quote:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
append="hdc=ide-cd"
boot="/dev/hda"
#compact # faster, but won't work on all systems.
prompt
timeout="300"
# VESA framebuffer console @ 1024x768x256
vga="791"
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
install=/boot/boot-bmp.b
bitmap=/boot/splash.bmp
bmp-colors=38,68,53,112,38,25
bmp-table=114p,347p,2,7
bmp-timer=470p,336p,25,0,11
# End LILO global section
# Linux bootable partition config begins

image="/boot/vmlinuz"
root="/dev/hdb1"
video=vesafb:ywrap,mtrr,vga=0x31X,vram:256
initrd="/boot/initrd"
label="Slackware"
append="splash=silent"
read-only # Non-UMSDOS filesystems should be mounted read-only for checking

image = /boot/linux-2.4.26/vmlinuz
root = /dev/hdb1
label = Original_Kernel
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins

other = /dev/hda1
label = Windows
table = /dev/hda
# Windows bootable partition config ends
Any idea? Have a nice day

Cedrik 10-22-2004 03:55 AM

At image="/boot/vmlinuz" section, try

change :
video=vesafb:ywrap,mtrr,vga=0x31X,vram:256

to:
video=vesa:ywrap,mtrr

If it fails, comment the video line and update the append line like :
append="splash=silent video=vesa:ywrap,mtrr"


All times are GMT -5. The time now is 01:49 AM.