LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   *** YOU'RE USING autoconf (GNU Autoconf) 2.60. KDE requires autoconf 2.52, 2.53 or 2. (http://www.linuxquestions.org/questions/slackware-14/%2A%2A%2A-youre-using-autoconf-gnu-autoconf-2-60-kde-requires-autoconf-2-52-2-53-or-2-a-499198/)

arubin 11-06-2006 03:43 PM

*** YOU'RE USING autoconf (GNU Autoconf) 2.60. KDE requires autoconf 2.52, 2.53 or 2.
 
I have been programming in an amatuer way for years in Pascal, Delphi and Java and thought that as a linux user I ought to have a look at C and programing for kde.

I went to kdevelop and thought I would try a HellowWorld as shown here

http://www.dazzle.plus.com/linux/part01.htm

Straightforward? No I have this error on run automake and friends

*** YOU'RE USING autoconf (GNU Autoconf) 2.60.
*** KDE requires autoconf 2.52, 2.53 or 2.54

Is this a problem with the way kdevelop is set up on slackware. I have never used kdevelop before but shouldn't Helloworld work on Slackware 11.0?

do I need to uninstall autoconf and re-install an earlier version

Eternal_Newbie 11-07-2006 01:38 PM

Hmm, I've just managed to reproduce the same error:
Code:

cd '/home/andrew/programming/hellokde/hellokde' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -f Makefile.cvs && mkdir '/home/andrew/programming/hellokde/hellokde/debug' && cd '/home/andrew/programming/hellokde/hellokde/debug' && CXXFLAGS="-O0 -g3" "/home/andrew/programming/hellokde/hellokde/configure" --enable-debug=full && cd '/home/andrew/programming/hellokde/hellokde/debug/src' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -k hellokde
This Makefile is only for the CVS repository
This will be deleted before making the distribution
<br />
*** YOU'RE USING autoconf (GNU Autoconf) 2.60.
*** KDE requires autoconf 2.52, 2.53 or 2.54
gmake[1]: *** [cvs] Error 1
gmake: *** [all] Error 2
*** Exited with status: 2 ***


I suspect that this is the problem:
Code:

&& WANT_AUTOCONF_2_5="1"
But I have no idea how to change that, I'm only an occasional programmer.

PS: I've occasionally used kdevelop under 10.2 and never encountered this problem.

Eternal_Newbie 11-07-2006 02:48 PM

Just discovered something that might help:

Open the project in kdevelop, then under the 'Project' menu open the 'Project Options' dialog.

Scroll down until you see 'Make Options', click on that and edit 'WANT_AUTOCONF_2_5' and change the value from 1 to 0.

Hopefully that should solve the problem

arubin 11-07-2006 03:22 PM

No. I still get the same problem.

It gets odder. Looking at the changelog even Slackware 9.0 was running 2.57

ppr:kut 11-09-2006 10:24 AM

I had the same problem when compiling a qt-app.
It turned out to be autoconf version 2.5x "hardcoded" into the makefile of the project.
I changed the line
Code:

  Autoconf*2.5* | autoconf*2.5* ) : ;;
to

Code:

  Autoconf*2.5* | autoconf*2.5* | Autoconf*2.6* | autoconf*2.6* ) : ;;
that did the job. After that everything compiled just fine.

arubin 11-09-2006 02:34 PM

I cannot find anything like that in any of the files but I posted this as a bug on the kde site and got this message

Fixed for KDevelop 3.4 and it's possible that it's also fixed for KDevelop 3.3.5 (KDE 3.5.5)

So I will try and upgrade.

Eshadow 09-24-2008 03:31 AM

The line is in the cvs.sh file. But you have to change the next part for in this file for "autoheader" too.


All times are GMT -5. The time now is 09:36 PM.