LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-22-2006, 03:54 AM   #1
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
"**** /sbin/dhcpcd: not running" messages on shutdown/reboot


This isn't really a major problem, but I'd like to get rid of those messages anyway. They look a bit out of place!

I recently installed Slack 10.2 on a new hard drive and the first thing I needed to do was install NDISWrapper, so that I could get online. I did that and after having some problems, I could get an IP address via DHCP from our router. Then, I added two lines to /etc/rc.d/rc.local (as I had done in Slack 10.1):

/etc/rc.d/rc.wireless wlan0
/sbin/dhcpcd wlan0.

The next time I started my machine, I saw a message saying something like "only rc.inet1 can call rc.wireless" (I can't remember the exact wording) and it said to try "/etc/rc.d/rc.inet1 wlan0_start" instead. I replaced the first line of rc.local with that and rebooted. That worked fine and I could get online. When I went to shutdown/reboot again, I received the aforementioned message about dhcpcd not running. I thought this would be solved by commenting out the second line in rc.local, but this did nothing and I still get those messages.

Edit: the lines for wlan0 that I've uncommented in rc.inet1.conf appear below.

IFNAME[4]="wlan0"
USE_DHCP[4]="yes"
WLAN_ESSID[4]=belkin54g
WLAN_MODE[4]=Managed

Any ideas?

Thanks .

Last edited by Nylex; 01-22-2006 at 03:56 AM.
 
Old 01-22-2006, 08:49 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,195

Rep: Reputation: Disabled
Quote:
Originally Posted by Nylex
This isn't really a major problem, but I'd like to get rid of those messages anyway. They look a bit out of place!

I recently installed Slack 10.2 on a new hard drive and the first thing I needed to do was install NDISWrapper, so that I could get online. I did that and after having some problems, I could get an IP address via DHCP from our router. Then, I added two lines to /etc/rc.d/rc.local (as I had done in Slack 10.1):

/etc/rc.d/rc.wireless wlan0
/sbin/dhcpcd wlan0.

The next time I started my machine, I saw a message saying something like "only rc.inet1 can call rc.wireless" (I can't remember the exact wording) and it said to try "/etc/rc.d/rc.inet1 wlan0_start" instead. I replaced the first line of rc.local with that and rebooted. That worked fine and I could get online. When I went to shutdown/reboot again, I received the aforementioned message about dhcpcd not running. I thought this would be solved by commenting out the second line in rc.local, but this did nothing and I still get those messages.

Edit: the lines for wlan0 that I've uncommented in rc.inet1.conf appear below.

IFNAME[4]="wlan0"
USE_DHCP[4]="yes"
WLAN_ESSID[4]=belkin54g
WLAN_MODE[4]=Managed

Any ideas?

Thanks .
Starting with Slackware 10.2 the "rc.wireless" script depends on some configuration work in the rc.inet1 script, and it can no longer run on it's own. But you corrected your addition in rc.local, so no problems there.

However, you should not really have to add "/etc/rc.d/rc.inet1 wlan0_start" in rc.local because Slackware will execute that exact command during booting. With your 4 lines for rc.inet1.conf as shown above you're all set to go. The oly thing I remember about ndiswrapper is that you manually have to load the module because hotplug will not do that for you. You would have to add this line to the bottom of /etc/rc.d/rc.modules:
Code:
/sbin/modprobe ndiswrapper
As for those "**** /sbin/dhcpcd: not running" messages, they are harmless. They occur when you configured a network interface to use DHCP, but then
  1. the interface did not get a network connection
  2. the DHCP client determined that it received an IP address with infinite lease time
In both cases, the dhcpcd program that started for such an interface while booting, will terminate itself. When you finally shutdown the machine, Slackware looks for DHCP configured interfaces and tries to terminate the DHCP client program (dhcpcd) that it expects to still be running. In those cases where the dhcpcd has already terminated, you will see your error message.

Eric
 
Old 01-22-2006, 09:12 AM   #3
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Thanks for the reply Eric. Yeah, I took the line out of rc.local and everything still works ok. I went and checked my rc.modules, but I don't have the "/sbin/modprobe ndiswrapper" line in there. It's weird, because I think I remember having to add it when I was using 10.1 :/.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"shutdown" and "halt" symlinks: poweroff, reboot. sud_crow Linux From Scratch 11 10-17-2006 11:03 PM
redhat9 install hangs at "running\sbin\loader" onedollar Linux - Software 2 12-29-2005 12:19 PM
redhat9 install hangs at "running\sbin\loader" onedollar Linux - Software 3 12-28-2005 09:50 AM
Removing "shutdown" and "reboot" in logout window nearfar Red Hat 1 10-07-2003 11:33 AM


All times are GMT -5. The time now is 09:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration