LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-12-2010, 01:05 AM   #1
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
[Xorg-1.7.5 in Slackware64 -current] still no workie.. Xorg bug?


UPDATE -- July 27 2010

I'm pleased to be able to say that this issue now appears to be resolved. I never got things to work with the versions of drivers & software that this thread is about, but over the 3 months that have passed since I created this thread, it appears that with the latest nVidia driver, and the currently current version of Xorg in Slackware64, the problem has been fixed. Maybe I'll never know what exactly the problem was, but no matter - all is working well now as I type this.

Please see post #91 of thread for currently working versions of Xorg & driver I am using.

Thanks to everyone who provided input & tried to help! I appreciate all of it.

Older update:

UPDATE -- I no longer think kernel .config has much if anything to do with this, so I changed the thread title. It seems to be an Xorg bug, based on info provided by folks in this thread, and by continuing to search the net for info.. So, I no longer request kernel .config files.

I am still trying to figure out why I cannot install and run Xorg-1.7.5 in Slackware-64-current. Soon, I'll hafta say $#%$ it and blacklist Xorg, and stay at 1.6.3 forever.

I believe I've tried pretty much everything..

-- I've used multiple different kernels from 2.6.32.x and 2.6.33 (no RC kernels).
-- I've tried the nvidia driver, the nv driver, and the vesa driver.
-- I've pruned down my xorg.conf to a rather simple version.
-- I've disabled Xinerama, disabled TwinView, disabled my second screen.
-- I've tried 2 or three different nvidia drivers.
-- I've checked and re-checked for missing components, libraries, corrupt packages.
-- I've recompiled my kernel a half-dozen times.
-- I've disabled my wallpaper-setting (fbsetbg) in my WM.
-- I've rebuilt my WM a half dozen times; rebuilt the WM's dependencies; rebuilt the WM again!

I've posted to nvidia's forum; nobody seems to have a clue, and have not had any replies to my thread.. I'm not entirely sure the problem even has anything specifically to do with nvidia anyhow -- as mentioned, I DID clean all proprietary nvidia code from my system and try the vesa driver too, and the `nv` driver also, and these didn't work either.
I also searched their forum for issues relating to the Xorg-1.7.5 but came up pretty empty; same with Google.

I've gone through my generated nvidia-bug-reports myself; of what I do understand from them (quite a bit) indicates no problems. What I do NOT understand from them, well, that's just it -- I don't know what to look for with register dumps and this sort of crap.

Still, I cannot install Xorg-1.7.5 and run `startx` without hanging and/or crashing my machine. It simply does not work.

RIGHT NOW: I am running the Xorg-1.6.3 at this very moment (from Slack64-13) along with the xf86-mouse and xf64-keyboard modules which came with that Xorg-1.6.3, and everything is peachy-perfect. But with ALL OTHER THINGS staying the same, if I upgrade my Xorg to 1.7.5, it no longer works.

I know that pretty much everyone else around here, who has upgraded to -current, is evidently running the new Xorg-1.7.5 without significant issue.

The only thing I can figure to try next, is alter my kernel configuration (again -- yes, I've done this already a few times). I have been using nearly identical kernel configs for the last year or better; I migrate my .config to my next kernel version, check for new/missing features, basic sanity check, and rebuild. No problem. Till now (and maybe it's not the kernel either..)


So, if you fit the following criteria, please email me your /proc/config.gz file, I'd like to diff it against mine.:

1-- you're running -current-64
2-- kernel 2.6.32.8 or 2.6.33 (I'll take very close relatives of these too!)
3-- you have two (or even one) nvidia cards running.
4-- you have one display per card, using Xinerama.
5-- you use nvidia-190.53 driver successfully.

Even if you're kinda similar to the above, I'd be interested in looking at your kernel config. Preferably the kernel versions should be close, the nvidia driver should be the exact same, and ideally ( important ) you should be running two+ displays by some means.


And please -- don't tell me I should buy ATI hardware, or try to sell me dual-head-2-go -- I'm happy with the hardware I have (usually).
If you DO have any suggestions I should try that I may not yet have done, feel free -- I'm listening.

Thanks people.

Sasha

Last edited by GrapefruiTgirl; 07-28-2010 at 05:05 AM. Reason: Title change -- New versions of software have eliminated problem. See post #91
 
Old 03-12-2010, 05:34 AM   #2
Ivshti
Member
 
Registered: Sep 2008
Distribution: Linvo
Posts: 132

Rep: Reputation: 33
I don't think it's the kernel config, however, here is mine, but it might not be very useful for you, since it's not for 64 bit kernel and it's also patched with zenkernel.

http://linvo.org/devel/config

Some questions:
1. Have you tried this on a normal -current without 64 bit support?
2. Have you tried to pre-compile X.org, maybe without HAL support?

You can try with this package, xorg-server 1.7.5.901 which is using udev for auto-configuration instead of HAL: http://linvo.org/repository/linvo-20...901-i686-2.tgz
Remove xorg-server before installing it.
However, it requires all the X packages a usual xorg-server requires from slackware-current (and NOT slackware-13.0), and also all the other updated things from current. Make sure everything is updated, all the series! That may also be the reason why the current thing doesn't work. Also, with the new udev and 2.6.33 kernel, make sure CONFIG_SYSFS_DEPRECATED is disabled, else NOTHING will work!

If the behavior is really the same with the vesa drivers, just try everything on a clean -current with the original slackware kernel. Create a new partition, let's say 6GB, and use installpkg (not the official slackware installer) to install all the series except kde and kdei to a new slackware-current installation. Make sure you have installed the xap/ series, however, since you need some kind of WM, or X will crash! That's a very important thing! It can also be the reason why X doesn't work for you. Try starting kdm or some kind of display manager before doing anything!
http://www.linuxquestions.org/questi...e-13.0-764400/
 
Old 03-12-2010, 06:20 AM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,425

Rep: Reputation: 937Reputation: 937Reputation: 937Reputation: 937Reputation: 937Reputation: 937Reputation: 937Reputation: 937
I'm just running the stock vmlinuz-generic-2.6.33 kernel + modules (note: not a monolithic/'huge' based one).

Blacklisting the nouveau module seems vital to getting anything working for me.

The 'nv' driver just doesn't work at all, no matter what I do.
The 'vesa' driver works fine.
The proprietary 'nvidia' 190.53 driver works fine once you put the nvidia-190.53-2.6.33.patch.txt patch on it

This is just a single card/single display system though, so I don't know how much value this will be to you.
 
Old 03-12-2010, 06:42 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,459

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
Apperently you are not the only person having problems with Xinerama and Xorg-1.7.5. Note the update comment of March 9 in the link below.
http://zuttobenkyou.wordpress.com/20...al-head-setup/

Like GazL, I am running the stock vmlinuz-generic-2.6.33 kernel + modules, with nouveau blacklisted and the patched 190.53 driver on both 32 bit and 64 bit.
I use separate X screens driven by the one GPU to drive my two monitors. which is working fine for me, but is different from your setup.
 
Old 03-12-2010, 06:43 AM   #5
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Thanks you guys -- I'll keep you's posted as to what happens with all this, but probably not much until tonight at the very least -- I've been up all night already so might sleep a lot today

@ Ivshti -- I followed the LQ link you gave, and some of the OTHER links from those links, and find this stuff about "need a display manager, or install KDE" to be distressing. It implies that a WM alone will not be enough (is this right?) which is counter to the exact reason I now use just a nice little WM started from init3/startx and do not have KDE installed.
Sheesh.
-- I have not tried a 32bit -current; there should be enough 32bit users around to figure out those problems
-- I haven't *yet* tried to recompile Xorg, but it IS on the menu for soon. And yes, HAL will be out of it.
-- I *am* using a WM, but not from /xap -- I'm using a non-slack WM called i3: http://i3.zekjur.net/ but I do have ALL of -current installed including the xap tree. Only at this moment of course I have downgraded Xorg, mouse, and kbd packages.
-- I won't install all KDE junk just to try KDM, so I'll see if XDM works instead.


@ GazL - me too, the nv driver does nothing at all for me, never has; it just won't work. But normally (with one screen anyhow) I can use the VESA driver to test stuff, but currently (ha ha) even that doesn't work.
I'm using a patches 190.53 nvidia driver, which installs fine, and works great with Xorg-1.6.3 and any kernel I choose, but not with Xorg-1.7.5. I do have nouveau blacklisted too, even though I haven't ever seen any sign of it being 'around' on my machine.

Many thanks for the tips & help -- updates later!

Sasha
 
Old 03-12-2010, 06:49 AM   #6
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
@ allend - thanks, your post popped up when I posted.

The OP at that link you gave, uses an xorg.conf nearly identical to my own; uses nvidia; and has two monitors the same size as mine. Great comparison!

I will read all the comments, I haven't yet. But I did note that just before the comments, he said he uses Arch, and because the new Xorgs barf at his config file, he's continuing to use Xorg-1.6.3, the same as I am right now, because it STILL WORKS

lol
more reading to do. Thanks again!
Sasha
 
Old 03-12-2010, 08:27 AM   #7
Ivshti
Member
 
Registered: Sep 2008
Distribution: Linvo
Posts: 132

Rep: Reputation: 33
Nope, not KDE. You just need to make sure that startx starts X with _SOMETHING_, else X found itself in a "idle" situation (got nothing to do) and collapsed.

Since startx might be confusing sometimes, and may not start your WM and you may not understand that this is happening, installing a display manager and running it is the best way to find is your X working.

I know this is weird - but as I said, X needs something to run in it since Slackware 13.0, or crashes.
 
Old 03-12-2010, 08:37 AM   #8
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
@ Ivshti -- if I'm not mistaken, KDM is part of KDE, is it not? (I just checked, it does look that way) Which if so, requires installing *some* of KDE to get it.. I'm just going by what I read in one of the threads linked to the one you linked above.

My WM is started from my /etc/X11/xinit/xinitrc file, the same way some other WM or DE are started by that means, and it DOES start. It's just that within 10 seconds or so (or sometimes it waits till I press something or use the mouse) it all freezes up. Most of the time I have to then use Magic SysRq to sync/umount/reboot, but once in a while I can get back to a VT if I'm lucky.
 
Old 03-12-2010, 09:22 AM   #9
GazL
Senior Member
 
Registered: May 2008
Posts: 3,425

Rep: Reputation: 937Reputation: 937Reputation: 937Reputation: 937Reputation: 937Reputation: 937Reputation: 937Reputation: 937
If it's only freezing when you do something like move the mouse/hit a key, then is it possible that it's something to do with input handling, and all that hal hot-plugging nonsense?

have you tried doing it all the old way instead, which is what I do.

xorg.conf extract:
Code:
Section "ServerFlags"
  Option         "AllowEmptyInput" "false"
  Option         "AutoAddDevices" "false"
  Option         "AutoEnableDevices" "false"
EndSection

Section "InputDevice"
    Identifier     "Keyboard1"
    Driver         "kbd"
    Option         "XkbModel" "chicony0420"
    Option         "XkbLayout" "gb"
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5"
EndSection
 
Old 03-12-2010, 12:56 PM   #10
Ivshti
Member
 
Registered: Sep 2008
Distribution: Linvo
Posts: 132

Rep: Reputation: 33
Yes, but KDM isn't the only login manager out there

Anyway, that's really bad. I guess it's HAL. Try using my package, or even easier, the method GazL suggested.
 
Old 03-12-2010, 01:02 PM   #11
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Quote:
Originally Posted by GrapefruiTgirl View Post
@ Ivshti -- if I'm not mistaken, KDM is part of KDE, is it not? (I just checked, it does look that way) Which if so, requires installing *some* of KDE to get it.. I'm just going by what I read in one of the threads linked to the one you linked above.

My WM is started from my /etc/X11/xinit/xinitrc file, the same way some other WM or DE are started by that means, and it DOES start. It's just that within 10 seconds or so (or sometimes it waits till I press something or use the mouse) it all freezes up. Most of the time I have to then use Magic SysRq to sync/umount/reboot, but once in a while I can get back to a VT if I'm lucky.
Which WM?

There is a bug in current releases of Xorg with Fluxbox, and other *box WM's (not OpenBox). Also disabling HAL (AllowEmpty "False") has been reported as causing issues with Xfce <-- Though I believe that one to be more of a config issue personally

http://cgit.freedesktop.org/xorg/xse...dfb0637c20559a

Last edited by disturbed1; 03-12-2010 at 01:04 PM.
 
Old 03-12-2010, 01:08 PM   #12
ReinaldoNS
LQ Newbie
 
Registered: Mar 2010
Distribution: Slackware
Posts: 3

Rep: Reputation: 0
Unhappy

Quote:
Originally Posted by allend View Post
Like GazL, I am running the stock vmlinuz-generic-2.6.33 kernel + modules, with nouveau blacklisted and the patched 190.53 driver on both 32 bit and 64 bit.
I use separate X screens driven by the one GPU to drive my two monitors. which is working fine for me, but is different from your setup.
What is your Xorg setup?

My last upgrade of -current 64 have the same problem of Shinobu comment on link posted. My cursor is unstable on second screen.

I have second Monitor on VGA output of my Notebook working fine before last Xorg update of -current.

I have patched NVidia driver 190.53 with only nouveau blacklisted.

My xorg.conf:
Code:
Section "ServerLayout"
    Identifier     "Simple Layout"
    Screen      0  "Screen0" 1280 0
    Screen      1  "Screen1" LeftOf "Screen0"
    InputDevice    "Mouse1" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "AutoAddDevices" "False"
    Option         "Xinerama" "1"
EndSection

Section "InputDevice"
    Identifier     "Keyboard1"
    Driver         "kbd"
    Option         "XkbModel" "hpzt11xx"
    Option         "XkbLayout" "us_intl"
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CMO"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "DELL E178FP"
    HorizSync       31.0 - 80.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce Go 7400"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce Go 7400"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0; DFP: 800x600 +0+0; DFP: 640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
    Option         "NoLogo" "true"
    Option         "CursorShadow" "true"
EndSection

Section "Screen"
    Identifier     "Screen 1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
    Option         "NoLogo" "true"
    Option         "CursorShadow" "true"
EndSection
 
Old 03-12-2010, 01:39 PM   #13
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Quote:
Originally Posted by allend View Post
Apperently you are not the only person having problems with Xinerama and Xorg-1.7.5. Note the update comment of March 9 in the link below.
http://zuttobenkyou.wordpress.com/20...al-head-setup/

Like GazL, I am running the stock vmlinuz-generic-2.6.33 kernel + modules, with nouveau blacklisted and the patched 190.53 driver on both 32 bit and 64 bit.
I use separate X screens driven by the one GPU to drive my two monitors. which is working fine for me, but is different from your setup.
I'm wondering if xinerama is the culprit here. I'm running the latest -current64 with the generic 2.6.33 kernel and the unpatch 190.53 nvidia driver. As others have stated, I had to blacklist nouveau (couldn't even boot without blacklisting it).

Does your setup work without xinerama and on just one screen?
 
Old 03-12-2010, 02:50 PM   #14
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Original Poster
Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
To address a few recent posts above (now that I'm awake from a nap)

Quote:
Originally Posted by GazL post #9
If it's only freezing when you do something like move the mouse/hit a key, then is it possible that it's something to do with input handling, and all that hal hot-plugging nonsense?

have you tried doing it all the old way instead, which is what I do.
Yes, I've had it "doing it the old way" ever since Slack13 and HAL came along. I have those 3 magic entries in my xorg.conf. Thing is, depending on what other stuff I have commented out (or not) in xorg.conf, the freezing happens even without any input events -- I just run `startx` and sit there and watch without touching anything, and within a few seconds, I see my status-bar clock stop 'clocking', and that's it -- frozen hard.
At the other times (I've changed xorg.conf so many times I'm not sure now which precisely are the options which affect this) it appears to not freeze until I touch the mouse, and then it locks up hard.
Quote:
Originally Posted by Ivshti post #10
Yes, but KDM isn't the only login manager out there
Anyway, that's really bad. I guess it's HAL. Try using my package, or even easier, the method GazL suggested.
yes I know, I was just making the point that it would be painful to install a whack of KDE just to use KDM to start X successfully. I mean to try SLIM one of these days, just haven't yet gotten around to it. Hopefully if I *NEED* to use a DM, that will suffice. If not, then XDM will do as well.

[off-topic] -- I installed some of the newer KDE packages so I could use KWrite a bit today, and got reminded again of why I got rid of KDE -- frikkin working on something and all the sudden *POOF* "Sorry the application encountered an error and had to close...". Ahhh memories coming back from the old MS days :/
[/off-topic]

Quote:
Originally Posted by disturbed1 post #11
Which WM?
There is a bug in current releases of Xorg with Fluxbox, and other *box WM's (not OpenBox). Also disabling HAL (AllowEmpty "False") has been reported as causing issues with Xfce <-- Though I believe that one to be more of a config issue personally.
Which WM? I am using i3 ( http://i3.zekjur.net/ ) which is inspired (but not based on) DWM. Maybe it's similar to the *box WM's but I'm not really sure.
I'll take a look at that FD.org later on and see what it has to say.


@ rmjohnso above post -- Nope, with the Xorg-1.7.5 my setup does not work even with only one monitor/screen enabled. No matter what I tried to adjust or change in xorg.conf, (I did not try physically removing card#2 from the machine, and am not about to) it would not work. It's like \(my system\) with \(Xorg-1.7.5\) is like trying to mix \(pure spring water\) and \(motor oil\) -- simply doesn't work.

Thanks for the continued input!

For the record, here's my xorg.conf (I'm perfectly running this very config as we speak, comments and all, with Xorg-1.6.3):
Code:
Section "ServerLayout"
    Identifier     "default"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    Fontpath        "/usr/share/fonts/CID/"
    FontPath        "/usr/share/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/OTF/"
    FontPath        "/usr/share/fonts/Speedo/"
    FontPath        "/usr/share/fonts/TTF/"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/share/fonts/cyrillic/"
    FontPath        "/usr/share/fonts/misc/:unscaled"
    FontPath        "/usr/local/share/fonts/"
EndSection

Section "Module"
# most (all?!) of these get loaded automatically with the newer Xorgs.
#    Load           "dri"
#    Load           "dri2"
#    Load           "int10"
#    Load           "dbe"
#    Load           "glx"
#    Load           "freetype"
     Load           "fbdevhw"
#    Load           "type1"
#    Load           "extmod"
  SubSection     "extmod"
  # don't initialise the DGA extension
     Option         "omit XFree86-DGA"
  EndSubSection
EndSection

Section "ServerFlags"
    Option         "Xinerama" "True"
#   Option         "RandR"    "False"
    Option         "AutoAddDevices" "False"
    Option         "AutoEnableDevices" "False"
    Option         "AllowEmptyInput" "False"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "device" "/dev/psaux"
    Option         "protocol" "ExplorerPS/2"
    Option         "buttons" "5"
    Option         "zaxismapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "Autorepeat" "500 50"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection

Section "Monitor"
# Samsung TFT Monitor (scr-1.0)
    Identifier     "Samsung0"
    VendorName     "Samsung"
    ModelName      "SyncMaster 2243WM"
#    DisplaySize     442    275
# next line from Xorg log w/ 'nv' driver used
#    DisplaySize     440 300
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
# Samsung TFT Monitor (scr-1.0)
    Identifier     "Samsung1"
    VendorName     "Samsung"
    ModelName      "SyncMaster 2243WM"
#    DisplaySize     442    275
# next line from Xorg log w/ 'nv' driver used
#    DisplaySize     440 300
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"

# primary card
    Identifier     "VideocardA(upperDVI)"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7100 GS"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"

# secondary card
    Identifier     "VideocardB(lowerDVI)"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7300 SE/7200 GS"
    BusID          "PCI:2:0:0"
EndSection

#Section "Device"
# secondary card
#    Identifier     "VideocardB(lowerVGA)"
#    Driver         "nvidia"
#    VendorName     "NVIDIA Corporation"
#    BoardName      "GeForce 7300 SE/7200 GS"
#    BusID          "PCI:2:0:0"
#EndSection

#Section "Device"
# primary card
#    Identifier     "VideocardA(upperVGA)"
#    Driver         "nvidia"
#    VendorName     "NVIDIA Corporation"
#    BoardName      "GeForce 7100 GS"
#    BusID          "PCI:1:0:0"
#EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "VideocardA(upperDVI)"
    Monitor        "Samsung0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "RenderAccel" "False"
    Option         "HWcursor" "On"
    Option         "TwinView" "False"
    Option         "ConnectedMonitor" "DFP"
    Option         "metamodes" "DFP-0: 1680x1050 +0+0"
    Option         "DamageEvents" "True"
    Option         "UseEdidDpi" "False"
#   Option         "NoTwinViewXineramaInfo" "True"
#   Option         "DynamicTwinView" "False"
#   Option         "AllowGLXWithComposite" "true"
  SubSection       "Display"
    Depth           24
  EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "VideocardB(lowerDVI)"
    Monitor        "Samsung1"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "RenderAccel" "False"
    Option         "HWcursor" "On"
    Option         "TwinView" "False"
    Option         "ConnectedMonitor" "DFP"
    Option         "metamodes" "DFP-0: 1680x1050 +0+0"
    Option         "DamageEvents" "True"
    Option         "UseEdidDpi" "False"
#   Option         "NoTwinViewXineramaInfo" "True"
#   Option         "DynamicTwinView" "False"
#   Option         "AllowGLXWithComposite" "true"
  SubSection       "Display"
    Depth           24
  EndSubSection
EndSection

Section "Extensions"
# these two enabled by default?
#  Option    "RENDER"  "False"
#  Option    "DAMAGE"  "False"
# And this doesn't work with Xinerama anyhow:
#  Option "Composite"  "False"
EndSection
 
Old 03-12-2010, 03:21 PM   #15
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Quote:
Originally Posted by GrapefruiTgirl View Post
Which WM? I am using i3 ( http://i3.zekjur.net/ ) which is inspired (but not based on) DWM. Maybe it's similar to the *box WM's but I'm not really sure.
I'll take a look at that FD.org later on and see what it has to say.


@ rmjohnso above post -- Nope, with the Xorg-1.7.5 my setup does not work even with only one monitor/screen enabled. No matter what I tried to adjust or change in xorg.conf, (I did not try physically removing card#2 from the machine, and am not about to) it would not work. It's like \(my system\) with \(Xorg-1.7.5\) is like trying to mix \(pure spring water\) and \(motor oil\) -- simply doesn't work.
Sounds quite similar to this entire conversation to me
http://www.mail-archive.com/arch-gen.../msg11775.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[TESTING REQUEST] Xorg in -current (yes, again) rworkman Slackware 171 10-31-2009 04:49 PM
Xorg config, X not allowing new resolution, works without Xorg config file? bapigoo9 Slackware 5 12-05-2008 12:52 AM
request for old ATI propietary driver for xorg 6.8 (8.12.10) bobbens Linux - Hardware 1 09-04-2005 04:46 AM
I have an XF86 config file for video, how do I turn it into XORG config lowpingnoob Linux - Newbie 18 06-12-2005 12:07 PM
replace 'xfree86' by 'xorg' in your xorg config file dindoung Linux - Newbie 2 02-26-2005 04:43 AM


All times are GMT -5. The time now is 05:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration