LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-22-2009, 08:16 PM   #1
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
[Thinkpad T61] No sound in Slackware 12.2?


Hello everyone,

My built-in alsa module is not working, therefore I have to compile alsa from source code. But now, I still cann't get my sound working.

Details below:
Code:
$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
Code:
$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe020000 irq 17
Code:
$ amixer info
Card default 'Intel'/'HDA Intel at 0xfe020000 irq 17'
  Mixer name    : 'Analog Devices AD1984'
  Components    : 'HDA:11d41984,17aa20d7,00100400'
  Controls      : 29
  Simple ctrls  : 18
Compile alsa-driver with:
Code:
./configure --with-cards=hda-intel,intel8x0,intel8x0m --with-sequencer=yes --with-isapnp=yes
make
sudo make install
Detecting and configuring sound card:
- alsaconf
- alsamixer and unmuted all channels except for Speaker because when I pressed "m", there is a strange noise, and immediatly I pressed "m" to mute it again.
- alsactl store

Code:
$ lsmod | grep snd
snd_hda_intel          29000  0 
snd_seq_dummy           6916  0 
snd_seq_oss            35328  0 
snd_seq_midi_event     10240  1 snd_seq_oss
snd_seq                51696  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10636  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            40608  0 
snd_mixer_oss          18176  1 snd_pcm_oss
snd_hda_codec_analog    62848  1 
snd_hda_codec          64768  2 snd_hda_intel,snd_hda_codec_analog
snd_hwdep              11012  1 snd_hda_codec
snd_pcm                71556  3 snd_hda_intel,snd_pcm_oss,snd_hda_codec
snd_timer              23304  2 snd_seq,snd_pcm
snd                    55972  12 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_analog,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc         12040  2 snd_hda_intel,snd_pcm
soundcore              10080  1 snd
Finding out my model:
Code:
$ head -n 1 /proc/asound/card0/codec#0 
Codec: Analog Devices AD1984
Looking at alsa document:
Code:
AD1984
          basic         default configuration
          thinkpad      Lenovo Thinkpad T61/X61
          dell          Dell T3400
Append the follow line into /etc/modprobe.d/sound:
Code:
options snd-hda-intel model=thinkpad

Test with aplay or any media player but no sound:
Code:
aplay /usr/share/sounds/anyfile.wav
Please help me to get my sound working.

Thanks in advance.

Last edited by quanta; 05-24-2009 at 11:16 AM.
 
Old 05-23-2009, 12:26 AM   #2
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
I have IBM/Lenovo T60. I just tested all the commands mentioned in your post. The results were similar except for the last command: it played the sound. Are you sure the sound card in your T61 is valid? If you aren't sure test it using some live distribution such as Slax.
 
Old 05-23-2009, 01:59 AM   #3
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Original Poster
Rep: Reputation: 100Reputation: 100
Quote:
Originally Posted by w1k0 View Post
I have IBM/Lenovo T60. I just tested all the commands mentioned in your post. The results were similar except for the last command: it played the sound. Are you sure the sound card in your T61 is valid? If you aren't sure test it using some live distribution such as Slax.
You're lucky.

Your mean is --with-cards=hda-intel,intel8x0,intel8x0m when I compiled alsa-driver? I'm sure. Beside, I tried to compile with default options, didn't use --with-cards, and it still isn't working.

I don't like use live CD. Thanks for your reply.
 
Old 05-23-2009, 03:38 AM   #4
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59
Why do you need to compile one, the driver is already part of the kernel. My suggestion is to recompile your kernel and add the driver along with Thinkpad ACPI Laptop Extras or
Code:
modprobe snd-hda-intel
modprobe ibm-acpi
in /etc/modprobe.d/sound try to add these
Code:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
Hope it helps
 
Old 05-23-2009, 04:42 AM   #5
bogzab
Member
 
Registered: Mar 2006
Location: Dyserth, Wales
Distribution: Slackware 13.37, Slackware 14.0
Posts: 260

Rep: Reputation: 31
I have a Lenovo 3000 N200 and with working sound. lspci suggests it has the same card as in your Thinkpad (Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)). However when I query for amixer info I see the Mixer name is "Realtek ALC861-VD" whereas you see 'Analog Devices AD1984'. Not sure now how I configured this - I do recall that sound did not exactly work "out of the box" when I first installed Slackware 12.1 on the laptop, but hope this info might help.
 
Old 05-23-2009, 01:08 PM   #6
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Original Poster
Rep: Reputation: 100Reputation: 100
@Nikosis: I have compiled new kernel (2.6.29.2):
Code:
$ uname -a
Linux slack 2.6.29.2 #1 SMP Thu Apr 30 10:15:02 ICT 2009 i686 Intel(R) Core(TM)2 Duo CPU     T8300  @ 2.40GHz GenuineIntel GNU/Linux
Code:
$ lsmod | grep snd
snd_seq_dummy           2336  0 
snd_seq_oss            25904  0 
snd_seq_midi_event      5376  1 snd_seq_oss
snd_seq                40632  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5480  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            33352  0 
snd_mixer_oss          12256  1 snd_pcm_oss
snd_hda_codec_analog    53428  1 
snd_hda_intel          21984  1 
snd_hda_codec          45924  2 snd_hda_codec_analog,snd_hda_intel
snd_hwdep               5972  1 snd_hda_codec
snd_pcm                57584  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              16556  2 snd_seq,snd_pcm
snd                    44496  13 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
snd_page_alloc          7292  2 snd_hda_intel,snd_pcm
Code:
# modprobe ibm-acpi
FATAL: Module ibm_acpi not found.
The content of /etc/modprobe.d/sound:
Code:
# cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
and... still have no sound.
 
Old 05-23-2009, 11:26 PM   #7
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59
ibm-acpi is not there anymore, I've been using older kernel.
As I can tell, everything seems fine, you should have sound.
I just compiled the same kernel and everything works, just run alsaconf and check if the sound is not muted or switched to headphones only, by default I think, the speakers are turned off, so you have to turn them on.
Code:
amixer cset numid=3 on

Last edited by Nikosis; 05-24-2009 at 02:05 AM.
 
Old 05-24-2009, 01:48 AM   #8
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Original Poster
Rep: Reputation: 100Reputation: 100
Quote:
Originally Posted by Nikosis View Post
ibm-acpi is not there anymore, I've been using older kernel.
OK.
Quote:
Originally Posted by Nikosis View Post
As I can tell, everything seems fine, you should have sound.
I just compiled the same kernel and everything works, just run alsaconf and check if the sound is not muted or switched to headphones only, by default I think, the speakers are turned off, so you have to turn them on.
Code:
amizer cset numid=3 on
I know, the above command is the same to pressed "m" at Speaker channel in alsamixer.

The mistake is: first of all, I always adjust the Master channel to 100 (db Gain=0.00). Then I unmuted the Speaker channel by pressing "m", and there is a "jangle". Immediately I pressed "m" again to mute it.

Now, I have a solution to that problem:
- Adjust the Master channel to 70 (db Gain = -12)
- Mute the Internal channel
- Unmute the Speaker channel
- After that I can adjust the Master column to 100 but still get small cracked sound.

and now I can play sound.

Hope it helps someone when Googling.
Attached Images
File Type: png alsamixer1.png (54.8 KB, 8 views)
File Type: png alsamixer2.png (52.9 KB, 4 views)

Last edited by quanta; 05-24-2009 at 11:19 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware Linux Networking - Thinkpad T61 altuz Linux - Networking 2 02-23-2009 05:32 PM
Slackware 12.0 on a Lenovo Thinkpad T61 Savet Linux - Laptop and Netbook 11 10-29-2008 12:14 AM
alsa on Thinkpad T61 no sound aherrys Slackware 4 07-13-2008 12:00 PM
ThinkPad T61 15.4" with Suse 10- anyone? Michaelus08 Linux - Laptop and Netbook 1 06-16-2008 09:47 AM
Thinkpad Lenovo T61 Nikosis Slackware 33 07-05-2007 06:11 AM


All times are GMT -5. The time now is 04:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration