LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   [SOLVED]Trouble compiling virtualbox Slaceware Current (http://www.linuxquestions.org/questions/slackware-14/%5Bsolved%5Dtrouble-compiling-virtualbox-slaceware-current-4175452534/)

Gumboherpy 03-03-2013 02:09 PM

[SOLVED]Trouble compiling virtualbox Slaceware Current
 
Code:

** Building 'vboxdrv' module ***
make[1]: Entering directory `/tmp/SBo/virtualbox-kernel-4.2.0/vboxdrv'
Makefile:190: *** Error: KERN_DIR does not point to a directory.  Stop.
make[1]: Leaving directory `/tmp/SBo/virtualbox-kernel-4.2.0/vboxdrv'
make: *** [all] Error 2

virtualbox-kernel:
Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.

The kernel is the one that comes installed with Slackware-Current

Code:

bash-4.2# uname -r
3.7.1-smp
bash-4.2#


hitest 03-03-2013 02:25 PM

I'm running the virtualbox package from oracle, it is running without issues on my -current work station. I'm using the package from the "All Distributions" link.

Download VirtualBox for Linux Hosts

Gumboherpy 03-03-2013 02:28 PM

Quote:

Originally Posted by hitest (Post 4903842)
I'm running the virtualbox package from oracle, it is running without issues on my -current work station. I'm using the package from the "All Distributions" link.

Download VirtualBox for Linux Hosts

Code:

bash-4.2# sh VirtualBox-4.2.8-83876-Linux_x86.run
Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation............
VirtualBox Version 4.2.8 r83876 (2013-02-20T16:16:46Z) installer
Please install the build and header files for your current Linux kernel.
The current kernel version is 3.7.1-smp
Problems were found which would prevent VirtualBox from installing.
Please correct these problems and try again.

SLackware is toying with me.....

Gumboherpy 03-03-2013 02:43 PM

I did a
Code:

slackpkg install kernel-source-3.7.1_smp-noarch-1
It works now. Slackware has a bigger learning curve than I thought.

hitest 03-03-2013 02:45 PM

Quote:

Originally Posted by Gumboherpy (Post 4903849)
It works now. Slackware has a bigger learning curve than I thought.

Glad you sorted it out. :)


All times are GMT -5. The time now is 05:56 AM.