LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-29-2008, 03:25 PM   #1
kite
Member
 
Registered: Aug 2003
Location: Shenzhen, China
Distribution: Slackware
Posts: 301

Rep: Reputation: 47
[SOLVED] MS Bluetooth Notebook Mouse 5000 & Slack 12.1


After hours' searching and testing, I got this mouse working under slackware 12.1. But I could not find a way to automatically connect this mouse on system startup. I doubt how I could achive it, because I need to press and hold the bluetooth button on the bottom of the mouse precisely when I issue "hidd --search" for connecting.

Anyone has the same experience?

Code:
 
cat rc.bluetooth.conf
# Bluetooth configuraton file

# Run hid2hci (allowed values are "true" and "false")
HID2HCI_ENABLE=false
HIDD_ENABLED=1
HIDD_OPTIONS="--connect MyMouseMACHere --server"
Code:
cat hcid.conf
#
# HCI daemon configuration file.
#

# HCId options
options {
	# Automatically initialize new devices
	autoinit yes;

	# Security Manager mode
	#   none - Security manager disabled
	#   auto - Use local PIN for incoming connections
	#   user - Always ask user for a PIN
	#
	security auto;

	# Pairing mode
	#   none  - Pairing disabled
	#   multi - Allow pairing with already paired devices
	#   once  - Pair once and deny successive attempts
	pairing multi;

	# Default PIN code for incoming connections
	passkey "";
}


device MyMouseMACHere 
{
name “Microsoft Bluetooth Notebook Mouse 5000”;
}
 
Old 10-30-2008, 04:57 AM   #2
kite
Member
 
Registered: Aug 2003
Location: Shenzhen, China
Distribution: Slackware
Posts: 301

Original Poster
Rep: Reputation: 47
update: the mouse auto reconnect works fine under winxp. But no luck under slackware.
 
Old 11-01-2008, 10:36 AM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
[solution]

I have a Logitech Bluetooth mouse working fine in Slack-12.1.
Does Microsoft actually make anything, like that mouse, or is
it just rebranded? I've had M$ mice before and they were Logitech
OEM mice with a M$ label.

Here's some information to share with you:

Code:
mingdao@jeremiah:~$ dmesg | grep -i bluetooth
Bluetooth: Core ver 2.11
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: HCI USB driver ver 2.9
Bluetooth: L2CAP ver 2.9
Bluetooth: L2CAP socket layer initialized
Bluetooth: HIDP (Human Interface Emulation) ver 1.2
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
Bluetooth: BNEP (Ethernet Emulation) ver 1.2
Bluetooth: BNEP filters: protocol multicast
input: Logitech Bluetooth Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1:1.0/hci0/acl000761D17A8C/input/input9
I just rebooted into Slackware and the bluetooth mouse works fine.

Code:
mingdao@jeremiah:~$ ls -l /etc/rc.d/rc.bluetooth.conf
-rw-r--r-- 1 root root 1050 2008-10-27 21:14 /etc/rc.d/rc.bluetooth.conf
mingdao@jeremiah:~$ cat /etc/rc.d/rc.bluetooth.conf
# /etc/rc.d/rc.bluetooth.conf
#
# This file contains the configuration for the Bluetooth subsystem, BlueZ.

# The lines below allow you to configure which BlueZ daemons will be started,
# along with any daemon-specific options.

# Allowed values for each (unless otherwise noted) are "true" and "false"

# =============================================================================

# The SDP daemon allows clients to detect supported Bluetooth services
SDPD_ENABLE=true

# The HID daemon supports Bluetooth Human Interface Devices
HIDD_ENABLE=true
HIDD_OPTIONS="--server"

# This switches your Bluetooth device into HCI mode, use this if your input
# device does not support Bluetooth HID
HID2HCI_ENABLE=false

# The RFCOMM daemon is used to simulate serial connections over Bluetooth
RFCOMM_ENABLE=true

# The DUN daemon is used for Dial Up Networking over Bluetooth
DUND_ENABLE=false
DUND_OPTIONS="--listen --persist --msdun call dun"

# The PAN daemon is used to setup a Bluetooth network.
PAND_ENABLE=false
PAND_OPTIONS="--listen --role NAP"
Code:
mingdao@jeremiah:~$ ls -l /etc/bluetooth/hcid.conf
-rw-r--r-- 1 root root 1243 2008-10-27 14:18 /etc/bluetooth/hcid.conf
mingdao@jeremiah:~$ cat /etc/bluetooth/hcid.conf
#
# HCI daemon configuration file.
#

# HCId options
options {
        # Automatically initialize new devices
        autoinit yes;

        # Security Manager mode
        #   none - Security manager disabled
        #   auto - Use local PIN for incoming connections
        #   user - Always ask user for a PIN
        #
        security user;

        # Pairing mode
        #   none  - Pairing disabled
        #   multi - Allow pairing with already paired devices
        #   once  - Pair once and deny successive attempts
        pairing multi;

        # Default PIN code for incoming connections
        passkey "1234";
}

# Default settings for HCI devices
device {
        # Local device name
        #   %d - device id
        #   %h - host name
        name "%h-%d";

        # Local device class
        class 0x000100;

        # Default packet type
        #pkt_type DH1,DM1,HV1;

        # Inquiry and Page scan
        iscan enable; pscan enable;
        discovto 0;

        # Default link mode
        #   none   - no specific policy
        #   accept - always accept incoming connections
        #   master - become master on incoming connections,
        #            deny role switch on outgoing connections
        lm accept;

        # Default link policy
        #   none    - no specific policy
        #   rswitch - allow role switch
        #   hold    - allow hold mode
        #   sniff   - allow sniff mode
        #   park    - allow park mode
        lp rswitch,hold,sniff,park;
}
Code:
mingdao@jeremiah:~$ sudo ls -l /etc/bluetooth/passkeys/default
-rw-r--r-- 1 root root 5 2008-10-27 17:33 /etc/bluetooth/passkeys/default
mingdao@jeremiah:~$ sudo cat /etc/bluetooth/passkeys/default
1234
I never press the button, run a command again, or anything.

It works in:
Slackware-12.1
Kubuntu-8.04.1-desktop-amd64
Windows XP Pro
Windows Vista Ultimate 32-bit

Hope this information is of some use and help to you.

Edit: Make sure this file is executable:

mingdao@jeremiah:~$ ls -l /usr/sbin/hcid
-rwxr-xr-x 1 root root 253640 2008-09-18 14:01 /usr/sbin/hcid

Last edited by XavierP; 11-01-2008 at 06:57 PM.
 
Old 11-01-2008, 02:03 PM   #4
kite
Member
 
Registered: Aug 2003
Location: Shenzhen, China
Distribution: Slackware
Posts: 301

Original Poster
Rep: Reputation: 47
Thanks a lot Bruce. You have real Kongfu to show

It seems that "SDPD_ENABLE=true" and "RFCOMM_ENABLE=true" were missing from my /etc/rc.d/rc.bluetooth.conf
I added them and did a /etc/rc.d/rc.bluetooth restart and found that my mouse resumed to work after a single press on the bluetooth bottom.

Problem solved.
 
  


Reply

Tags
bluetooth, mouse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth mouse and keyboard connect, mouse doesn't work BallsOfSteel Linux - Hardware 2 05-25-2008 02:09 AM
Mouse Microsoft Wireless Notebook Optical Mouse 4000 on SLED 10 Aleksej Linux - Hardware 1 01-12-2007 10:54 PM


All times are GMT -5. The time now is 02:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration