LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   [SOLVED] MS Bluetooth Notebook Mouse 5000 & Slack 12.1 (http://www.linuxquestions.org/questions/slackware-14/%5Bsolved%5D-ms-bluetooth-notebook-mouse-5000-and-slack-12-1-a-679821/)

kite 10-29-2008 02:25 PM

[SOLVED] MS Bluetooth Notebook Mouse 5000 & Slack 12.1
 
After hours' searching and testing, I got this mouse working under slackware 12.1. But I could not find a way to automatically connect this mouse on system startup. I doubt how I could achive it, because I need to press and hold the bluetooth button on the bottom of the mouse precisely when I issue "hidd --search" for connecting.

Anyone has the same experience?

Code:


cat rc.bluetooth.conf
# Bluetooth configuraton file

# Run hid2hci (allowed values are "true" and "false")
HID2HCI_ENABLE=false
HIDD_ENABLED=1
HIDD_OPTIONS="--connect MyMouseMACHere --server"

Code:

cat hcid.conf
#
# HCI daemon configuration file.
#

# HCId options
options {
        # Automatically initialize new devices
        autoinit yes;

        # Security Manager mode
        #  none - Security manager disabled
        #  auto - Use local PIN for incoming connections
        #  user - Always ask user for a PIN
        #
        security auto;

        # Pairing mode
        #  none  - Pairing disabled
        #  multi - Allow pairing with already paired devices
        #  once  - Pair once and deny successive attempts
        pairing multi;

        # Default PIN code for incoming connections
        passkey "";
}


device MyMouseMACHere
{
name “Microsoft Bluetooth Notebook Mouse 5000”;
}


kite 10-30-2008 03:57 AM

update: the mouse auto reconnect works fine under winxp. But no luck under slackware.

Bruce Hill 11-01-2008 09:36 AM

[solution]
 
I have a Logitech Bluetooth mouse working fine in Slack-12.1.
Does Microsoft actually make anything, like that mouse, or is
it just rebranded? I've had M$ mice before and they were Logitech
OEM mice with a M$ label.

Here's some information to share with you:

Code:

mingdao@jeremiah:~$ dmesg | grep -i bluetooth
Bluetooth: Core ver 2.11
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: HCI USB driver ver 2.9
Bluetooth: L2CAP ver 2.9
Bluetooth: L2CAP socket layer initialized
Bluetooth: HIDP (Human Interface Emulation) ver 1.2
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
Bluetooth: BNEP (Ethernet Emulation) ver 1.2
Bluetooth: BNEP filters: protocol multicast
input: Logitech Bluetooth Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1:1.0/hci0/acl000761D17A8C/input/input9

I just rebooted into Slackware and the bluetooth mouse works fine.

Code:

mingdao@jeremiah:~$ ls -l /etc/rc.d/rc.bluetooth.conf
-rw-r--r-- 1 root root 1050 2008-10-27 21:14 /etc/rc.d/rc.bluetooth.conf
mingdao@jeremiah:~$ cat /etc/rc.d/rc.bluetooth.conf
# /etc/rc.d/rc.bluetooth.conf
#
# This file contains the configuration for the Bluetooth subsystem, BlueZ.

# The lines below allow you to configure which BlueZ daemons will be started,
# along with any daemon-specific options.

# Allowed values for each (unless otherwise noted) are "true" and "false"

# =============================================================================

# The SDP daemon allows clients to detect supported Bluetooth services
SDPD_ENABLE=true

# The HID daemon supports Bluetooth Human Interface Devices
HIDD_ENABLE=true
HIDD_OPTIONS="--server"

# This switches your Bluetooth device into HCI mode, use this if your input
# device does not support Bluetooth HID
HID2HCI_ENABLE=false

# The RFCOMM daemon is used to simulate serial connections over Bluetooth
RFCOMM_ENABLE=true

# The DUN daemon is used for Dial Up Networking over Bluetooth
DUND_ENABLE=false
DUND_OPTIONS="--listen --persist --msdun call dun"

# The PAN daemon is used to setup a Bluetooth network.
PAND_ENABLE=false
PAND_OPTIONS="--listen --role NAP"

Code:

mingdao@jeremiah:~$ ls -l /etc/bluetooth/hcid.conf
-rw-r--r-- 1 root root 1243 2008-10-27 14:18 /etc/bluetooth/hcid.conf
mingdao@jeremiah:~$ cat /etc/bluetooth/hcid.conf
#
# HCI daemon configuration file.
#

# HCId options
options {
        # Automatically initialize new devices
        autoinit yes;

        # Security Manager mode
        #  none - Security manager disabled
        #  auto - Use local PIN for incoming connections
        #  user - Always ask user for a PIN
        #
        security user;

        # Pairing mode
        #  none  - Pairing disabled
        #  multi - Allow pairing with already paired devices
        #  once  - Pair once and deny successive attempts
        pairing multi;

        # Default PIN code for incoming connections
        passkey "1234";
}

# Default settings for HCI devices
device {
        # Local device name
        #  %d - device id
        #  %h - host name
        name "%h-%d";

        # Local device class
        class 0x000100;

        # Default packet type
        #pkt_type DH1,DM1,HV1;

        # Inquiry and Page scan
        iscan enable; pscan enable;
        discovto 0;

        # Default link mode
        #  none  - no specific policy
        #  accept - always accept incoming connections
        #  master - become master on incoming connections,
        #            deny role switch on outgoing connections
        lm accept;

        # Default link policy
        #  none    - no specific policy
        #  rswitch - allow role switch
        #  hold    - allow hold mode
        #  sniff  - allow sniff mode
        #  park    - allow park mode
        lp rswitch,hold,sniff,park;
}

Code:

mingdao@jeremiah:~$ sudo ls -l /etc/bluetooth/passkeys/default
-rw-r--r-- 1 root root 5 2008-10-27 17:33 /etc/bluetooth/passkeys/default
mingdao@jeremiah:~$ sudo cat /etc/bluetooth/passkeys/default
1234

I never press the button, run a command again, or anything.

It works in:
Slackware-12.1
Kubuntu-8.04.1-desktop-amd64
Windows XP Pro
Windows Vista Ultimate 32-bit

Hope this information is of some use and help to you.

Edit: Make sure this file is executable:

mingdao@jeremiah:~$ ls -l /usr/sbin/hcid
-rwxr-xr-x 1 root root 253640 2008-09-18 14:01 /usr/sbin/hcid

kite 11-01-2008 01:03 PM

Thanks a lot Bruce. You have real Kongfu to show :)

It seems that "SDPD_ENABLE=true" and "RFCOMM_ENABLE=true" were missing from my /etc/rc.d/rc.bluetooth.conf
I added them and did a /etc/rc.d/rc.bluetooth restart and found that my mouse resumed to work after a single press on the bluetooth bottom.

Problem solved.


All times are GMT -5. The time now is 10:12 PM.