LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-26-2009, 06:48 PM   #1
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Rep: Reputation: 31
Exclamation [SOLVED] Having problem with KDM themes on Slackware 12.2


Hello all this is my post here. Long time troller and I can usually figure things out. This time though I am stuck as to where to even start.

I am running Slackware 12.2 with kde 2.5.10 and kernel 2.6.29.6 i686.

When I try to enable themes I get this error "The application KDE Control Center (kcontrol) crashed and caused the signal 11 (SIGSEGV).

I run the back trace and here is the result.

Code:
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb697f6e0 (LWP 26588)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0xb75551c7 in QString::utf8 () from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#6  0xb787f22a in KConfigBase::writeEntry () from /usr/lib/libkdecore.so.4
#7  0xb787f35b in KConfigBase::writeEntry () from /usr/lib/libkdecore.so.4
#8  0xb6032913 in KDMThemeWidget::save () from /usr/lib/kde3/kcm_kdmtheme.so
#9  0xb68f164b in ProxyWidget::applyClicked ()
   from /usr/lib/libkdeinit_kcontrol.so
#10 0xb68f2e5c in ProxyWidget::qt_invoke ()
   from /usr/lib/libkdeinit_kcontrol.so
#11 0xb7292a7d in QObject::activate_signal ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#12 0xb72935fd in QObject::activate_signal ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#13 0xb75a630c in QButton::clicked ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#14 0xb7323c5d in QButton::mouseReleaseEvent ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#15 0xb72c95c4 in QWidget::event () from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#16 0xb723515a in QApplication::internalNotify ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#17 0xb7235e7a in QApplication::notify ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#18 0xb7869672 in KApplication::notify () from /usr/lib/libkdecore.so.4
#19 0xb71d72b1 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#20 0xb71d5c23 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#21 0xb71e625d in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#22 0xb724b720 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#23 0xb724b5b6 in QEventLoop::exec ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#24 0xb7234bbf in QApplication::exec ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#25 0xb68dca72 in kdemain () from /usr/lib/libkdeinit_kcontrol.so
#26 0xb77746e4 in kdeinitmain () from /usr/lib/kde3/kcontrol.so
#27 0x0804eb00 in ?? ()
#28 0x00000007 in ?? ()
#29 0x08078950 in ?? ()
#30 0x00000001 in ?? ()
#31 0x00000000 in ?? ()
Now I am not running qt-3.3 I have upgraded to qt4. This is throwing me for a loop here and any help will be greatly appreciated.

Last edited by AuroraZero; 10-29-2009 at 04:22 AM.
 
Old 10-28-2009, 07:04 PM   #2
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Original Poster
Rep: Reputation: 31
Okay just a little update here. I have reinstalled qt 3 to no avail. I have also compiled form source the theme manger. Still the exact same error. I now believe there is a bug in the qt3 package I used to install it and I shall have to re download it and compile it from source. What a pain on dial up!!!

Before anyone asks no they do not offer broadband here unless it is satellite. Which costs 3 arms and 4 legs. $$$$$
 
  


Reply

Tags
crash, error, kdm, theme


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware - KDM issues returnzero Linux - Newbie 3 06-13-2009 11:55 AM
how to configure kdm in slackware 12.2 Vlad420 Slackware 7 05-21-2009 01:23 AM
slackware install problem no gdm or kdm dlogiudice Slackware 2 03-27-2009 01:00 PM
KDM on slackware masand Slackware 9 11-02-2005 04:01 AM
Can I use KDM in Slackware 9? Seph64 Slackware 3 05-02-2003 03:51 PM


All times are GMT -5. The time now is 10:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration