LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-14-2011, 08:36 AM   #1
Z0K4
Member
 
Registered: Sep 2011
Location: Split, Croatia
Distribution: Slackware, Fedora
Posts: 86

Rep: Reputation: 4
[Solved] Brightness set to zero in Salix OS on eMachines with Intel's GMA4500


Greetings forum!

So, I have a problem: I just finished installing Salix OS on my eMachines laptop. I didn't encounter any problems during the installation, but after rebooting, screen brightness is set to 0! I tried with Fn keys but they didn't help... I think it's kernel thing because I tried Ubuntu Live CD and the result was the same: backlight turned off!

Salix is fully backward compatible with Slackware so there should be no problems applying your solutions for Slackware to Salix OS.

Thank you in advance!

Last edited by Z0K4; 09-15-2011 at 06:16 PM.
 
Old 09-14-2011, 09:38 AM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Take a look in /sys/class/backlight/ - you should see a 'brightness' entry. If you cat it, you will get the current value. You can set it with something like:
Code:
echo -n 5 > /sys/class/backlight/xxxx/brightness
If that works, you can place the command in your rc.local so it's set at system boot, or in .bash_profile to set it at login (or both).
 
Old 09-14-2011, 10:03 AM   #3
Z0K4
Member
 
Registered: Sep 2011
Location: Split, Croatia
Distribution: Slackware, Fedora
Posts: 86

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by macemoneta View Post
Take a look in /sys/class/backlight/ - you should see a 'brightness' entry. If you cat it, you will get the current value. You can set it with something like:
Code:
echo -n 5 > /sys/class/backlight/xxxx/brightness
If that works, you can place the command in your rc.local so it's set at system boot, or in .bash_profile to set it at login (or both).
Unfortunately this didn't work. I found brightness entry and used cat command! Value was 9 so I did as you sad:
Code:
echo -n 5 > /sys/class/backlight/acpi_video0/brightness
Brightness was still at 0, so instead of 5 I've put 50 it returned wrong argument or something like that! So I put it back to 9. Do you have any other suggestions?

Thank you for your help!
 
Old 09-14-2011, 10:11 AM   #4
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Some eMachines require that a kernel parameter be added to whatever bootloader you are using:
Code:
acpi_osi=Linux
 
Old 09-14-2011, 10:19 AM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
Quote:
Originally Posted by Z0K4 View Post
Greetings forum!

Salix is fully backward compatible with Slackware so there should be no problems applying your solutions for Slackware to Salix OS.
Did you try installing Slackware on that machine to see whether your statement is actually true?

Eric
 
Old 09-14-2011, 10:20 AM   #6
Z0K4
Member
 
Registered: Sep 2011
Location: Split, Croatia
Distribution: Slackware, Fedora
Posts: 86

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by macemoneta View Post
Some eMachines require that a kernel parameter be added to whatever bootloader you are using:
Code:
acpi_osi=Linux
I use LiLo. Can you tell me how can I edit the configuration file and what to do after that?
 
Old 09-14-2011, 10:24 AM   #7
Z0K4
Member
 
Registered: Sep 2011
Location: Split, Croatia
Distribution: Slackware, Fedora
Posts: 86

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by Alien Bob View Post
Did you try installing Slackware on that machine to see whether your statement is actually true?

Eric
Well, no... Hell, I don't even know how to install Slackware. That's what I was told, that they are compatible and that both slackers and Salix users benefit from each other! If I'm wrong I apologize!
 
Old 09-14-2011, 10:30 AM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,394

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Quote:
Brightness was still at 0, so instead of 5 I've put 50 it returned wrong argument or something like that! So I put it back to 9.
On my eMachines EM250 (not yours as you have a different graphics chipset),when I do 'cat /sys/class/backlight/acpi_video0/max_brightness', the value returned is 9.
It seems that the maximum brightness is already set on your machine.

Oh, and with Slackware, I have no problems with brightness. Function keys work as advertised. KDE power management brightness settings are obeyed.
 
1 members found this post helpful.
Old 09-14-2011, 10:43 AM   #9
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Quote:
Originally Posted by Z0K4 View Post
I use LiLo. Can you tell me how can I edit the configuration file and what to do after that?
Edit /etc/lilo.conf and add the parameter to the 'append=' (add it if needed). For example:
Code:
image=/boot/vmlinuz-XXXXXXX
  label=linux
  read-only
  root=/dev/hdaX
  initrd=/boot/initrd-XXXXXX.img
  append="someOption someOtherOption acpi_osi=Linux"
Then rerun the lilo command to update the boot.
 
Old 09-14-2011, 11:15 AM   #10
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,394

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
For some other possibilities, if the fix suggested by macemoneta does not work, see here. http://ubuntuforums.org/showthread.php?p=10591451
 
1 members found this post helpful.
Old 09-14-2011, 11:25 AM   #11
Z0K4
Member
 
Registered: Sep 2011
Location: Split, Croatia
Distribution: Slackware, Fedora
Posts: 86

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by macemoneta View Post
Edit /etc/lilo.conf and add the parameter to the 'append=' (add it if needed).

Then rerun the lilo command to update the boot.
I added acpi_osi=Linux to append and after that:
Code:
/sbin/lilo
then rebooted but nothing changed... unfortunately.
Should I remove acpi_osi=Linux from append, or just leave it there?

Quote:
Originally Posted by allend View Post
On my eMachines EM250 (not yours as you have a different graphics chipset),when I do 'cat /sys/class/backlight/acpi_video0/max_brightness', the value returned is 9.
It seems that the maximum brightness is already set on your machine.

Oh, and with Slackware, I have no problems with brightness. Function keys work as advertised.
My Fn keys also work, I mean, I can barely see that but when I hit proper combination it says that screen brightness is changed but it's not. I also want Slackware, but I don't know nothing about it! That is way I choose Slackware based distribution that is more or less compatible with Slackware.

Quote:
Originally Posted by allend View Post
For some other possibilities, if the fix suggested by macemoneta does not work, see here. http://ubuntuforums.org/showthread.php?p=10591451
Thank you I'll check this out!
 
Old 09-14-2011, 11:31 AM   #12
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Quote:
Originally Posted by Z0K4 View Post
I added acpi_osi=Linux to append and after that:
Code:
/sbin/lilo
then rebooted but nothing changed... unfortunately.
Should I remove acpi_osi=Linux from append, or just leave it there?
If it's not working, and you can't see any change in /sys behavior, then you might as well remove it.
 
Old 09-14-2011, 06:10 PM   #13
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64
Posts: 133

Rep: Reputation: 19
You might want to try this kernel parameter
Code:
acpi_backlight=vendor
 
Old 09-15-2011, 01:22 AM   #14
Z0K4
Member
 
Registered: Sep 2011
Location: Split, Croatia
Distribution: Slackware, Fedora
Posts: 86

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by dr.s View Post
You might want to try this kernel parameter
Code:
acpi_backlight=vendor
I've tried that one last night. It only disabled my Fn +/- brightness key!
What did help me was this code (must be super user):
Code:
setpci -s 00:02.0 F4.B=7F
Now brightness is always at 40-50% till I reboot, and then is reset to 0%... I even don't know what this code stands for, does it harm my hardware... because I can see hexadecimal code, and something similar is used in asembler language!

Thank you for your help guys! Any other ideas?

Regards!
 
Old 09-15-2011, 09:16 AM   #15
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,394

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Just found another link that is relevant. http://forums.gentoo.org/viewtopic-t...6-start-0.html
Appears to be a bug that will need to be addressed upstream.
The command simply writes to the pci register that controls the backlight. I do not see how it will do any damage.
You could try writing F4.B=00 and see whether it affects your brightness level.

Last edited by allend; 09-15-2011 at 09:37 AM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Brightness set to zero: moved to http://www.linuxquestions.org/questions/slackware-14/brightness-set Z0K4 Linux - Laptop and Netbook 5 09-15-2011 10:09 AM
Is anyone using Salix? windtalker10 Slackware 26 07-10-2010 10:10 PM
Brightness problems on an Intel 845 brandnew427 Linux - Hardware 2 12-20-2009 11:14 PM
Using the Appledisplay module to set monitor brightness njbailey Linux - Kernel 2 10-16-2006 08:17 AM
Sony vaio vgn-b55g lcd brightness can't be set Habu Linux - Laptop and Netbook 1 02-19-2006 05:45 PM


All times are GMT -5. The time now is 04:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration