LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   [Slackware 10.2] Network isn't working (http://www.linuxquestions.org/questions/slackware-14/%5Bslackware-10-2%5D-network-isnt-working-378533/)

dubbeld00 10-31-2005 01:50 AM

[Slackware 10.2] Network isn't working
 
As the title says, my network won't be able to work.

The installer autodetects de4x5. After I installed the PC and using netconfig to set up my network correctly (my router doesn't use a DHCP so I'd to set up it manually) it still doesn't work.

The light on my isn't burning, when using ifconfig I see that there are 20 errors

eth0 Link encap:Ethernet HWaddr 00:50:8B:4C:03:74
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:20 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x2000

(This is an error I found that's the same as mine except that I'm using the following configuration:
IP 192.168.2.3
Subnetmask 255.255.255.0
gateway 192.168.2.1
nameserver 192.168.2.1)

So I thought it might be the driver that's incorrect... I googled on the pc (a Compaq Presario 5686) And saw that I wasn't the only having problems. The PC is using a DS21143 NIC, and should use tulip (not de4x5),

so I configured /etc/rc.d/rc.modules, commented the area where it's searching what driver you had configured during install (in my case it was the de4x5) and decommented the line /???/modprobe tulip.

Then I rebooted the PC and still had errors when I looked at ifconfig.

route -n gives:
Dest gateway mask flags Iface use
192.168.2.0 0.0.0.0 255.255.255.0 U eth0 0
127.0.0.0 0.0.0.0 255.255.255.0 U lo 0
0.0.0.0 192.168.2.1 255.255.255.0 UG eth0 0

How can I fix it?

zhangmaike 10-31-2005 02:48 AM

According to the output from ifconfig, it looks like eth0 is configured with the wrong IP address (192.168.0.1).

If you want this configuration:

Quote:

IP 192.168.2.3
Subnetmask 255.255.255.0
gateway 192.168.2.1
nameserver 192.168.2.1
try the following commands (as root):

Code:

ifconfig eth0 192.168.2.3 up
ifconfig eth0 netmask 255.255.255.0
route add default gw 192.168.2.1 eth0

Since your routing table (from route -n) and netmask already look okay, the last two commands probably won't do anything, but they won't hurt either.

And make sure that the line

Code:

nameserver 192.168.2.1
is in your /etc/resolv.conf file.

dubbeld00 10-31-2005 02:57 AM

I've allready configurated that... (but tried it again but still it doesn't work)

The only problem is that my NIC doesn't work. If I type ifconfig i see:

eth0 Link encap:Ethernet HWaddr 00:50:8B:4C:03:74
inet addr:192.168.2.3 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:20 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x2000

(I copied it from internet, b.c. it was the same error... only forgot to change the IP adresses...)

zhangmaike 10-31-2005 03:01 AM

After doing those commands, can you ping your router or yourself (192.168.2.3 not 127.0.0.1)

dubbeld00 10-31-2005 03:04 AM

I can ping 192.168.2.3
I can't ping my router (or any other device thats in the network)
192.168.2.1 (my router) it's set up to reply to a ping... so that won't be the problem...

PING 192.168.2.1 (192.168.2.1) from 192.168.2.3 : 56(84) bytes of data.
>From 192.168.2.3: Destination Host Unreachable
>From 192.168.2.3: Destination Host Unreachable

Like i said... I think my NIC is the problem (It's working in win 98 so it isn't broken) not the configuration

zhangmaike 10-31-2005 03:23 AM

Hmmm... According to the de4x5 documentation, that driver supports several chipsets including DC21143. Although yours was typed with an S, the similarity is striking... and since the driver was loaded automatically in the first place, I'd try those commands again with the original driver (de4x5) loaded instead of tulip.

dubbeld00 10-31-2005 03:30 AM

I've configurated that one before... But when I found out that the de4x5 doesn't worked, I tried tulip (that also supports the DS21143 (You are talking about a DC don't know if it's a typo, b.c. I'm talking about a DS21143)) that supports this card (also?).

By the way, in installation (NETWORK command) if I skip the de4x5 It comes with tulip as working driver...

I also installed it 6 times (3 times with the de4x5 and 3 times with the tulip) but de4x5 AND tulip gives:

eth0 Link encap:Ethernet HWaddr 00:50:8B:4C:03:74
inet addr:192.168.2.3 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:20 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x2000

I can't ping (except my own IP and 127.0.0.1) and my routers LED isn't burning (so there is no connection between my NIC and router)

Alien Bob 10-31-2005 04:12 AM

Indeed, it looks like the connection between your NIC and the switch is not working. That could mean a faulty cable, or a handshake mismatch, or the network connector has burnt out... etc..
The eth0 interface itself seems to be functional. The problem appears not to be Slackware related.

What do the commands
Code:

ethtool eth0
and/or
Code:

mii-tool
tell you?

Eric

dubbeld00 10-31-2005 04:32 AM

LAN is working on windows 98... so I think there is nothing damaged on my NIC.

So I've tested it with an other LAN cable (cat 5 only 1 meter long... so that should not give any data losses). This cable is working on my other linux pc so should work.

Tested it with both drivers (de4x5 and tulip) both not working


ethtool eth0
Settings for eth0:
No data available

mii-tool:
eth0: no link

Edit:
The LAN Cable I used is also working... (checked it on an other PC)... I could ping my router without packet losses...

dubbeld00 10-31-2005 04:51 AM

Found something:

mii-tool -l gives:
100mbit half duplex no link...

But it's a:
10 Mbps Ethernet Port

Might this be the problem, and how can I solve it....


Edit:

dmesg:
using tulip...

*** WARNING *** No MII transceiver found...


by forcing it to use 10mbit...

mii-tool -F 10baseT-FD eth0

and you check the status again... its back to 100mbit

by forcing it with modprobe tulip options=10

10mbit full duplex no link

_____
Using de4x5

seems to work but when using:
mii-tools:

comes with an error: SIOCGMIIPHY on eth0 operation not supported no MII interface found...

mii-tools won't work using de4x5

Alien Bob 10-31-2005 05:40 AM

From the driver's source code:
Code:

Command  line arguments are  now  allowed, similar  to passing arguments
    through LILO. This will allow a per adapter board  set up of full duplex
    and media. The only lexical constraints  are: the board name (dev->name)
    appears in the list before its  parameters.  The list of parameters ends
    either at the end of the parameter list or with another board name.  The
    following parameters are allowed:

            fdx        for full duplex
            autosense  to set the media/speed; with the following
                      sub-parameters:
                      TP, TP_NW, BNC, AUI, BNC_AUI, 100Mb, 10Mb, AUTO

    Case sensitivity is important  for  the sub-parameters. They *must*  be
    upper case. Examples:

        insmod de4x5 args='eth1:fdx autosense=BNC eth0:autosense=100Mb'.

So, you could try what happens if you force the driver to use 10Mbit by adding this to /etc/modules.conf (assuming you're using a 2.4 kernel:

Code:

options de4x5 args='eth0:fdx autosense=10Mb'
ans see if that helps. Try other mixes of driver arguments if the above line does not fix it.

Eric

dubbeld00 10-31-2005 06:05 AM

Thanks all

options de4x5 args='eth0:fdx autosense=10Mb'

works :D

maginotjr 10-31-2005 08:17 AM

incredible how some threads can go deep and realy found the problem.. I dont have nothing with this problem, but was interesting following it up....

:D

:cool:

ekorn 06-13-2009 02:28 PM

Quote:

Originally Posted by dubbeld00 (Post 1928570)
options de4x5 args='eth0:fdx autosense=10Mb'
works :D

I'm sorry to resurrect an old thread, but this sounds like a solution for my predicament too (on the same model, Compaq Presario 5686). However, I'm using Puppy Linux 4.2.1, which uses kernel 2.6 and therefore modprobe.conf instead of modules.conf.
Just copying the "options" line above to /etc/modprobe.conf didn't work; instead, it prevented the Puppy Linux network wizard from detecting my network card. Could somebody please tell me how to make the equivalent change in modprobe.conf? Is there a way to test such settings without having to reboot the computer? Any help is greatly appreciated.

Alien Bob 06-13-2009 02:36 PM

This is a Slackware forum. Please take your Puppy Linux question to the Puppy Linux forum and next time, do not resurrect a thread that has been dead for nearly four years.

Eric


All times are GMT -5. The time now is 05:42 AM.