LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-30-2010, 02:56 PM   #1
brooko
Member
 
Registered: Nov 2009
Posts: 35

Rep: Reputation: 0
[SBo] minitube - missing mpeg4 aac


Just installed minitube v1.1 via sbopkg. Video plays but there's no sound and i get the following error message *edit* actually nothing much happens no video or sound. It just displays the title of the videos in the list without playing.

Code:
Phonon error: "A required codec is missing. You need to install the following codec(s) to play this content: MPEG-4 AAC" 2
I have faad2 installed which is a "MPEG2 and MPEG 4 AAC decoder" but thats not listed as a dependency anyway, only QT >=4.5 which i have.

On the minitube home page it suggests removing xine phono backend if there's no sound, but i'm not even sure if this is installed.

Code:
sudo apt-get remove phonon-backend-xine
Anyone had any luck with minitube?

Last edited by brooko; 11-30-2010 at 03:01 PM. Reason: updated
 
Old 12-02-2010, 04:43 AM   #2
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 555

Rep: Reputation: 75
sure you're on the right forum here? your "apt-get" makes me think you run Ubuntu ...
 
Old 12-02-2010, 06:08 PM   #3
skykooler
Member
 
Registered: Feb 2010
Distribution: Ubuntu
Posts: 84

Rep: Reputation: 17
I also have had this problem.

Quote:
sure you're on the right forum here? your "apt-get" makes me think you run Ubuntu ...
This is the code the Minitube page suggests.
 
Old 12-03-2010, 11:30 PM   #4
woodardjd
LQ Newbie
 
Registered: Nov 2010
Location: Oklahoma City, OK
Distribution: Slackware
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by skykooler View Post
I also have had this problem.



This is the code the Minitube page suggests.
True. But, that is a Debian, and derivatives, action call.
Since the OP stated he installed via sbopkg, one must assume he is running Slackware. Therefore, a Debian call won't work.
On Slackware you use package tools. pkgtool, installpkg. slackpkg and removepkg.
There are two xine packages delivered with Slackware. xine-lib and xine-ui.
Since KDE has no dependencies on xine, it should be safe to remove these packages.
 
Old 12-11-2010, 12:05 PM   #5
brooko
Member
 
Registered: Nov 2009
Posts: 35

Original Poster
Rep: Reputation: 0
My reference to the 'apt-get' line was merely pointing out that the minitube page suggests the removal of 'phonon-backend-xine' but that being a debian style package slackware probably bundles it all together in a phonon package, which i have installed.

Code:
root@slackbox:~# slackpkg file-search phonon

Looking for phonon in package list. Please wait... DONE

The list below shows the packages that contains "phonon" file.

[ installed ] - PyQt-4.7.3-x86_64-1
[ installed ] - phonon-4.4.1-x86_64-1
[ installed ] - qt-4.6.2_2d3d3e5-x86_64-1

You can search specific packages using "slackpkg search package".
Perhaps i should try removing phonon and see what happens? What uses phonon?
 
Old 12-11-2010, 05:31 PM   #6
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
Unfortunately I can't comment on the actual problem, and I don't use minitube (I really don't like it), but after seeing this thread originally I did try it out. It worked fine outside of KDE, so in theory it can work just fine. I can't comment on the original problem since I did not test it in KDE, and phonon is a KDE thing. When their advice is to remove a component of KDE, it suggests that the application was not written particularly well in terms of KDE compatibility...but I believe the problem rests in that phonon's xine backend would have to be recompiled after installing faad2, or phonon would have to be set to use another backend that supports MPEG-4 AAC audio (gstreamer with the correct plugins, maybe?). If you want to use minitube outside of KDE, it's easy. If you want to use it inside KDE, you will have to change your environment by either choosing a new backend for phonon (not sure how you do this, but I am sure it is in some KDE setting somewhere...though this may break something else) or recompiling phonon's xine backend.
 
Old 12-12-2010, 05:10 AM   #7
ppr:kut
Slackware Contributor
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 366

Rep: Reputation: 94
Whatever it is, it's not a phonon issue. Phonon is designed to be engine (codec) independent. Everything codec related is done in the engine that specified by the backend in use.
If you use phonon-xine and you can't play mp4/aac, then the error is with xine, not with phonon and not with phonon-xine.
Removing phonon-xine is a work-around, which forces phonon to use another backend, and hence another engine (like gstreamer, mplayer, vlc, whatever).
That can't simply be done with Slackware, since the backends are not split out in separate packages. However, phonon has a configuration module in system-settings where you can specify the backend you want to use (Computer Administration -> Multimedia -> Backend).
Beware however, that if the engine for whatever backend you choose doesn't support that codec either, switching the backend won't change anything.
 
Old 12-13-2010, 03:42 PM   #8
brooko
Member
 
Registered: Nov 2009
Posts: 35

Original Poster
Rep: Reputation: 0
Thanks for the info, i'm not actually running kde and don't have any of the kde packages installed. I'm running Gnome from GSB instead.
I'll have a look into phonon to see if a re-configure / re-build might help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Audacious won't play AAC AAC+, & no system sounds KDE 4.4.3 netcrawl Slackware 4 11-09-2014 10:22 PM
DVB-T tuner missing MPEG4-based channels mafiltenborg Linux - Hardware 24 12-05-2010 02:59 PM
XMMS AAC plugin - can't compile MPEG4IP, missing lid3tag Dag Linux - Software 2 03-02-2007 09:27 PM
Converting mpeg4 to mpeg2 (mpeg4 to dvd) conn-fused Linux - Software 9 03-04-2006 12:00 PM
aac/m4a support for JUK / decent aac music players reformedgeek Linux - Newbie 1 04-23-2005 03:52 PM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration