LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   [SBo] minitube - missing mpeg4 aac (http://www.linuxquestions.org/questions/slackware-14/%5Bsbo%5D-minitube-missing-mpeg4-aac-847513/)

brooko 11-30-2010 01:56 PM

[SBo] minitube - missing mpeg4 aac
 
Just installed minitube v1.1 via sbopkg. Video plays but there's no sound and i get the following error message *edit* actually nothing much happens no video or sound. It just displays the title of the videos in the list without playing.

Code:

Phonon error: "A required codec is missing. You need to install the following codec(s) to play this content: MPEG-4 AAC" 2
I have faad2 installed which is a "MPEG2 and MPEG 4 AAC decoder" but thats not listed as a dependency anyway, only QT >=4.5 which i have.

On the minitube home page it suggests removing xine phono backend if there's no sound, but i'm not even sure if this is installed.

Code:

sudo apt-get remove phonon-backend-xine
Anyone had any luck with minitube?

Ramurd 12-02-2010 03:43 AM

sure you're on the right forum here? your "apt-get" makes me think you run Ubuntu ...

skykooler 12-02-2010 05:08 PM

I also have had this problem.

Quote:

sure you're on the right forum here? your "apt-get" makes me think you run Ubuntu ...
This is the code the Minitube page suggests.

woodardjd 12-03-2010 10:30 PM

Quote:

Originally Posted by skykooler (Post 4178817)
I also have had this problem.



This is the code the Minitube page suggests.

True. But, that is a Debian, and derivatives, action call.
Since the OP stated he installed via sbopkg, one must assume he is running Slackware. Therefore, a Debian call won't work.
On Slackware you use package tools. pkgtool, installpkg. slackpkg and removepkg.
There are two xine packages delivered with Slackware. xine-lib and xine-ui.
Since KDE has no dependencies on xine, it should be safe to remove these packages.

brooko 12-11-2010 11:05 AM

My reference to the 'apt-get' line was merely pointing out that the minitube page suggests the removal of 'phonon-backend-xine' but that being a debian style package slackware probably bundles it all together in a phonon package, which i have installed.

Code:

root@slackbox:~# slackpkg file-search phonon

Looking for phonon in package list. Please wait... DONE

The list below shows the packages that contains "phonon" file.

[ installed ] - PyQt-4.7.3-x86_64-1
[ installed ] - phonon-4.4.1-x86_64-1
[ installed ] - qt-4.6.2_2d3d3e5-x86_64-1

You can search specific packages using "slackpkg search package".

Perhaps i should try removing phonon and see what happens? What uses phonon?

T3slider 12-11-2010 04:31 PM

Unfortunately I can't comment on the actual problem, and I don't use minitube (I really don't like it), but after seeing this thread originally I did try it out. It worked fine outside of KDE, so in theory it can work just fine. I can't comment on the original problem since I did not test it in KDE, and phonon is a KDE thing. When their advice is to remove a component of KDE, it suggests that the application was not written particularly well in terms of KDE compatibility...but I believe the problem rests in that phonon's xine backend would have to be recompiled after installing faad2, or phonon would have to be set to use another backend that supports MPEG-4 AAC audio (gstreamer with the correct plugins, maybe?). If you want to use minitube outside of KDE, it's easy. If you want to use it inside KDE, you will have to change your environment by either choosing a new backend for phonon (not sure how you do this, but I am sure it is in some KDE setting somewhere...though this may break something else) or recompiling phonon's xine backend.

ppr:kut 12-12-2010 04:10 AM

Whatever it is, it's not a phonon issue. Phonon is designed to be engine (codec) independent. Everything codec related is done in the engine that specified by the backend in use.
If you use phonon-xine and you can't play mp4/aac, then the error is with xine, not with phonon and not with phonon-xine.
Removing phonon-xine is a work-around, which forces phonon to use another backend, and hence another engine (like gstreamer, mplayer, vlc, whatever).
That can't simply be done with Slackware, since the backends are not split out in separate packages. However, phonon has a configuration module in system-settings where you can specify the backend you want to use (Computer Administration -> Multimedia -> Backend).
Beware however, that if the engine for whatever backend you choose doesn't support that codec either, switching the backend won't change anything.

brooko 12-13-2010 02:42 PM

Thanks for the info, i'm not actually running kde and don't have any of the kde packages installed. I'm running Gnome from GSB instead.
I'll have a look into phonon to see if a re-configure / re-build might help.


All times are GMT -5. The time now is 09:50 PM.