LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-10-2013, 03:50 PM   #1
Clementine Jam
LQ Newbie
 
Registered: Apr 2013
Location: Mogilev, BY
Distribution: Slackware
Posts: 17

Rep: Reputation: Disabled
Post [Request] Qt 5.x in /testing or /extra for Slackware 14.1


Qt 4.x is EOL soon and many projects migrating or planning to migrate on Qt5. So, i think that it would be a good choice to add Qt5 into -current branch for including Qt5 to Slackware 14.1.

Qt4 and Qt5 might be non-conflicting, if Qt5 to use a bit modified SlackBuild from Qt4

Code:
./configure \
  -confirm-license \
  -opensource \
  -prefix /usr/lib${LIBDIRSUFFIX}/qt5 \
  -fast \
...
Code:
# Link the shared libraries into /usr/lib:
( cd $PKG/usr/lib${LIBDIRSUFFIX}
  for file in qt5/lib/*.so* ; do
    ln -sf $file .
  done
)
Code:
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
( cd $PKG/usr/lib${LIBDIRSUFFIX}/qt5/lib/pkgconfig
  for file in *.pc ; do
    ( cd $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig ; ln -sf /usr/lib${LIBDIRSUFFIX}/qt5/lib/pkgconfig/$file . )
  done
)
and so on.

Please, add Qt5 to the Current branch!
 
Old 10-10-2013, 04:10 PM   #2
jon lee
Member
 
Registered: Jul 2013
Posts: 81

Rep: Reputation: Disabled
One of the big changes for Qt5 is support for gstreamer 1.0. Unfortunately neither Clementine or KDE support this ATM (although I suspect KDE will with the v5.0 release to match Qt). I don't remember which one but there is at least one alternative browser which requires gstreamer 1.0.

I know Qt4 included Qt3 support (I could find only two things which actually used it- the 'make xconfig' for kernel configuration, and K3b.. and the latest git of k3b dropped this dependency).

All in all, it will take some time for everything to migrate in this direction.
 
1 members found this post helpful.
Old 10-10-2013, 09:14 PM   #3
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Quote:
Originally Posted by Clementine Jam View Post
Please, add Qt5 to the Current branch!
Quote:
Originally Posted by jon lee View Post
...although I suspect KDE will with the v5.0 release to match Qt).
When you start talking KDE5 then you can talk qt5
 
1 members found this post helpful.
Old 10-10-2013, 09:33 PM   #4
jprzybylski
Member
 
Registered: Apr 2011
Location: Canada
Distribution: Slackware
Posts: 96

Rep: Reputation: 23
To be honest, I can't think of an application that requires qt5 at the moment, so it sounds more like a cool new technology that can live in a SlackBuild until stable software starts coming out that uses it.
 
1 members found this post helpful.
Old 10-10-2013, 11:31 PM   #5
jon lee
Member
 
Registered: Jul 2013
Posts: 81

Rep: Reputation: Disabled
Talking

At about the same time as Qt5 being used, I would like to have PyQt compiled against Python3. (It gives extra extensions that I need).
 
Old 10-11-2013, 02:49 AM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,195

Rep: Reputation: Disabled
Quote:
Originally Posted by jon lee View Post
At about the same time as Qt5 being used, I would like to have PyQt compiled against Python3. (It gives extra extensions that I need).
Since Slackware has only python2.7, it will be pretty hard to compile PyQt against python3.

Eric
 
1 members found this post helpful.
Old 10-11-2013, 02:55 AM   #7
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by Clementine Jam View Post
Qt4 and Qt5 might be non-conflicting, if Qt5 to use a bit modified SlackBuild from Qt4
Actually qt4 needs to be rebuilt (with changes) and a new package included for you to have both versions installed.

I've already gone through it here :-

http://www.linuxquestions.org/questi...-a-4175468237/

EDIT
Patch for qt5.Slackbuild for 5.1.1
Code:
--- qt5.SlackBuild.old  2013-07-13 09:22:00.000000000 +1000
+++ qt5.SlackBuild      2013-09-28 17:22:05.597624488 +1000
@@ -125,8 +125,6 @@
   -plugin-sql-sqlite \
   -dbus \
   -nomake examples \
-  -nomake demos \
-  -nomake docs \
   -no-separate-debug-info \
   -no-pch
   # No-precompiled-headers is ccache-friendly.

Last edited by wildwizard; 10-11-2013 at 02:59 AM.
 
Old 10-11-2013, 11:52 AM   #8
jon lee
Member
 
Registered: Jul 2013
Posts: 81

Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
Since Slackware has only python2.7, it will be pretty hard to compile PyQt against python3.

Eric
I know... but since we're talking about a pipe dream for Slack. 15 Most modern distros have already switched to Python 3. I'm not real sure of the advantages/dependencies of sticking with Python 2. I would do it myself except it's a huge chain (Qt, Python3, sip, PyQt, KDE...).
 
Old 10-11-2013, 12:24 PM   #9
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
Python 3 is essentially a different language than 2. It is not easy to switch from 2 to 3. Similarly is C++ to Java. We can install the other in additional.
 
Old 10-13-2013, 04:11 PM   #10
jon lee
Member
 
Registered: Jul 2013
Posts: 81

Rep: Reputation: Disabled
I'm not aware of many (if any) direct dependencies on python2 in Slackware.
KDE has an indirect dependency on python but the version depends on that which was used to compile PyQt.

I just came across this problem again today trying to install Openshot. Requires pygoocanvas which requires pycairo which requires python3. (and, no, the py2cairo is not sufficient).
bash-4.2# python setup.py
Error: Python >= (3, 0) is required

Most everything is migrating towards python3. I also need it for the kxstudio plugins.
Ubuntu already employs it.
And, Qt5 and python3 would be a natural together.




(Edit: Well, scratch that. Just had to use the pygoocanvas .14 tarball instead of the latest git
http://i102.photobucket.com/albums/m...psef2098e2.png

Last edited by jon lee; 10-13-2013 at 05:51 PM.
 
Old 10-13-2013, 06:23 PM   #11
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by jon lee View Post
I'm not aware of many (if any) direct dependencies on python2 in Slackware.
Possibly not many requires Python 2, but absolutely nothing (in slackware-current) requires Python 3. So why should 3 replace 2? BTW, I know at least hplip depends on Python 2.

Quote:
Originally Posted by jon lee View Post
I just came across this problem again today trying to install Openshot. Requires pygoocanvas which requires pycairo which requires python3. (and, no, the py2cairo is not sufficient).
bash-4.2# python setup.py
Error: Python >= (3, 0) is required
I've never heard of Openshot. Why should its dependency added to slackware? -- Just downloaded the latest source (openshot-1.4.3). The README says it requires Python 2.5+, and it's Python source is incompatible with Python 3.

Quote:
Originally Posted by jon lee View Post
Most everything is migrating towards python3.
Yes. Your wording is precise -- "is migrating", not "has migrated".
AFAIK, e.g. the physics community is far from ready for Python 3. Some fundamental softwares are even just matured on Python 2. So, what's the exact meaning of "everything" here?

Quote:
Originally Posted by jon lee View Post
I also need it for the kxstudio plugins.
You are free to install your dependencies.

Quote:
Originally Posted by jon lee View Post
Ubuntu already employs it.
Slackware does not have to be the same as Ubuntu. The former will never be a re-branded redistribution of Debian.
 
Old 10-13-2013, 07:00 PM   #12
mattallmill
Member
 
Registered: Nov 2009
Location: Salina,Kansas
Distribution: Slackware64-current
Posts: 192

Rep: Reputation: 30
Quote:
Originally Posted by guanx View Post
Slackware does not have to be the same as Ubuntu. The former will never be a re-branded redistribution of Debian.
I, for one, am glad of that. IMO, there are too many things which do not work right in Ubuntu for me to even give it a serious moment's thought.

Regards,

Matt
 
Old 10-14-2013, 05:44 AM   #13
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,195

Rep: Reputation: Disabled
Quote:
Originally Posted by jon lee View Post
I'm not aware of many (if any) direct dependencies on python2 in Slackware.
KDE has an indirect dependency on python but the version depends on that which was used to compile PyQt.

I just came across this problem again today trying to install Openshot. Requires pygoocanvas which requires pycairo which requires python3. (and, no, the py2cairo is not sufficient).
bash-4.2# python setup.py
Error: Python >= (3, 0) is required

Most everything is migrating towards python3. I also need it for the kxstudio plugins.
Ubuntu already employs it.
And, Qt5 and python3 would be a natural together.

(Edit: Well, scratch that. Just had to use the pygoocanvas .14 tarball instead of the latest git
http://i102.photobucket.com/albums/m...psef2098e2.png
Next time, check SlackBuilds.org first. They have a SlackBuild for OpenShot 1.4.3 on Slackware 14.0, including all the required dependencies. Building OpenShot on Slackware 14.0 using sbopkg would be dead easy.

And remember - Slackware's tools do not require Python 3. And the fact that there is no Python 3 SlackBuild on slackbuilds.org is a good indication that nobody has found a need for Python 3 yet (or a tool that requires Python 3)...

Eric
 
1 members found this post helpful.
Old 10-14-2013, 05:50 AM   #14
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Quote:
Originally Posted by Alien Bob View Post
And remember - Slackware's tools do not require Python 3. And the fact that there is no Python 3 SlackBuild on slackbuilds.org is a good indication that nobody has found a need for Python 3 yet (or a tool that requires Python 3)...

Eric
Amen
 
Old 10-14-2013, 06:08 AM   #15
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,413

Rep: Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857Reputation: 857
ehm, actually there is...

but the only thing I use it with is the newer lxc (and is not even essential).

Last edited by ponce; 10-14-2013 at 06:09 AM.
 
  


Reply

Tags
slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
k3b localization -- Request for testing markush Slackware 8 07-02-2013 08:36 AM
Request for Testing: bash-completion 2.0 rworkman Slackware 15 01-31-2013 04:19 AM
Question List: Core, Extra and Testing, datebase and Powerpill vs Pacman culaterout Arch 2 01-25-2010 07:45 AM
[TESTING REQUEST] Xorg in -current (yes, again) rworkman Slackware 171 10-31-2009 04:49 PM
Request for Testing - hal-0.5.11rc1 in -current rworkman Slackware 11 03-18-2008 01:23 PM


All times are GMT -5. The time now is 03:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration